summaryrefslogtreecommitdiff
path: root/gui-libs/gtk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-21 05:13:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-21 05:13:39 +0100
commitc0e834f207174ee62c093753cea0176c947a9ba1 (patch)
treee66c65a8f13e7813a0f5aba59befb6b1c70b10de /gui-libs/gtk
parent592a577f4a904833f78a30dae83e83fa2fbcc970 (diff)
gentoo auto-resync : 21:09:2023 - 05:13:39
Diffstat (limited to 'gui-libs/gtk')
-rw-r--r--gui-libs/gtk/Manifest2
-rw-r--r--gui-libs/gtk/gtk-4.12.2.ebuild228
2 files changed, 230 insertions, 0 deletions
diff --git a/gui-libs/gtk/Manifest b/gui-libs/gtk/Manifest
index e48a5d65017e..505fb175742f 100644
--- a/gui-libs/gtk/Manifest
+++ b/gui-libs/gtk/Manifest
@@ -1,5 +1,7 @@
DIST gtk-4.10.5.tar.xz 16403464 BLAKE2B 9ca10de5e178e0b3e34fdf5f6126fc89e914a06e60c1c160b6273a5eb10b60e362e3db27af6012d2ea92452bb5787e6784e11d1f15a4ff284b04bbf9750ff91a SHA512 7ca1d2cabbeb6020613fcb11f57b8161f38337a6c3bc3572365dd642af9498fad0f5b2fc0a2419e06567d541e62e67b3d1087ab9bd3e756363052b2f7b366fde
DIST gtk-4.12.1.tar.xz 16924668 BLAKE2B c59d944de510e1c024564c320d44e15b5766f48bd03532944f01ae91111eb909d535011e07f871b3bef17213575acb13c03108cf1bba82987fc15f7cebcc0b83 SHA512 5a893d3d855b5f1cf5b2e3c1c5178cc25e4165288f1ecc257d8af5ac1f94fc70fce7be34cf4b0292acd6652e544dd989c0065c1287623b6d4a115a9974a441c9
+DIST gtk-4.12.2.tar.xz 16942832 BLAKE2B a4916d1b6fd6669422c2b18db70f6cc318ec330baafd4a6a9ceb4d37e7a9fd1206131a5b146ff33d4ac2c5f1e5d879f77026f7bd136e082630960a82212f4274 SHA512 5373a3c6bf434644b97c955207c80833c8f77402baca6a91b0f467b5a2fea1474e6913104ee764d61df19a8ca98c117580ad54a95cfab64113e26e8bdc3ff095
EBUILD gtk-4.10.5.ebuild 5853 BLAKE2B bd82b2b19208e582fb47c6577dc7218ea3ca2f430d6de3c81fd723d775a4ab76d58b72819e4fb8f2b9e440dc59cf8273a03577bb37455f9bf344ebfc706dda24 SHA512 78cd05a61afbd1a4408f405fad73be83da94904b08a4b9cecd413e03b569a1dc234e43597a36896910eb3cb52e54749ab3a079042f11d6e1b60589512c2004c3
EBUILD gtk-4.12.1.ebuild 5908 BLAKE2B 5568f07edef3d423f87845ee10df51d9f0362fd25b02fca472a53e89336f78c5b3d7b85fda5f005f59b67e9301a72ece9530ea08fdb04435f526977d94f3aa90 SHA512 77f12771944b3c403bb613060d24cee9f5f426d15e9057cf45ab6b292d898612db292f3fcbde3b84b978e29f01b747f0e099d39f00269440df02696514e4b4b8
+EBUILD gtk-4.12.2.ebuild 5908 BLAKE2B 5568f07edef3d423f87845ee10df51d9f0362fd25b02fca472a53e89336f78c5b3d7b85fda5f005f59b67e9301a72ece9530ea08fdb04435f526977d94f3aa90 SHA512 77f12771944b3c403bb613060d24cee9f5f426d15e9057cf45ab6b292d898612db292f3fcbde3b84b978e29f01b747f0e099d39f00269440df02696514e4b4b8
MISC metadata.xml 775 BLAKE2B a679a63b050be837319131924b4196dc7fdd2a1dcbca4b099eebc8550db3120dc8afe2b743acd68ce386fda7e4bd3af1eb2eb11d333542e1dbcc8b8a68c6c919 SHA512 15d8dc9c2701575b59d596cc10b1ca18691d10c3a418989eece698650e82a34720bea9d53a4ca4aa83745ce5d254cec5438f1ab10093ab2f765e77d0c9c24433
diff --git a/gui-libs/gtk/gtk-4.12.2.ebuild b/gui-libs/gtk/gtk-4.12.2.ebuild
new file mode 100644
index 000000000000..129a4ca40173
--- /dev/null
+++ b/gui-libs/gtk/gtk-4.12.2.ebuild
@@ -0,0 +1,228 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+inherit gnome.org gnome2-utils meson optfeature python-any-r1 toolchain-funcs virtualx xdg
+
+DESCRIPTION="GTK is a multi-platform toolkit for creating graphical user interfaces"
+HOMEPAGE="https://www.gtk.org/ https://gitlab.gnome.org/GNOME/gtk/"
+
+LICENSE="LGPL-2+"
+SLOT="4"
+IUSE="aqua broadway cloudproviders colord cups examples ffmpeg gstreamer +introspection sysprof test vulkan wayland +X cpu_flags_x86_f16c"
+REQUIRED_USE="
+ || ( aqua wayland X )
+ test? ( introspection )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.76.0:2
+ >=x11-libs/cairo-1.17.6[aqua?,glib,svg(+),X?]
+ >=x11-libs/pango-1.50.0[introspection?]
+ >=dev-libs/fribidi-1.0.6
+ >=media-libs/harfbuzz-2.6.0:=
+ >=x11-libs/gdk-pixbuf-2.30:2[introspection?]
+ media-libs/libpng:=
+ media-libs/tiff:=
+ media-libs/libjpeg-turbo:=
+ >=media-libs/libepoxy-1.4[egl,X(+)?]
+ >=media-libs/graphene-1.10.0[introspection?]
+ app-text/iso-codes
+ x11-misc/shared-mime-info
+
+ cloudproviders? ( net-libs/libcloudproviders )
+ colord? ( >=x11-misc/colord-0.1.9:0= )
+ cups? ( >=net-print/cups-2.0 )
+ ffmpeg? ( media-video/ffmpeg:= )
+ gstreamer? (
+ >=media-libs/gst-plugins-bad-1.12.3:1.0
+ >=media-libs/gst-plugins-base-1.12.3:1.0[opengl]
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1.76:= )
+ vulkan? ( media-libs/vulkan-loader:= )
+ wayland? (
+ >=dev-libs/wayland-1.21.0
+ >=dev-libs/wayland-protocols-1.31
+ media-libs/mesa[wayland]
+ >=x11-libs/libxkbcommon-0.2
+ )
+ X? (
+ >=app-accessibility/at-spi2-core-2.46.0
+ media-libs/fontconfig
+ media-libs/mesa[X(+)]
+ x11-libs/libX11
+ >=x11-libs/libXi-1.8
+ x11-libs/libXext
+ >=x11-libs/libXrandr-1.5
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXdamage
+ x11-libs/libXinerama
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ X? ( x11-base/xorg-proto )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-update-icon-cache-3
+"
+# librsvg for svg icons (PDEPEND to avoid circular dep), bug #547710
+PDEPEND="
+ gnome-base/librsvg
+ >=x11-themes/adwaita-icon-theme-3.14
+"
+BDEPEND="
+ dev-libs/gobject-introspection-common
+ introspection? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ )
+ dev-python/docutils
+ dev-libs/glib
+ >=dev-util/gdbus-codegen-2.48
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+ test? (
+ dev-libs/glib:2
+ media-fonts/cantarell
+ wayland? ( dev-libs/weston[headless] )
+ )
+"
+
+python_check_deps() {
+ python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]" || return
+}
+
+pkg_setup() {
+ use introspection && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ # Nothing should use gtk4-update-icon-cache and an unversioned one is shipped by dev-util/gtk-update-icon-cache
+ sed -i \
+ -e '/gtk4-update-icon-cache/d' \
+ docs/reference/gtk/meson.build \
+ tools/meson.build \
+ || die
+
+ # The border-image-excess-size.ui test is known to fail on big-endian platforms
+ # See https://gitlab.gnome.org/GNOME/gtk/-/issues/5904
+ if [[ $(tc-endian) == big ]]; then
+ sed -i \
+ -e "/border-image-excess-size.ui/d" \
+ -e "/^xfails =/a 'border-image-excess-size.ui'," \
+ testsuite/reftests/meson.build || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ # GDK backends
+ $(meson_use X x11-backend)
+ $(meson_use wayland wayland-backend)
+ $(meson_use broadway broadway-backend)
+ -Dwin32-backend=false
+ $(meson_use aqua macos-backend)
+
+ # Media backends
+ $(meson_feature ffmpeg media-ffmpeg)
+ $(meson_feature gstreamer media-gstreamer)
+
+ # Print backends
+ -Dprint-cpdb=disabled
+ $(meson_feature cups print-cups)
+
+ # Optional dependencies
+ $(meson_feature vulkan)
+ $(meson_feature cloudproviders)
+ $(meson_feature sysprof)
+ -Dtracker=disabled # tracker3 is not packaged in Gentoo yet
+ $(meson_feature colord)
+ # Expected to fail with GCC < 11
+ # See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71993
+ $(meson_feature cpu_flags_x86_f16c f16c)
+
+ # Introspection
+ $(meson_feature introspection)
+
+ # Documentation
+ -Ddocumentation=false # we ship pregenerated API docs from tarball
+ -Dscreenshots=false
+ -Dman-pages=true
+
+ # Demos, examples, and tests
+ -Ddemo-profile=default
+ $(meson_use examples build-demos)
+ $(meson_use test build-testsuite)
+ $(meson_use examples build-examples)
+ -Dbuild-tests=false
+ )
+ meson_src_configure
+}
+
+src_test() {
+ "${BROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/gtk" || die
+
+ if use X; then
+ einfo "Running tests under X"
+ GSETTINGS_SCHEMA_DIR="${S}/gtk" virtx meson_src_test --setup=x11 --timeout-multiplier=130
+ fi
+
+ if use wayland; then
+ einfo "Running tests under Weston"
+
+ export XDG_RUNTIME_DIR="$(mktemp -p $(pwd) -d xdg-runtime-XXXXXX)"
+
+ weston --backend=headless-backend.so --socket=wayland-5 --idle-time=0 &
+ compositor=$!
+ export WAYLAND_DISPLAY=wayland-5
+
+ GSETTINGS_SCHEMA_DIR="${S}/gtk" meson_src_test --setup=wayland --timeout-multiplier=130
+
+ exit_code=$?
+ kill ${compositor}
+ fi
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/gtk-doc/html
+ # This will install API docs specific to X11 and wayland regardless of USE flags, but this is intentional
+ doins -r "${S}"/docs/reference/{gtk/gtk4,gsk/gsk4,gdk/gdk4{,-wayland,-x11}}
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version "app-text/evince"; then
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your settings.ini file."
+ fi
+
+ if use examples ; then
+ optfeature "syntax highlighting in gtk4-demo" app-text/highlight
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}