summaryrefslogtreecommitdiff
path: root/gui-libs/gtk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-06 03:38:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-06 03:38:26 +0100
commit0cfdfb9b75c154c98f3963d4a002425218e29efc (patch)
treecb47769d0bed36a09e21390122592c6987caebd1 /gui-libs/gtk
parent50c291a3ace58006f8fa9cf44a36f6e42bff2b54 (diff)
gentoo auto-resync : 06:06:2023 - 03:38:26
Diffstat (limited to 'gui-libs/gtk')
-rw-r--r--gui-libs/gtk/Manifest2
-rw-r--r--gui-libs/gtk/gtk-4.10.4.ebuild216
2 files changed, 218 insertions, 0 deletions
diff --git a/gui-libs/gtk/Manifest b/gui-libs/gtk/Manifest
index 6e734aba0bfc..d3f15c4305b5 100644
--- a/gui-libs/gtk/Manifest
+++ b/gui-libs/gtk/Manifest
@@ -2,6 +2,8 @@ AUX gtk-4.10.3-black-screen-rendering.patch 1412 BLAKE2B ce5b99591f6eca170cedbad
AUX gtk-4.10.3-crash-css-color.patch 3953 BLAKE2B 53f6a898d26549ec71b437b9a3a2873262989e2eef402a478667b74d43eedd1d53a8e78df522be483d91cb664b90cc6ac376db9e527a8dc05227dbdd778931d8 SHA512 7cbbe18118bcffc0452b2ade9542cd8518337844a57ac4e98838d698533be82c25ce619e4b311987e2bb76cc107201fa392b2b32a5ddb8534e175a06584d05bf
AUX gtk-4.10.3-list-delete.patch 3805 BLAKE2B 639968b281aad549f32adcda70e651ca739e0880390790cd8f5b53eb2bcc28cbfbae5f7ea8310c72e9489f5fc92811a5f71e3821f2deae6bea84996e8bb1fc53 SHA512 218c3c3082404d9495e09fa9a5f38eea6eb6ffbc9b88dedb78ba3c594ee82c92d361e485ca808775e4b0bdfad6091a473d92da2bf4c8ce0a796499384147d42c
DIST gtk-4.10.3.tar.xz 20483468 BLAKE2B dcc845e567e3f921f1b479ac2b40b45922725452656d08e95579f3dd8d521261cedf73bf998c781e42318d0c2253967765a4bcb6223db4f29d45648bc524f843 SHA512 aac4703f9c135271febdd373b24995dabcd08fb0cea2d6014c812f2839ae88926c1939ddcc64ab9728ba3248a1f58260ce73fa6ef5679e54dbb798021adfa324
+DIST gtk-4.10.4.tar.xz 20526652 BLAKE2B 12874d90f9f48f22d57c53cf035065726e5bbd9a701cacf390acad6889fd86dbc3c4cb2f8f9a0690d9375935a7e3a8685211283814dbbfb28c6c08fd159529c5 SHA512 0c5db3af72227977e11fea3adddec1321b82bcace3c3d10a7c914b8d98b0bdb7994084c0a9e883b24815038bf4a0efe1eb1c4ff79e6838e83cadb6ddf2a1239f
EBUILD gtk-4.10.3-r1.ebuild 5946 BLAKE2B b57782c9bf65e4ef1273a7beda824be649658a8f791af0cda90005f7de8417765c0c6bfa5f610148e8849b88e1d5c300480a09a94704f96343e133b72b453e0c SHA512 04f0d553976b4cdad1df78270ebf558ed15710535203150464888a5661f537ce7ce8c99df0dc03d0813f31677fe573c585b85e5f5b4b8de30e68064f789bbeff
EBUILD gtk-4.10.3.ebuild 5796 BLAKE2B 0a9b1d7f5b594c9c882ca763facfea5b4ac0d3621f12a1c0375b28e0b4a9defd006f9cf589793376b6406168c7de3352c9c04bd34a9879e92ccc27fd357596a7 SHA512 72012e0c3adec57d0da2f3da75e55f76b0762f528b3172cd02c26081e380dd4a191a75a15415ecfad89fd04926e8195c8189333bb62a9c7be8348e78f7930501
+EBUILD gtk-4.10.4.ebuild 5512 BLAKE2B df2978d3f135e8b2348c404aceca2297917987954dc450e7409ffb8a43c4d3a573549dc57b7dd6993ab83142f7632ee830fef1ecc6fa4807d54f39fd558da97f SHA512 47642cf067b0f8dff2a3a6ac45639fd3fb9e325edbf0d085f5eb020909a5470df6dee4745c8bf3e03f96958658ea799d2f4575f6f490ce13ab38c574db2e8553
MISC metadata.xml 775 BLAKE2B a679a63b050be837319131924b4196dc7fdd2a1dcbca4b099eebc8550db3120dc8afe2b743acd68ce386fda7e4bd3af1eb2eb11d333542e1dbcc8b8a68c6c919 SHA512 15d8dc9c2701575b59d596cc10b1ca18691d10c3a418989eece698650e82a34720bea9d53a4ca4aa83745ce5d254cec5438f1ab10093ab2f765e77d0c9c24433
diff --git a/gui-libs/gtk/gtk-4.10.4.ebuild b/gui-libs/gtk/gtk-4.10.4.ebuild
new file mode 100644
index 000000000000..045fb0a4744d
--- /dev/null
+++ b/gui-libs/gtk/gtk-4.10.4.ebuild
@@ -0,0 +1,216 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit gnome.org gnome2-utils meson optfeature python-any-r1 virtualx xdg
+
+DESCRIPTION="GTK is a multi-platform toolkit for creating graphical user interfaces"
+HOMEPAGE="https://www.gtk.org/ https://gitlab.gnome.org/GNOME/gtk/"
+
+LICENSE="LGPL-2+"
+SLOT="4"
+IUSE="aqua broadway cloudproviders colord cups examples ffmpeg gstreamer +introspection sysprof test vulkan wayland +X cpu_flags_x86_f16c"
+REQUIRED_USE="
+ || ( aqua wayland X )
+ test? ( introspection )
+"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.72.0:2
+ >=x11-libs/cairo-1.17.6[aqua?,glib,svg(+),X?]
+ >=x11-libs/pango-1.50.0[introspection?]
+ >=dev-libs/fribidi-1.0.6
+ >=media-libs/harfbuzz-2.6.0:=
+ >=x11-libs/gdk-pixbuf-2.30:2[introspection?]
+ media-libs/libpng:=
+ media-libs/tiff:=
+ media-libs/libjpeg-turbo:=
+ >=media-libs/libepoxy-1.4[egl,X(+)?]
+ >=media-libs/graphene-1.10.0[introspection?]
+ app-text/iso-codes
+ x11-misc/shared-mime-info
+
+ cloudproviders? ( net-libs/libcloudproviders )
+ colord? ( >=x11-misc/colord-0.1.9:0= )
+ cups? ( >=net-print/cups-2.0 )
+ ffmpeg? ( media-video/ffmpeg:= )
+ gstreamer? (
+ >=media-libs/gst-plugins-bad-1.12.3:1.0
+ >=media-libs/gst-plugins-base-1.12.3:1.0[opengl]
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1.72:= )
+ vulkan? ( media-libs/vulkan-loader:= )
+ wayland? (
+ >=dev-libs/wayland-1.21.0
+ >=dev-libs/wayland-protocols-1.25
+ media-libs/mesa[wayland]
+ >=x11-libs/libxkbcommon-0.2
+ )
+ X? (
+ >=app-accessibility/at-spi2-core-2.46.0
+ media-libs/fontconfig
+ media-libs/mesa[X(+)]
+ x11-libs/libX11
+ >=x11-libs/libXi-1.8
+ x11-libs/libXext
+ >=x11-libs/libXrandr-1.5
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXdamage
+ x11-libs/libXinerama
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ X? ( x11-base/xorg-proto )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-update-icon-cache-3
+"
+# librsvg for svg icons (PDEPEND to avoid circular dep), bug #547710
+PDEPEND="
+ gnome-base/librsvg
+ >=x11-themes/adwaita-icon-theme-3.14
+"
+BDEPEND="
+ dev-libs/gobject-introspection-common
+ introspection? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ )
+ dev-python/docutils
+ >=dev-util/gdbus-codegen-2.48
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+ test? (
+ dev-libs/glib:2
+ media-fonts/cantarell
+ wayland? ( dev-libs/weston[headless] )
+ )
+"
+
+python_check_deps() {
+ python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]" || return
+}
+
+pkg_setup() {
+ use introspection && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ # Nothing should use gtk4-update-icon-cache and an unversioned one is shipped by dev-util/gtk-update-icon-cache
+ sed -i \
+ -e '/gtk4-update-icon-cache/d' \
+ docs/reference/gtk/meson.build \
+ tools/meson.build \
+ || die
+}
+
+src_configure() {
+ local emesonargs=(
+ # GDK backends
+ $(meson_use X x11-backend)
+ $(meson_use wayland wayland-backend)
+ $(meson_use broadway broadway-backend)
+ -Dwin32-backend=false
+ $(meson_use aqua macos-backend)
+
+ # Media backends
+ $(meson_feature ffmpeg media-ffmpeg)
+ $(meson_feature gstreamer media-gstreamer)
+
+ # Print backends
+ -Dprint-cpdb=disabled
+ $(meson_feature cups print-cups)
+
+ # Optional dependencies
+ $(meson_feature vulkan)
+ $(meson_feature cloudproviders)
+ $(meson_feature sysprof)
+ -Dtracker=disabled # tracker3 is not packaged in Gentoo yet
+ $(meson_feature colord)
+ # Expected to fail with GCC < 11
+ # See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71993
+ $(meson_feature cpu_flags_x86_f16c f16c)
+
+ # Documentation and introspection
+ -Dgtk_doc=false # we ship pregenerated API docs from tarball
+ -Dupdate_screenshots=false
+ -Dman-pages=true
+ $(meson_feature introspection)
+
+ # Demos and binaries
+ $(meson_use test build-testsuite)
+ $(meson_use examples build-examples)
+ $(meson_use examples demos)
+ -Dbuild-tests=false
+ )
+ meson_src_configure
+}
+
+src_test() {
+ "${BROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/gtk" || die
+
+ if use X; then
+ einfo "Running tests under X"
+ GSETTINGS_SCHEMA_DIR="${S}/gtk" virtx meson_src_test --setup=x11 --timeout-multiplier=130
+ fi
+
+ if use wayland; then
+ einfo "Running tests under Weston"
+
+ export XDG_RUNTIME_DIR="$(mktemp -p $(pwd) -d xdg-runtime-XXXXXX)"
+
+ weston --backend=headless-backend.so --socket=wayland-5 --idle-time=0 &
+ compositor=$!
+ export WAYLAND_DISPLAY=wayland-5
+
+ GSETTINGS_SCHEMA_DIR="${S}/gtk" meson_src_test --setup=wayland --timeout-multiplier=130
+
+ exit_code=$?
+ kill ${compositor}
+ fi
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/gtk-doc/html
+ # This will install API docs specific to X11 and wayland regardless of USE flags, but this is intentional
+ doins -r "${S}"/docs/reference/{gtk/gtk4,gsk/gsk4,gdk/gdk4{,-wayland,-x11}}
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version "app-text/evince"; then
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your settings.ini file."
+ fi
+
+ if use examples ; then
+ optfeature "syntax highlighting in gtk4-demo" app-text/highlight
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}