summaryrefslogtreecommitdiff
path: root/gui-libs/gtk-layer-shell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /gui-libs/gtk-layer-shell
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'gui-libs/gtk-layer-shell')
-rw-r--r--gui-libs/gtk-layer-shell/Manifest2
-rw-r--r--gui-libs/gtk-layer-shell/gtk-layer-shell-0.6.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/gui-libs/gtk-layer-shell/Manifest b/gui-libs/gtk-layer-shell/Manifest
index 480b1cd68552..ef816b96735e 100644
--- a/gui-libs/gtk-layer-shell/Manifest
+++ b/gui-libs/gtk-layer-shell/Manifest
@@ -1,3 +1,5 @@
DIST gtk-layer-shell-0.1.0.tar.xz 34580 BLAKE2B db815d711e53485e00de2e0b7d238f6c66ddac9ca790d5f31c44eed965ad01ee07392d27552ae21bb1eab4905cc1d5f7dad9c10fd059afb43ba85c7ea1af2aa5 SHA512 3788559405a495d43279b20b9d64e1fb0fb9be4125eb3011a623565938246310c2e81cb6d52db111e42a9cd0739bb273ccf7fcb7c52db8b74a1e44108e061c6d
+DIST gtk-layer-shell-0.6.0.tar.gz 133047 BLAKE2B cbfc5f2ae355f1308a21d09bdaf925774223179d310b752c2540666b691a0be4c45c740f79c7a02877c95bcc31293f59643938e80c38687f0f3805534af93ab4 SHA512 ca5367b5f1637a07c28c772e79e5ac84219ff069091077f83c5edbc88be084538a925b3c76e6cc9dcd8d2826ae340b79605875e87209ee4f4d5e27dc4e93a523
EBUILD gtk-layer-shell-0.1.0-r1.ebuild 852 BLAKE2B c4d2823e3a8d4b33b598c029d4e56db888e61b071c70b8f1706833b8dd0cfa3492dcdcfe05cbd7025255e304004fb2503d496d5e5ee1ba9168e4efcd92e5fa7c SHA512 744fb57920dc4b7b3567c8ba8d6694308694bdfc4868ab10c523c6561096a7c2e4f05420df7ea9f13bfe0c2d82ce94b804f682abbff7f1db85ecc95a8dbd79ba
+EBUILD gtk-layer-shell-0.6.0.ebuild 1091 BLAKE2B b0b89e0002cf09bbb662a794b5999ae52d4fda36053caa2a2832292fdb6c85f22fb89bf7a51884ed61f2da1c6b6fdee59db24955745547d1f8bd27eeb13d0642 SHA512 bff868b5e3f74faf63d3ede160401772f4fdadb84d5f0b7647f1c52cb37ca1310ab492272852071d2ecbc5f26ebff03ab02a655fb3a9ed93398fa81950080f80
MISC metadata.xml 335 BLAKE2B f06a1477c07ecc8f5a6941a88638f4a9ef96ba0567a5b4a5e7f4265491f904e390206c8e6b3af595cc2c0b6d0341a0753a19538e44346e8469d7f0aa69ec1b95 SHA512 e8d6a2f35fe0ce36274a8d0dd5aed3f30ce3177f584bc55e9e7cc5bd5cb80a2d7ce06791766d8d43c33b34a791d30e082cdebef5bafd1f1faa0a10a07a36967a
diff --git a/gui-libs/gtk-layer-shell/gtk-layer-shell-0.6.0.ebuild b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.6.0.ebuild
new file mode 100644
index 000000000000..5273f2c8acd0
--- /dev/null
+++ b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit meson python-any-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wmww/${PN}"
+else
+ SRC_URI="https://github.com/wmww/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Library to create desktop components for Wayland using the Layer Shell protocol"
+HOMEPAGE="https://github.com/wmww/gtk-layer-shell"
+
+LICENSE="MIT-with-advertising LGPL-3+"
+SLOT="0"
+IUSE="examples gtk-doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=x11-libs/gtk+-3.24.26:3[introspection,wayland]
+ >=dev-libs/wayland-1.10.0
+ >=dev-libs/wayland-protocols-1.16
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+ test? ( ${PYTHON_DEPS} )
+"
+
+src_configure() {
+ # Note: next release makes introspection optional
+ local emesonargs=(
+ $(meson_use examples)
+ $(meson_use gtk-doc docs)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}