summaryrefslogtreecommitdiff
path: root/gui-libs/egl-wayland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /gui-libs/egl-wayland
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'gui-libs/egl-wayland')
-rw-r--r--gui-libs/egl-wayland/Manifest2
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.7.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/gui-libs/egl-wayland/Manifest b/gui-libs/egl-wayland/Manifest
index 4f3c3b98fc04..3d568e27e56d 100644
--- a/gui-libs/egl-wayland/Manifest
+++ b/gui-libs/egl-wayland/Manifest
@@ -1,5 +1,7 @@
AUX 10_nvidia_wayland.json 115 BLAKE2B b10206c742e8966d1192b9b0604137e6b296d2be74a437841c63844c0716343578b11565a34fb4c534d5908c0b5775305581b68039a6ff9ed7421c9d385a2b7a SHA512 1a611ac0fc2762d94661efc28fa58d57a821185afa7589158d1b8d503bd7361ba1b5029302550134ed1787c2bf90e2ea8afbf3bdefbfe268d8cf13d2f340fb47
AUX egl-wayland-1.1.6-remove-werror.patch 251 BLAKE2B 12a14b185f9b1cb3a42226708642f5b57c2b0eb64d81c96438ee24ac45b950ba588591194648fc8e64e3aa8d2fda9ba2dba63a2f78fc22c00a14d56403bf6839 SHA512 c6c3c4d4f776f44d642d51ab2eed44a0388558b43f2c4c894b6d19bdef40b8a646be43b6b356a3ffa0297e36a48122ef057265db68a8717020abe30906bc8f28
DIST egl-wayland-1.1.6.tar.gz 48674 BLAKE2B 66f58d4b841ebaaec6c0711e0dae0b3c774a7b0206f9cfd4d9e94a2c05688d563fddbbf9a60247980df00c3c493147e292bc536e2eb56de962f3b34c6215e026 SHA512 81fd3be3f49ad012efd31189d85666e869653f1f4004de4103f4ad13b7fda036cef432d1e30e33664ae423092dc1b86cfd2773d6542bb09d7a74720ba14e0fa4
+DIST egl-wayland-1.1.7.tar.gz 48681 BLAKE2B eebbd0e36045c50b39ef70292156f5cd137a51af2169b56a35d318d90ade3d4a5b94206d86246d52fda0c6c093ff25e389b1a3ccbe60595dc9661d199e30f33b SHA512 edc81d9f2c617587044d5f9d35b3e355db8544e8fa1d861c1b92a5a11bc1af7d994ca8abd49ce6f462a1971f20296b4c757bdf1df0d2bfc981cdafaa839f12af
EBUILD egl-wayland-1.1.6.ebuild 1660 BLAKE2B a2dc305faacb372b25c49692081f9f8ce3c441405388abc8b231d89703c6e136e53eca1b32770a1d9f3c39a56cb32c13cc07b75fc3c94168bb28fe17e7465383 SHA512 83952f79b5f07f5a709268d37e09e465befa617091e8cd9b6aba1e3208e3441df0ab908cc5366ca9cb8ddafc5ec830d69bad86bcb893ff47077a725a546fe34f
+EBUILD egl-wayland-1.1.7.ebuild 1668 BLAKE2B e30178a9c6b007e9c3d8e32a3a4c0747d95e433dc5ce5c64b240e07ff5b475b86455e0292bd1f1c14795e688b0f48a9a606b1b898a3fb4133bea32e10f45ca4e SHA512 811afc180dda6e110e69c54d5b1bbdb3c9088ca8820d4e5916b960b96548bc90b7fcda57f0b0150afcab377ec705ebf1dfe440b6953dd3739e2511cb3714d31c
MISC metadata.xml 477 BLAKE2B 406298dc8bb1aabdb3f5dbe507846089c4dfeee1bf4db6e76624c33b369b2f3afd485c91020073aaaf09bc0a3500c0ca6f991b52325478e302c4c7134f009f74 SHA512 cc1b9b630d0751801cb834dafe15003eb370f3984ffeec7d5515eb2972587a5b8bb72b03dabb1e27dcbfc6c509e6974713d0fdcfcb2c96c5737f19e9ebe2ac18
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.7.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.7.ebuild
new file mode 100644
index 000000000000..01dea054a2c3
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic meson
+
+DESCRIPTION="EGLStream-based Wayland external platform (for NVIDIA)"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland"
+SRC_URI="https://github.com/NVIDIA/egl-wayland/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/wayland
+ !x11-drivers/nvidia-drivers[wayland(-)]"
+DEPEND="
+ ${RDEPEND}
+ gui-libs/eglexternalplatform
+ media-libs/libglvnd"
+BDEPEND="dev-util/wayland-scanner"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.6-remove-werror.patch
+)
+
+src_configure() {
+ # EGLStream is not intended for X11, always build without (bug #777558)
+ append-cppflags -DEGL_NO_X11
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/10_nvidia_wayland.json
+}
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "To use EGLStream with x11-drivers/nvidia-drivers, it is necessary to"
+ elog "load the nvidia-drm module with experimental nvidia-drm.modeset=1."
+ elog
+ elog "Can be accomplished by:"
+ elog " echo 'options nvidia-drm modeset=1' > ${EROOT}/etc/modprobe.d/nvidia-drm.conf"
+ elog "...then reloading the module."
+ elog
+ elog "Note that EGLStream requires support from the wayland compositor and"
+ elog "is not currently supported by many popular options such as gui-wm/sway."
+ fi
+
+ if has_version "<x11-drivers/nvidia-drivers-391"; then
+ ewarn "<=nvidia-drivers-390.xx may not work properly with this version of"
+ ewarn "egl-wayland, it is recommended to use nouveau drivers for wayland."
+ fi
+}