summaryrefslogtreecommitdiff
path: root/gui-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
commit6d691ad5b6239929063441bbd14c489e92e7396e (patch)
treee294f87b1ce66397fee1273bd6c7131aeb586f51 /gui-apps
parentd99093fb4bb5652015c06274d64083daa2439e4f (diff)
gentoo resync : 05.03.2021
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/Manifest.gzbin3387 -> 3547 bytes
-rw-r--r--gui-apps/swappy/Manifest4
-rw-r--r--gui-apps/swappy/metadata.xml16
-rw-r--r--gui-apps/swappy/swappy-1.3.1.ebuild55
-rw-r--r--gui-apps/swappy/swappy-9999.ebuild55
5 files changed, 130 insertions, 0 deletions
diff --git a/gui-apps/Manifest.gz b/gui-apps/Manifest.gz
index f933b50860ca..44300af5bec9 100644
--- a/gui-apps/Manifest.gz
+++ b/gui-apps/Manifest.gz
Binary files differ
diff --git a/gui-apps/swappy/Manifest b/gui-apps/swappy/Manifest
new file mode 100644
index 000000000000..3dfedafbb989
--- /dev/null
+++ b/gui-apps/swappy/Manifest
@@ -0,0 +1,4 @@
+DIST swappy-1.3.1.tar.gz 650917 BLAKE2B 7d1334414b5c4a7b0b53adbb40c5757398283dc0f3815ff5f4d2db6dd35d650b7e89e70663eaf7a0e111fadfcfe19e57af6a27037047f82f923409a77e44bdb6 SHA512 0d6a3ae9ed2595795ecff22fcc90640e416a1e34f11129146bb49642b4db58c615c29c1d4dcc964cc371545e73e64e99e48d1ddd0e8f36280158b649613a1693
+EBUILD swappy-1.3.1.ebuild 1081 BLAKE2B ceba7f7acf7bbd32f655594844966c0f8e7ec07744cfed1ace08057db62ce68a338223ac67729ae59c9dba7e8d169ccdacdf997e62de3d3efe5cdaca2b203fbd SHA512 3389c12dbdf7d227863ce51baabd287cb8838985941b1c1daf62c2cedf3499af7b3ee85a0180ebca930764836a2fba9999e1ac6e8637830a4b30a3458d10882b
+EBUILD swappy-9999.ebuild 1081 BLAKE2B ceba7f7acf7bbd32f655594844966c0f8e7ec07744cfed1ace08057db62ce68a338223ac67729ae59c9dba7e8d169ccdacdf997e62de3d3efe5cdaca2b203fbd SHA512 3389c12dbdf7d227863ce51baabd287cb8838985941b1c1daf62c2cedf3499af7b3ee85a0180ebca930764836a2fba9999e1ac6e8637830a4b30a3458d10882b
+MISC metadata.xml 462 BLAKE2B c5d0b997c087af0575cec9cd58d01f8932a5e8fe7866a9bf910a77eddc3a3e120ab1fd9f7b53c8b2e8bcbde0ac75998851a943052dcc912ef981ebe655d3807c SHA512 ce5e2cc6d96e781aa1684e0653a951ca0dcbad1a19abef0c838dc6dd1f0f93ad51095e3ec56fe7d9eda52c77393082e6e715c5bbee999f425ca2904458ee72ec
diff --git a/gui-apps/swappy/metadata.xml b/gui-apps/swappy/metadata.xml
new file mode 100644
index 000000000000..4d6892c98d9e
--- /dev/null
+++ b/gui-apps/swappy/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>emily@emlove.me</email>
+ <name>Emily Mills</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-apps/swappy/swappy-1.3.1.ebuild b/gui-apps/swappy/swappy-1.3.1.ebuild
new file mode 100644
index 000000000000..eea557b615f4
--- /dev/null
+++ b/gui-apps/swappy/swappy-1.3.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg optfeature
+
+DESCRIPTION="A Wayland native snapshot and editor tool, inspired by Snappy on macOS"
+HOMEPAGE="https://github.com/jtheoof/swappy"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jtheoof/swappy"
+else
+ SRC_URI="https://github.com/jtheoof/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/pango
+"
+RDEPEND="${DEPEND}
+ media-fonts/fontawesome[otf]
+"
+BDEPEND="
+ app-text/scdoc
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # See https://github.com/jtheoof/swappy/pull/99
+ sed -i -e 's/Utility;Graphics;Annotation;/Utility;Graphics;/' src/po/swappy.desktop.in || die "Sed failed!"
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dwerror=false
+ -Dman-pages=enabled
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "persisting clipboard after closing" gui-apps/wl-clipboard
+}
diff --git a/gui-apps/swappy/swappy-9999.ebuild b/gui-apps/swappy/swappy-9999.ebuild
new file mode 100644
index 000000000000..eea557b615f4
--- /dev/null
+++ b/gui-apps/swappy/swappy-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg optfeature
+
+DESCRIPTION="A Wayland native snapshot and editor tool, inspired by Snappy on macOS"
+HOMEPAGE="https://github.com/jtheoof/swappy"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jtheoof/swappy"
+else
+ SRC_URI="https://github.com/jtheoof/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/pango
+"
+RDEPEND="${DEPEND}
+ media-fonts/fontawesome[otf]
+"
+BDEPEND="
+ app-text/scdoc
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # See https://github.com/jtheoof/swappy/pull/99
+ sed -i -e 's/Utility;Graphics;Annotation;/Utility;Graphics;/' src/po/swappy.desktop.in || die "Sed failed!"
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dwerror=false
+ -Dman-pages=enabled
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "persisting clipboard after closing" gui-apps/wl-clipboard
+}