summaryrefslogtreecommitdiff
path: root/gui-apps/xwaylandvideobridge
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-20 21:42:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-20 21:42:17 +0100
commit90a3be9d71a22834f9bc82c072f1b993f9a10e31 (patch)
tree7f86c1f37e857df29494ec91436ca76bed49441a /gui-apps/xwaylandvideobridge
parenta597364520b9291d0b2a23bb007ced022e821d95 (diff)
gentoo auto-resync : 20:08:2023 - 21:42:17
Diffstat (limited to 'gui-apps/xwaylandvideobridge')
-rw-r--r--gui-apps/xwaylandvideobridge/Manifest3
-rw-r--r--gui-apps/xwaylandvideobridge/metadata.xml11
-rw-r--r--gui-apps/xwaylandvideobridge/xwaylandvideobridge-0_pre20230819.ebuild44
3 files changed, 58 insertions, 0 deletions
diff --git a/gui-apps/xwaylandvideobridge/Manifest b/gui-apps/xwaylandvideobridge/Manifest
new file mode 100644
index 000000000000..40b7888dd0ca
--- /dev/null
+++ b/gui-apps/xwaylandvideobridge/Manifest
@@ -0,0 +1,3 @@
+DIST xwaylandvideobridge-0_pre20230819-8842032f.tar.gz 34466 BLAKE2B 7407638cab2476f56c6e0b402e8683af7145e9acc47240635161bc780467eafa91cc11d720916ac3ce36e401bda65b8d9a244de994cd72193c58ca385f0b1f2a SHA512 8ea099fa2719b715d35eadc5224477470a6ca226bb388098b4c1423a62f23c1e7c52222093cb126e2af7f898be5a04f63294d350d4907aaf35e2e726940477d4
+EBUILD xwaylandvideobridge-0_pre20230819.ebuild 1142 BLAKE2B 4295032a0ad2c6f82e0ba9f03989b5d9e0bbe0783dc2d613c902f561fc53d5c99e90ba21f17164f983d0d560b18d8e18d7f3bf1064261783ca2d8a96154bfd3c SHA512 5d599ac2a953b69fa5b36a350a24b0f50d67ad8f12532a036a0b3645d4fd88e2988822c17ca89fced09ca17f848e2d3cb8a8b8951239defca7698a3b97bc37f8
+MISC metadata.xml 344 BLAKE2B 004ab22788c1bb9bb66be657676712db6998fa99a248d7e98354caf30d16bbba71f079f027bf0eceeb38ef6af0a3e662ca81fe8ba5bd90c789b81833665f405c SHA512 6a1892d29f307c2aa65ff58fa0cf59050cab7e0500317720846662bf5757e0e17d24d20118a4a07c68707dcdd0878db658b83c2262e5187aa13d3bd9330cc9f9
diff --git a/gui-apps/xwaylandvideobridge/metadata.xml b/gui-apps/xwaylandvideobridge/metadata.xml
new file mode 100644
index 000000000000..170f61584cfe
--- /dev/null
+++ b/gui-apps/xwaylandvideobridge/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="kde-invent">system/xwaylandvideobridge</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/xwaylandvideobridge/xwaylandvideobridge-0_pre20230819.ebuild b/gui-apps/xwaylandvideobridge/xwaylandvideobridge-0_pre20230819.ebuild
new file mode 100644
index 000000000000..97ce7e415fc4
--- /dev/null
+++ b/gui-apps/xwaylandvideobridge/xwaylandvideobridge-0_pre20230819.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+QTMIN=5.15.9
+KDE_ORG_CATEGORY="system"
+KDE_ORG_COMMIT="8842032fe672575a9dfe44adc7ef84b468d931fe"
+inherit ecm kde.org
+
+DESCRIPTION="Screenshare Wayland windows to XWayland apps"
+HOMEPAGE="https://planet.kde.org/david-edmundson-2023-03-22-fixing-wayland-xwayland-screen-casting/
+https://invent.kde.org/system/xwaylandvideobridge"
+
+if [[ ${KDE_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-plasma/kpipewire-5.27.4:5
+ media-libs/freetype
+ x11-libs/libxcb:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ ecm_src_prepare
+ # https://invent.kde.org/system/xwaylandvideobridge/-/merge_requests/14
+ ecm_punt_kf_module WidgetsAddons
+}