summaryrefslogtreecommitdiff
path: root/gui-apps/wl-clipboard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /gui-apps/wl-clipboard
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'gui-apps/wl-clipboard')
-rw-r--r--gui-apps/wl-clipboard/Manifest4
-rw-r--r--gui-apps/wl-clipboard/metadata.xml11
-rw-r--r--gui-apps/wl-clipboard/wl-clipboard-1.0.0.ebuild25
-rw-r--r--gui-apps/wl-clipboard/wl-clipboard-9999.ebuild25
4 files changed, 65 insertions, 0 deletions
diff --git a/gui-apps/wl-clipboard/Manifest b/gui-apps/wl-clipboard/Manifest
new file mode 100644
index 000000000000..8bd43dd7e55f
--- /dev/null
+++ b/gui-apps/wl-clipboard/Manifest
@@ -0,0 +1,4 @@
+DIST wl-clipboard-1.0.0.tar.gz 25442 BLAKE2B 02e2e99287e1376f26f73a546654e66ddb9d0a85caf457e4a023f0a02cb4d7a9cb3c8ab5840982bf014afb9fc3601722dd4c2fc4239b74a05d309a0a16d20299 SHA512 328c18a9eb2ccfc788e7ab785077ab8d663c75f2ce8f6f434799575fc76ccc89238faf930948bced216d22bee0adfc810af5e84ffc63bc82c4e1d02da4286296
+EBUILD wl-clipboard-1.0.0.ebuild 522 BLAKE2B 0ae35fafd52edd80d4ca0773680d75f3025dd5fa7c21fbeb48daeed2d8d7a783a402b1446e3dc13e76aa3ba953873ec7eead59084fd76096f7d5a12a3c57eb99 SHA512 6ba9f30e8e85028621776fb5fa0ff69090854d1f8e8fb1ad60a526562e90e567533b7da83b599ed7b56f25366e2f7a63e464376249d7660dfd12a17aa9bcf420
+EBUILD wl-clipboard-9999.ebuild 522 BLAKE2B 0ae35fafd52edd80d4ca0773680d75f3025dd5fa7c21fbeb48daeed2d8d7a783a402b1446e3dc13e76aa3ba953873ec7eead59084fd76096f7d5a12a3c57eb99 SHA512 6ba9f30e8e85028621776fb5fa0ff69090854d1f8e8fb1ad60a526562e90e567533b7da83b599ed7b56f25366e2f7a63e464376249d7660dfd12a17aa9bcf420
+MISC metadata.xml 467 BLAKE2B c0262280459dbebc32dfd41583bc0ad9704ea6af0a5a4fb446074f2fea417abc7f4e6e98fdf04348a187ca630235302042ac6b15fc85d5c18c2637882996c687 SHA512 3561bb191a3d0b62c6844a23d29de38897b9e6ecb62934d73dc04bcc70dbb45e2ea6ce2b2b14a54a61f0f17fcc2428cbdb868c58dbb9426eea75c1a7851ec901
diff --git a/gui-apps/wl-clipboard/metadata.xml b/gui-apps/wl-clipboard/metadata.xml
new file mode 100644
index 000000000000..1c9838f357ee
--- /dev/null
+++ b/gui-apps/wl-clipboard/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Two command-line Wayland clipboard utilities, wl-copy and wl-paste, that let you easily copy data between the clipboard and Unix pipes, sockets, files and so on.
+ </longdescription>
+</pkgmetadata>
diff --git a/gui-apps/wl-clipboard/wl-clipboard-1.0.0.ebuild b/gui-apps/wl-clipboard/wl-clipboard-1.0.0.ebuild
new file mode 100644
index 000000000000..d7fcf5337472
--- /dev/null
+++ b/gui-apps/wl-clipboard/wl-clipboard-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayland clipboard utilities"
+HOMEPAGE="https://github.com/bugaevc/wl-clipboard"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bugaevc/${PN}.git"
+else
+ SRC_URI="https://github.com/bugaevc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/wayland"
+RDEPEND="${DEPEND}"
+BDEPEND=""
diff --git a/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild b/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild
new file mode 100644
index 000000000000..d7fcf5337472
--- /dev/null
+++ b/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayland clipboard utilities"
+HOMEPAGE="https://github.com/bugaevc/wl-clipboard"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bugaevc/${PN}.git"
+else
+ SRC_URI="https://github.com/bugaevc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/wayland"
+RDEPEND="${DEPEND}"
+BDEPEND=""