summaryrefslogtreecommitdiff
path: root/gui-apps/wf-shell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-17 20:58:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-17 20:58:02 +0000
commit3a38a5d9da46eca9d656aa0ec448c8ba6034b044 (patch)
tree82664350bc7b90a6468e096087e6b4204e772ca7 /gui-apps/wf-shell
parent5959c8510d12e770f9320c71e55b4419e49154ee (diff)
gentoo auto-resync : 17:12:2023 - 20:58:01
Diffstat (limited to 'gui-apps/wf-shell')
-rw-r--r--gui-apps/wf-shell/Manifest4
-rw-r--r--gui-apps/wf-shell/wf-shell-0.8.0.ebuild52
-rw-r--r--gui-apps/wf-shell/wf-shell-9999.ebuild15
3 files changed, 66 insertions, 5 deletions
diff --git a/gui-apps/wf-shell/Manifest b/gui-apps/wf-shell/Manifest
index 48e9549423a7..a72e13d27403 100644
--- a/gui-apps/wf-shell/Manifest
+++ b/gui-apps/wf-shell/Manifest
@@ -1,4 +1,6 @@
DIST wf-shell-0.7.0.tar.xz 9014840 BLAKE2B f2e1ffb76de79db580227ddefc10c9f3431c92f77e6519da1102e7c4456bb30c4f25c82570a5b2796985dac00be65f9428ac6682e80920ed22359f63e3e6a84d SHA512 3d72c5d399280ee9da841a417faf696f8baa40edc1040bc1f354f113a8e431dbab428c93928b1d3faa520e35211345cabb5c70f55e10cfb7a4c321a6db19df90
+DIST wf-shell-0.8.0.tar.xz 9100508 BLAKE2B 0867f9968fca25d183fb912e01afc55ae6c9e3a0645eb63b2622ed53bb5d6538827a8e1bb6c68be4885f0c1513e76f0fd8f580402885bfa49dcbc7a0b8b02b49 SHA512 cdaebb4aabcfcb4a4d2ef0f7845348892e5731cc44417861b958d3f067f19b6bab002845d7663ef50f57e462664ff1ca0cdab74257109211db8fa20a47ef53ae
EBUILD wf-shell-0.7.0-r1.ebuild 914 BLAKE2B d6185bbe13d40a4818ba6bbdf8bb8dfde0a114ed275430dc0ec8d70eae1ea68862b2efd57a27f3dd51e154fd143c2e1652ddd559f51576b603e124fa08b1f8dd SHA512 f4ad21e52c93477823b064ba7b7bc8ad97b626150a2cd450f8ae73948252001fe60527f8ddf4317f3f41224a46d7e318673f4438de73e1bd730f018771394708
-EBUILD wf-shell-9999.ebuild 915 BLAKE2B 404fde44359fe315d21a285fe0360db4c796f14ed0f5e06e79c0f099f3a2c4555fb1a2b887f52d466cd71c609537d62dde61e0bfe2fada848bb31b7c356a7042 SHA512 5a5d68d6fede164b7bce561afb64ba3683de77e2886c197572981fba0e9dca2d64c5e32d4fc2059cd696336b3518cd0f5612e8de76205ed47ab0080aeb096b63
+EBUILD wf-shell-0.8.0.ebuild 1044 BLAKE2B 01d2e91fda18036a7587506533f1a742e8a48922a7973ef6c1dc7638b311fac994f51eed0becd6f0255911c8b2e3b6091bfdd4c2ef03dd58764872e5bb83d371 SHA512 a0f783905520a97c8036c36e07802e94a9d55b647a0acabd9dc358c93c6e5b804217102ef9f2fa41b255c59e9e02a526e2338c3a0f0417017d41668493840bca
+EBUILD wf-shell-9999.ebuild 1044 BLAKE2B 01d2e91fda18036a7587506533f1a742e8a48922a7973ef6c1dc7638b311fac994f51eed0becd6f0255911c8b2e3b6091bfdd4c2ef03dd58764872e5bb83d371 SHA512 a0f783905520a97c8036c36e07802e94a9d55b647a0acabd9dc358c93c6e5b804217102ef9f2fa41b255c59e9e02a526e2338c3a0f0417017d41668493840bca
MISC metadata.xml 524 BLAKE2B ed5b140bcf98524da710a06b621e86f531f38087c0526620ef13cd235306884d6f51fa35ddf3a7656301614122b1205298ffb6bc5159ac3fa07cd78a6d91ead3 SHA512 0e341fbd9c922ddd3c6895a60464b7004dc3d8c56b2bb4c718aece640289f6f448d4d9804ff3b7c361cf466889ad091baa015bf6d6c39ae1707ca9fa68f50371
diff --git a/gui-apps/wf-shell/wf-shell-0.8.0.ebuild b/gui-apps/wf-shell/wf-shell-0.8.0.ebuild
new file mode 100644
index 000000000000..1cfcb8cbb345
--- /dev/null
+++ b/gui-apps/wf-shell/wf-shell-0.8.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wf-shell"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+ SLOT="0/9999"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ SLOT="0/$(ver_cut 1-2)"
+fi
+
+LICENSE="MIT"
+IUSE="+pulseaudio"
+
+# no tests
+RESTRICT="test"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0[wayland]
+ dev-libs/gobject-introspection
+ dev-libs/libdbusmenu
+ >=gui-libs/gtk-layer-shell-0.6
+ dev-libs/wayland
+ gui-libs/wf-config:${SLOT}
+ gui-wm/wayfire:${SLOT}
+ pulseaudio? ( media-libs/libpulse )
+"
+RDEPEND="${DEPEND}
+ gui-apps/wayland-logout
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure () {
+ local emesonargs=(
+ "$(meson_feature pulseaudio pulse)"
+ -Dwayland-logout=false
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/wf-shell/wf-shell-9999.ebuild b/gui-apps/wf-shell/wf-shell-9999.ebuild
index 0734bbb0cb13..1cfcb8cbb345 100644
--- a/gui-apps/wf-shell/wf-shell-9999.ebuild
+++ b/gui-apps/wf-shell/wf-shell-9999.ebuild
@@ -11,20 +11,27 @@ HOMEPAGE="https://github.com/WayfireWM/wf-shell"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+ SLOT="0/9999"
else
SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
+ SLOT="0/$(ver_cut 1-2)"
fi
LICENSE="MIT"
-SLOT="0"
IUSE="+pulseaudio"
+# no tests
+RESTRICT="test"
+
DEPEND="
- dev-cpp/gtkmm:3.0=[wayland]
+ dev-cpp/gtkmm:3.0[wayland]
dev-libs/gobject-introspection
- gui-libs/gtk-layer-shell
- >=gui-wm/wayfire-${PV%.*}
+ dev-libs/libdbusmenu
+ >=gui-libs/gtk-layer-shell-0.6
+ dev-libs/wayland
+ gui-libs/wf-config:${SLOT}
+ gui-wm/wayfire:${SLOT}
pulseaudio? ( media-libs/libpulse )
"
RDEPEND="${DEPEND}