summaryrefslogtreecommitdiff
path: root/gui-apps/wf-recorder/wf-recorder-0.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /gui-apps/wf-recorder/wf-recorder-0.3.0-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'gui-apps/wf-recorder/wf-recorder-0.3.0-r1.ebuild')
-rw-r--r--gui-apps/wf-recorder/wf-recorder-0.3.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/gui-apps/wf-recorder/wf-recorder-0.3.0-r1.ebuild b/gui-apps/wf-recorder/wf-recorder-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..db2c10339ad5
--- /dev/null
+++ b/gui-apps/wf-recorder/wf-recorder-0.3.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Screen recorder for wlroots-based compositors"
+HOMEPAGE="https://github.com/ammen99/wf-recorder"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ammen99/wf-recorder.git"
+else
+ SRC_URI="https://github.com/ammen99/wf-recorder/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/wayland
+ media-sound/pulseaudio
+ media-video/ffmpeg[pulseaudio,x264]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"