summaryrefslogtreecommitdiff
path: root/gui-apps/wcm/wcm-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /gui-apps/wcm/wcm-9999.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'gui-apps/wcm/wcm-9999.ebuild')
-rw-r--r--gui-apps/wcm/wcm-9999.ebuild17
1 files changed, 3 insertions, 14 deletions
diff --git a/gui-apps/wcm/wcm-9999.ebuild b/gui-apps/wcm/wcm-9999.ebuild
index 8178a3b0d885..54d7e4cee824 100644
--- a/gui-apps/wcm/wcm-9999.ebuild
+++ b/gui-apps/wcm/wcm-9999.ebuild
@@ -10,21 +10,20 @@ HOMEPAGE="https://github.com/WayfireWM/wcm"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+ EGIT_REPO_URI="https://github.com/WayfireWM/wcm.git"
else
- SRC_URI="https://github.com/WayfireWM/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/WayfireWM/wcm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="debug"
DEPEND="
dev-libs/libevdev
dev-libs/libxml2
dev-cpp/gtkmm:3.0[wayland]
- ~gui-wm/wayfire-${PV}[debug=]
+ ~gui-wm/wayfire-${PV}
"
RDEPEND="${DEPEND}"
@@ -34,13 +33,3 @@ BDEPEND="
dev-libs/wayland-protocols
virtual/pkgconfig
"
-
-src_compile() {
- local emesonargs=""
- if use debug; then
- emesonargs+=(
- "-Db_sanitize=address,undefined"
- )
- fi
- meson_src_compile
-}