summaryrefslogtreecommitdiff
path: root/gui-apps/wayvnc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /gui-apps/wayvnc
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'gui-apps/wayvnc')
-rw-r--r--gui-apps/wayvnc/Manifest4
-rw-r--r--gui-apps/wayvnc/metadata.xml24
-rw-r--r--gui-apps/wayvnc/wayvnc-0.4.0.ebuild44
-rw-r--r--gui-apps/wayvnc/wayvnc-9999.ebuild44
4 files changed, 116 insertions, 0 deletions
diff --git a/gui-apps/wayvnc/Manifest b/gui-apps/wayvnc/Manifest
new file mode 100644
index 000000000000..f003c6065408
--- /dev/null
+++ b/gui-apps/wayvnc/Manifest
@@ -0,0 +1,4 @@
+DIST wayvnc-0.4.0.tar.gz 52157 BLAKE2B 7c8456d5136ef361ca7dd72ffa7501514eeb7a61ae1777a02391fb7fceea6b020d68951300ab76254f2afd5e2610fe66ce0f461d18dc38522706691438f4620e SHA512 b8f1af24213077dc6126ae1f613b9cdeed8f365f9d1989a5b053563f0eb4bc49921e746e0f1026fe0e02bfeea23b912798678a5a337a052d977aa04496a75570
+EBUILD wayvnc-0.4.0.ebuild 884 BLAKE2B 12217ad95e53efd84149ce8d3140bb1552b41a425740e448f1d59f98d8ebf8a32b6401dac5b92895ac6dcd453af531d0940f3c74324d8714e6b0b49a3ae93293 SHA512 d13a811372db890cd7d3e894e2190852e3b6806cbeef91d11cf1fa9d7a035b219b8cc9065f498864ff943b1f57a69c52443e39db223e46e8060dd3f1c81f4bd3
+EBUILD wayvnc-9999.ebuild 884 BLAKE2B 12217ad95e53efd84149ce8d3140bb1552b41a425740e448f1d59f98d8ebf8a32b6401dac5b92895ac6dcd453af531d0940f3c74324d8714e6b0b49a3ae93293 SHA512 d13a811372db890cd7d3e894e2190852e3b6806cbeef91d11cf1fa9d7a035b219b8cc9065f498864ff943b1f57a69c52443e39db223e46e8060dd3f1c81f4bd3
+MISC metadata.xml 936 BLAKE2B cf96fe5683e483676b78f7c155ea20aa76f302bc27a9a17e69b862256da3d7c6d90c9ca113ef96de8b00f179981ee9eb8ceec8258948a588f7e4f4ea29d48f7e SHA512 21d6f94c0ec2c47a47e4d408b834af9be63d855ac7cd9a5b0d1e6ca642eab3eb80c4e4b8bc9e692be2dbf29d31167770467a75041deb196c0fdfedb8e05dfd02
diff --git a/gui-apps/wayvnc/metadata.xml b/gui-apps/wayvnc/metadata.xml
new file mode 100644
index 000000000000..32c02efdbf9e
--- /dev/null
+++ b/gui-apps/wayvnc/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ VNC server for wlroots based Wayland compositors.
+ It attaches to a running Wayland session, creates
+ virtual input devices and exposes a single display
+ via the RFB protocol. The Wayland session may be a
+ headless one, so it is also possible to run wayvnc
+ without a physical display attached.
+ </longdescription>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="gbm">enable GPU-side screencopy (experimental)</flag>
+ <flag name="tracing">Trace kernel and memory calls</flag>
+ </use>
+</pkgmetadata>
diff --git a/gui-apps/wayvnc/wayvnc-0.4.0.ebuild b/gui-apps/wayvnc/wayvnc-0.4.0.ebuild
new file mode 100644
index 000000000000..369ff2e67cac
--- /dev/null
+++ b/gui-apps/wayvnc/wayvnc-0.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="VNC server for wlroots based Wayland compositors"
+HOMEPAGE="https://github.com/any1/wayvnc"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
+else
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="gbm tracing"
+
+RDEPEND="
+ dev-libs/aml
+ dev-libs/wayland
+ gui-libs/neatvnc[tracing?]
+ media-libs/mesa:=[egl,gles2,gbm?]
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ tracing? ( dev-util/systemtap )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature gbm screencopy-dmabuf)
+ $(meson_use tracing systemtap)
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/wayvnc/wayvnc-9999.ebuild b/gui-apps/wayvnc/wayvnc-9999.ebuild
new file mode 100644
index 000000000000..369ff2e67cac
--- /dev/null
+++ b/gui-apps/wayvnc/wayvnc-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="VNC server for wlroots based Wayland compositors"
+HOMEPAGE="https://github.com/any1/wayvnc"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
+else
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="gbm tracing"
+
+RDEPEND="
+ dev-libs/aml
+ dev-libs/wayland
+ gui-libs/neatvnc[tracing?]
+ media-libs/mesa:=[egl,gles2,gbm?]
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ tracing? ( dev-util/systemtap )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature gbm screencopy-dmabuf)
+ $(meson_use tracing systemtap)
+ )
+ meson_src_configure
+}