summaryrefslogtreecommitdiff
path: root/gui-apps/wayland-logout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /gui-apps/wayland-logout
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'gui-apps/wayland-logout')
-rw-r--r--gui-apps/wayland-logout/Manifest4
-rw-r--r--gui-apps/wayland-logout/metadata.xml12
-rw-r--r--gui-apps/wayland-logout/wayland-logout-1.0.ebuild26
-rw-r--r--gui-apps/wayland-logout/wayland-logout-9999.ebuild26
4 files changed, 68 insertions, 0 deletions
diff --git a/gui-apps/wayland-logout/Manifest b/gui-apps/wayland-logout/Manifest
new file mode 100644
index 000000000000..ba4c7bb868aa
--- /dev/null
+++ b/gui-apps/wayland-logout/Manifest
@@ -0,0 +1,4 @@
+DIST wayland-logout-1.0.tar.gz 16663 BLAKE2B 7f8932342cd584f9e8c6abcaf83b2a5ff7ff14eda00f6d47a402206cff5786a9f4d5fbd75b8704fd0c39fad9550e47dbd499ac4a9b233f63ee6ed80b544d4556 SHA512 2c31fe11d4e6de53c7e873e7d235c4dcfbcb1425f4d7d2969b623574dd0bea77ee1fd482949b09cd86a1755ed48f2a8b39e4b2db6adedaf6d465144e9ef71652
+EBUILD wayland-logout-1.0.ebuild 605 BLAKE2B 421307556328f95d1bb6aabf1d0a1522a055fd1abb52db07c8aaae429f066816589288520ff946d0d9bfcc47073aad897985ff877d314c04c6e847fa0efe54c3 SHA512 fb8e6fe732098e46666ea5c36a5dd0e1b832a7247d5d428cd9395459683a6bab84ad347a2ff2e8b9c539c10ff3f102ec913464bdbeb711522eee28ac7477e529
+EBUILD wayland-logout-9999.ebuild 605 BLAKE2B 421307556328f95d1bb6aabf1d0a1522a055fd1abb52db07c8aaae429f066816589288520ff946d0d9bfcc47073aad897985ff877d314c04c6e847fa0efe54c3 SHA512 fb8e6fe732098e46666ea5c36a5dd0e1b832a7247d5d428cd9395459683a6bab84ad347a2ff2e8b9c539c10ff3f102ec913464bdbeb711522eee28ac7477e529
+MISC metadata.xml 359 BLAKE2B 6a34261ec10702f5bec40975ab7723eee34e015afa5a4544146834c43a9a3b040d9ead5d5a617da0b8253e9e9a7e05fe9efae38588b02b8fa16f653d9bfc5340 SHA512 43bdd93da8962e2ca6d852356e206511754f1e5f0bda721ac6458c54abab89367fc137f686583dd9df6d83be82bad66f9858efc52ed1e5a002d6b3bacd8fdbb4
diff --git a/gui-apps/wayland-logout/metadata.xml b/gui-apps/wayland-logout/metadata.xml
new file mode 100644
index 000000000000..d155fdbc0406
--- /dev/null
+++ b/gui-apps/wayland-logout/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-apps/wayland-logout/wayland-logout-1.0.ebuild b/gui-apps/wayland-logout/wayland-logout-1.0.ebuild
new file mode 100644
index 000000000000..edb385b32abf
--- /dev/null
+++ b/gui-apps/wayland-logout/wayland-logout-1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="general logout scripts for wayland compositors"
+
+HOMEPAGE="https://github.com/soreau/wayland-logout"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/soreau/wayland-logout"
+else
+ SRC_URI="https://github.com/soreau/wayland-logout/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="sys-process/lsof"
+
+src_install() {
+ newbin wayland-logout.sh wayland-logout
+ dosym wayland-logout /usr/bin/wlogout
+}
diff --git a/gui-apps/wayland-logout/wayland-logout-9999.ebuild b/gui-apps/wayland-logout/wayland-logout-9999.ebuild
new file mode 100644
index 000000000000..edb385b32abf
--- /dev/null
+++ b/gui-apps/wayland-logout/wayland-logout-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="general logout scripts for wayland compositors"
+
+HOMEPAGE="https://github.com/soreau/wayland-logout"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/soreau/wayland-logout"
+else
+ SRC_URI="https://github.com/soreau/wayland-logout/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="sys-process/lsof"
+
+src_install() {
+ newbin wayland-logout.sh wayland-logout
+ dosym wayland-logout /usr/bin/wlogout
+}