summaryrefslogtreecommitdiff
path: root/gui-apps/wayland-logout/wayland-logout-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /gui-apps/wayland-logout/wayland-logout-1.1.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'gui-apps/wayland-logout/wayland-logout-1.1.ebuild')
-rw-r--r--gui-apps/wayland-logout/wayland-logout-1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/gui-apps/wayland-logout/wayland-logout-1.1.ebuild b/gui-apps/wayland-logout/wayland-logout-1.1.ebuild
new file mode 100644
index 000000000000..19849dc6704e
--- /dev/null
+++ b/gui-apps/wayland-logout/wayland-logout-1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="general logout scripts for wayland compositors"
+
+HOMEPAGE="https://github.com/soreau/wayland-logout"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/soreau/wayland-logout"
+else
+ SRC_URI="https://github.com/soreau/wayland-logout/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="sys-process/lsof"
+
+src_install() {
+ newbin wayland-logout.sh wayland-logout
+ doman wayland-logout.1
+}