summaryrefslogtreecommitdiff
path: root/gui-apps/waybar/waybar-0.9.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /gui-apps/waybar/waybar-0.9.5-r1.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'gui-apps/waybar/waybar-0.9.5-r1.ebuild')
-rw-r--r--gui-apps/waybar/waybar-0.9.5-r1.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/gui-apps/waybar/waybar-0.9.5-r1.ebuild b/gui-apps/waybar/waybar-0.9.5-r1.ebuild
deleted file mode 100644
index fe2a849be6ce..000000000000
--- a/gui-apps/waybar/waybar-0.9.5-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors"
-HOMEPAGE="https://github.com/Alexays/Waybar"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Alexays/${PN^}.git"
-else
- SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-S="${WORKDIR}/${PN^}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="mpd network popups pulseaudio sndio tray +udev wifi"
-
-BDEPEND="
- >=app-text/scdoc-1.9.2
- virtual/pkgconfig
-"
-DEPEND="
- dev-cpp/gtkmm:3.0
- dev-libs/jsoncpp:=
- dev-libs/libinput:=
- dev-libs/libsigc++:2
- >=dev-libs/libfmt-5.3.0:=
- >=dev-libs/spdlog-1.8.0:=
- dev-libs/date:=
- dev-libs/wayland
- dev-libs/wayland-protocols
- gui-libs/wlroots:=
- x11-libs/gtk+:3[wayland]
- mpd? ( media-libs/libmpdclient )
- network? ( dev-libs/libnl:3 )
- popups? ( gui-libs/gtk-layer-shell )
- pulseaudio? ( media-sound/pulseaudio )
- sndio? ( media-sound/sndio:= )
- tray? (
- dev-libs/libdbusmenu[gtk3]
- dev-libs/libappindicator
- )
- udev? ( virtual/libudev:= )
- wifi? ( || ( sys-apps/util-linux net-wireless/rfkill ) )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.9.7-libfmt-8.patch"
-)
-
-src_configure() {
- local emesonargs=(
- $(meson_feature mpd)
- $(meson_feature network libnl)
- $(meson_feature popups gtk-layer-shell)
- $(meson_feature pulseaudio)
- $(meson_feature sndio)
- $(meson_feature tray dbusmenu-gtk)
- $(meson_feature udev libudev)
- $(meson_feature wifi rfkill)
- )
- meson_src_configure
-}