summaryrefslogtreecommitdiff
path: root/gui-apps/swayidle/swayidle-1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-06 03:18:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-06 03:18:56 +0000
commita2f130f3156ea1d203e99a781424790176b9b2b5 (patch)
tree10fbba06303ed3b478a8a39114e6b6127ef18dbb /gui-apps/swayidle/swayidle-1.7.ebuild
parent519f4aac6d5896fe0204e6429485f95240c7ff58 (diff)
gentoo auto-resync : 06:02:2023 - 03:18:56
Diffstat (limited to 'gui-apps/swayidle/swayidle-1.7.ebuild')
-rw-r--r--gui-apps/swayidle/swayidle-1.7.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/gui-apps/swayidle/swayidle-1.7.ebuild b/gui-apps/swayidle/swayidle-1.7.ebuild
deleted file mode 100644
index 2fc7da1e95f1..000000000000
--- a/gui-apps/swayidle/swayidle-1.7.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="Idle management daemon for Wayland"
-HOMEPAGE="https://github.com/swaywm/swayidle"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
-else
- SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="elogind +man systemd"
-REQUIRED_USE="?? ( elogind systemd )"
-
-DEPEND="
- dev-libs/wayland
- elogind? ( >=sys-auth/elogind-237[policykit] )
- systemd? ( >=sys-apps/systemd-237[policykit] )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- >=dev-libs/wayland-protocols-1.14
- virtual/pkgconfig
- man? ( app-text/scdoc )
-"
-
-src_configure() {
- local emesonargs=(
- -Dman-pages=$(usex man enabled disabled)
- "-Dfish-completions=true"
- "-Dzsh-completions=true"
- "-Dbash-completions=true"
- )
- if use systemd; then
- emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
- elif use elogind; then
- emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
- else
- emesonargs+=("-Dlogind=disabled")
- fi
-
- meson_src_configure
-}