summaryrefslogtreecommitdiff
path: root/gui-apps/qt6ct
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
commit1426dfeb15e4d49cb4238c6cf37455a6130cd83f (patch)
tree9f9734bcdc280108e52d753b3c57234371772c3c /gui-apps/qt6ct
parent836586553c510ee2dd91e2ecd7676fe432c1f1a4 (diff)
gentoo auto-resync : 18:09:2023 - 11:05:42
Diffstat (limited to 'gui-apps/qt6ct')
-rw-r--r--gui-apps/qt6ct/Manifest3
-rw-r--r--gui-apps/qt6ct/metadata.xml11
-rw-r--r--gui-apps/qt6ct/qt6ct-0.8_p20230917.ebuild45
3 files changed, 59 insertions, 0 deletions
diff --git a/gui-apps/qt6ct/Manifest b/gui-apps/qt6ct/Manifest
new file mode 100644
index 000000000000..0a14118c9bde
--- /dev/null
+++ b/gui-apps/qt6ct/Manifest
@@ -0,0 +1,3 @@
+DIST qt6ct-0.8_p20230917.tar.gz 159468 BLAKE2B bf7c5446932a5e8152ee7121f8ee679aeacabae3c3be636bef0e6c1d128abfea571971efabb6366a654ea5845cce028ab641d795d6c56963d894a21732b8656b SHA512 751f9f6b2264ef04661b8b3ccdda599dfc0109aa35f60334857d382414872155b4d5b0e3b14cd6130385dfccb945e1547900a30a7cf08d87a0a592839ef05dba
+EBUILD qt6ct-0.8_p20230917.ebuild 1283 BLAKE2B 534247188cb732bdaadb2cf0dbfe2a2aa60862ab5a498299f82087b303d75b2274afedf3ce85327b1c4322a54c274c665db146be275171583deee3f87f86b895 SHA512 46bc603c43fc143458b979f66c57a759bfd13360c572634e995ea4ef835ed36565db26fd7e734a81db7face7bdb0f0ce6580c1fe23c647710fb0ea725165c59d
+MISC metadata.xml 328 BLAKE2B 0e3436b743292d8aaceb7474ba3a2ad22a5b0d81e18d2a2ec050a76d773da3736a1be17681d694bcbdbc2c6825639f35836db0ba75be526457af5ad2be29fa3d SHA512 8dd8edc8b55d76fcb5d6f3181783778a6b06fd22bafe0fafba033ef7981981620e9e29d0019ed39fd9b45bb202fddaf6d7f25b5150b81a1fc0054e79784249cc
diff --git a/gui-apps/qt6ct/metadata.xml b/gui-apps/qt6ct/metadata.xml
new file mode 100644
index 000000000000..68805024ec91
--- /dev/null
+++ b/gui-apps/qt6ct/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ionen@gentoo.org</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">trialuser02/qt6ct</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/qt6ct/qt6ct-0.8_p20230917.ebuild b/gui-apps/qt6ct/qt6ct-0.8_p20230917.ebuild
new file mode 100644
index 000000000000..fa1499bba9d7
--- /dev/null
+++ b/gui-apps/qt6ct/qt6ct-0.8_p20230917.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt6 Configuration Tool (for DE/WM without Qt integration)"
+HOMEPAGE="https://github.com/trialuser02/qt6ct/"
+#SRC_URI="https://github.com/trialuser02/qt6ct/releases/download/${PV}/${P}.tar.xz"
+
+# temporary snapshot for https://github.com/trialuser02/qt6ct/issues/32
+QT6CT_HASH=f083799f1495dabaeeb482274ee90c73a0a78a43
+SRC_URI="
+ https://github.com/trialuser02/qt6ct/archive/${QT6CT_HASH}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${PN}-${QT6CT_HASH}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# uses Qt private APIs wrt :=
+DEPEND="dev-qt/qtbase:6=[gui,widgets]"
+RDEPEND="
+ ${DEPEND}
+ dev-qt/qtsvg:6
+"
+BDEPEND="
+ dev-qt/qtbase:6
+ dev-qt/qttools:6[linguist]
+"
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note need to export QT_QPA_PLATFORMTHEME=qt6ct in the used environment"
+ elog "for theming to take effect (not done automatically, may want to set in"
+ elog "the HOME's shell initialization scripts, or use /etc/env.d followed by"
+ elog "running env-update then re-login)."
+ elog
+ elog "If also using x11-misc/qt5ct, =qt5ct is alternatively recognized so it"
+ elog "can be activated for both Qt5 and Qt6 at once."
+ fi
+}