summaryrefslogtreecommitdiff
path: root/gui-apps/mako
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /gui-apps/mako
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'gui-apps/mako')
-rw-r--r--gui-apps/mako/Manifest6
-rw-r--r--gui-apps/mako/mako-1.2.ebuild46
-rw-r--r--gui-apps/mako/mako-1.3.ebuild51
-rw-r--r--gui-apps/mako/mako-9999.ebuild51
-rw-r--r--gui-apps/mako/metadata.xml19
5 files changed, 173 insertions, 0 deletions
diff --git a/gui-apps/mako/Manifest b/gui-apps/mako/Manifest
new file mode 100644
index 000000000000..4e97678dd398
--- /dev/null
+++ b/gui-apps/mako/Manifest
@@ -0,0 +1,6 @@
+DIST mako-1.2.tar.gz 34443 BLAKE2B d505cbc7d25755ef3880adceaf8e33c277a90583c37ebd2691cd3d8d142f19f7eedca2ad167c0174723706c6f0a9b0688ddb34ed824e8231330265f1b5e3d645 SHA512 2552590f690a9749e9ef897052ca6aecf70eb01d77b1afe21335c84e257c6c8347abbd7f33150d561e8f52a9ae3a91c7a199a93cecf64a305934886522fc1454
+DIST mako-1.3.tar.gz 46482 BLAKE2B ea7699f713aded0476f3a9b88d90fa8d3bbd4e64e888caa68a98208625cdd15f1261c389dcb8ab43c6fbc77e1ebc0840b378443a1b350ff16adc59b98b9be0a8 SHA512 efada6ac413d80949669df3124ab9979537dcedd535132de57338b484ff2c81da8da59503a14dc2e9bbb266101659dd1d399d66456d383fdd1853d9137587259
+EBUILD mako-1.2.ebuild 792 BLAKE2B 385ba17de9753c166f00c4a5dce928e1b218ac4035372820f61293c0f3fcf76bebc99a021c90511c2f6b93a2cd57c2e330b41871043c1fabc3d5fcf6531e2462 SHA512 df4f74b2c3e633a97b7b77ca5d3c30c7b87314b5ddab8d864f1e332b7504c5519794d21c49146a8fb77da64831468a4407b131243f5f1a2a405dc1e2a454e985
+EBUILD mako-1.3.ebuild 894 BLAKE2B 5d7a5aa5cbac293bc0b1f9e0e5bed07c38a2c2548da92a95c907f48c2ce310fd20f88e695bbd956be3044178a268198abcffb62c104b1ca075318528981baa50 SHA512 c30b91982ab4b20a31831a16df7807a14ad46fcfab6ad5f6b7a7ff6ca28b54188abc95dec2c08aac90bbd132a815b1ec88fd106d6a3a1d682938b645791524c0
+EBUILD mako-9999.ebuild 894 BLAKE2B 5d7a5aa5cbac293bc0b1f9e0e5bed07c38a2c2548da92a95c907f48c2ce310fd20f88e695bbd956be3044178a268198abcffb62c104b1ca075318528981baa50 SHA512 c30b91982ab4b20a31831a16df7807a14ad46fcfab6ad5f6b7a7ff6ca28b54188abc95dec2c08aac90bbd132a815b1ec88fd106d6a3a1d682938b645791524c0
+MISC metadata.xml 642 BLAKE2B 4b96d18b0cf351347a12d6e520d7aace4de2f7df8532953288dcfa2549cde936417b73499e0d0b7debd7716d1b49431db6529a213da0b69491df081400af8ae8 SHA512 51c3f7458f486883613916701f721045c3f7f82c9be1b8feb781632e38489e08c1d84411daaf56e01bc07d06c3b1c1683f55a79a51b4d6fd0f522ce97d303c8a
diff --git a/gui-apps/mako/mako-1.2.ebuild b/gui-apps/mako/mako-1.2.ebuild
new file mode 100644
index 000000000000..edbba54c3231
--- /dev/null
+++ b/gui-apps/mako/mako-1.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway."
+HOMEPAGE="https://github.com/emersion/mako"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~arm64 x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/pango
+ x11-libs/cairo
+ || (
+ sys-apps/systemd
+ sys-auth/elogind
+ )
+ sys-apps/dbus[user-session]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+ app-text/scdoc
+"
+
+src_configure() {
+ local emesonargs=(
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/mako/mako-1.3.ebuild b/gui-apps/mako/mako-1.3.ebuild
new file mode 100644
index 000000000000..60eca46bf3e5
--- /dev/null
+++ b/gui-apps/mako/mako-1.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway."
+HOMEPAGE="https://github.com/emersion/mako"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+icons"
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/pango
+ x11-libs/cairo
+ || (
+ sys-apps/systemd
+ sys-auth/elogind
+ )
+ sys-apps/dbus[user-session]
+ icons? (
+ x11-libs/gtk+:3
+ x11-libs/gdk-pixbuf
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+ app-text/scdoc
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicons=$(usex icons enabled disabled)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/mako/mako-9999.ebuild b/gui-apps/mako/mako-9999.ebuild
new file mode 100644
index 000000000000..60eca46bf3e5
--- /dev/null
+++ b/gui-apps/mako/mako-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway."
+HOMEPAGE="https://github.com/emersion/mako"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+icons"
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/pango
+ x11-libs/cairo
+ || (
+ sys-apps/systemd
+ sys-auth/elogind
+ )
+ sys-apps/dbus[user-session]
+ icons? (
+ x11-libs/gtk+:3
+ x11-libs/gdk-pixbuf
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+ app-text/scdoc
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicons=$(usex icons enabled disabled)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/mako/metadata.xml b/gui-apps/mako/metadata.xml
new file mode 100644
index 000000000000..f4af030a3eca
--- /dev/null
+++ b/gui-apps/mako/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A lightweight notification daemon for Wayland. Works on Sway.
+ </longdescription>
+ <use>
+ <flag name="icons">Enable support for icons</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">emmersion/mako</remote-id>
+ <bugs-to>https://github.com/emersion/mako/issues</bugs-to>
+ <changelog>https://github.com/emersion/mako/releases</changelog>
+ </upstream>
+</pkgmetadata>