summaryrefslogtreecommitdiff
path: root/gui-apps/kanshi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /gui-apps/kanshi
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'gui-apps/kanshi')
-rw-r--r--gui-apps/kanshi/Manifest4
-rw-r--r--gui-apps/kanshi/kanshi-1.1.0.ebuild43
-rw-r--r--gui-apps/kanshi/kanshi-9999.ebuild43
-rw-r--r--gui-apps/kanshi/metadata.xml22
4 files changed, 112 insertions, 0 deletions
diff --git a/gui-apps/kanshi/Manifest b/gui-apps/kanshi/Manifest
new file mode 100644
index 000000000000..aae09a6baf9f
--- /dev/null
+++ b/gui-apps/kanshi/Manifest
@@ -0,0 +1,4 @@
+DIST kanshi-1.1.0.tar.gz 15884 BLAKE2B 1085e9d8f3ff53f78cb248941269713fd7ea38c60ad0e9816acb902f171b6f945af521a3835fc9db479620e6031483f6dbab5cfc507872dcabdfbcf9d6711269 SHA512 6582bae7b73ad13cad83e4d537c7c870699a72bf6993becaafa47a3dd70439a3c626ffff4874c8f737b32b62ad7512772c2c3bf54ac2cb74879213bd40b8d7a1
+EBUILD kanshi-1.1.0.ebuild 817 BLAKE2B 1a51aef77f13910c4d083209df702f02a2f51c488f1e91dd15745116ada7e0c63cf6cc7b02d554577e73938950bc9177906b649c04151f40d3ac969ea1b09c85 SHA512 8090432f3ad0e3291b8d2615b620e9d7e838b25b8bacadc05c3171d29f1435e0b61f737af5640853cf5987c1d2a7d61ab7af659a9459385e472a5a787d257014
+EBUILD kanshi-9999.ebuild 817 BLAKE2B 1a51aef77f13910c4d083209df702f02a2f51c488f1e91dd15745116ada7e0c63cf6cc7b02d554577e73938950bc9177906b649c04151f40d3ac969ea1b09c85 SHA512 8090432f3ad0e3291b8d2615b620e9d7e838b25b8bacadc05c3171d29f1435e0b61f737af5640853cf5987c1d2a7d61ab7af659a9459385e472a5a787d257014
+MISC metadata.xml 704 BLAKE2B ba26243d3417e1c46f674a0eeff81560833c9ce78f8a3c4d48e8b98f759a6080c40083a045bb03feae74c19b8ec8f2f0ff584e2c51e0b437f6f3d068b8a70843 SHA512 85145bd2e7f8d83c7d7dd77c0d8f4e396e1b987bcb176153527f62f8bfd96b98536a3627d01ecd52401dc26734bc5125913139f5defac7421b59fe30fd90a97a
diff --git a/gui-apps/kanshi/kanshi-1.1.0.ebuild b/gui-apps/kanshi/kanshi-1.1.0.ebuild
new file mode 100644
index 000000000000..221a5f5f59ed
--- /dev/null
+++ b/gui-apps/kanshi/kanshi-1.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="dynamic display configuration (autorandr for wayland)"
+HOMEPAGE="https://github.com/emersion/kanshi"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/kanshi"
+else
+ SRC_URI="https://github.com/emersion/kanshi/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+RDEPEND="
+ dev-libs/wayland
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/kanshi/kanshi-9999.ebuild b/gui-apps/kanshi/kanshi-9999.ebuild
new file mode 100644
index 000000000000..221a5f5f59ed
--- /dev/null
+++ b/gui-apps/kanshi/kanshi-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="dynamic display configuration (autorandr for wayland)"
+HOMEPAGE="https://github.com/emersion/kanshi"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/kanshi"
+else
+ SRC_URI="https://github.com/emersion/kanshi/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+RDEPEND="
+ dev-libs/wayland
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/kanshi/metadata.xml b/gui-apps/kanshi/metadata.xml
new file mode 100644
index 000000000000..170a33a029b3
--- /dev/null
+++ b/gui-apps/kanshi/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bman@gentoo.org</email>
+ <name>Aaron Bauman</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ <description>Proxy-maintainer, assign bugs</description>
+ </maintainer>
+ <longdescription>
+ kanshi allows you to define output profiles that are
+ automatically enabled and disabled on hotplug.
+ For instance, this can be used to turn a laptop's
+ internal screen off when docked.
+ </longdescription>
+ <use>
+ <flag name="man">build and install man pages</flag>
+ </use>
+</pkgmetadata>