summaryrefslogtreecommitdiff
path: root/gui-apps/kanshi/kanshi-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-25 02:49:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-25 02:49:03 +0100
commitca125edb1c8e51bd222fec61eb155151bbd4b791 (patch)
treeb1ca31e2662c41a1e85c62975d23ce38fa0e5df0 /gui-apps/kanshi/kanshi-1.3.0.ebuild
parent9d0673651c57438d51e18c6b8ca894d0491b2df3 (diff)
gentoo auto-resync : 25:08:2022 - 02:49:03
Diffstat (limited to 'gui-apps/kanshi/kanshi-1.3.0.ebuild')
-rw-r--r--gui-apps/kanshi/kanshi-1.3.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/gui-apps/kanshi/kanshi-1.3.0.ebuild b/gui-apps/kanshi/kanshi-1.3.0.ebuild
new file mode 100644
index 000000000000..2f3236686822
--- /dev/null
+++ b/gui-apps/kanshi/kanshi-1.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="dynamic display configuration (autorandr for wayland)"
+HOMEPAGE="https://wayland.emersion.fr/kanshi/ https://sr.ht/~emersion/kanshi/"
+SRC_URI="
+ https://git.sr.ht/~emersion/kanshi/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${PN}-v${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+man varlink"
+
+RDEPEND="
+ dev-libs/wayland
+ varlink? ( dev-libs/libvarlink )
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+ man? ( >=app-text/scdoc-1.9.3 )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ $(meson_feature varlink ipc)
+ )
+ meson_src_configure
+}