summaryrefslogtreecommitdiff
path: root/gui-apps/foot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /gui-apps/foot
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'gui-apps/foot')
-rw-r--r--gui-apps/foot/Manifest2
-rw-r--r--gui-apps/foot/foot-1.12.1.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/gui-apps/foot/Manifest b/gui-apps/foot/Manifest
index 046256206481..a358a83c7da2 100644
--- a/gui-apps/foot/Manifest
+++ b/gui-apps/foot/Manifest
@@ -1,3 +1,5 @@
DIST foot-1.11.0.tar.gz 468899 BLAKE2B f3e3909c670598dab151f8be4104921fddd6621e833a8fe43c68d06347e3e866101fe1563282622436638674b7f73770762d47a7b9fd61d42b00bc7634e2ea76 SHA512 edf8130dfb52e06b6d8638115eca19695b24536f3f6b284e0319876edb95c3c86800f9527cc9dae3f66d2d317d26add793634a19f302e52c9f0118b9b91fc9c2
+DIST foot-1.12.1.tar.gz 484702 BLAKE2B 5f3ed5923dfe2e3d110da298d4abefb331c15bb0f3db3135a4e8d481b528b3f8287fc5d8516e9d3a34b8084f6364edae93dee496d9192fe610d2c17733277451 SHA512 553f404b074f4372fb8cfb050f0378d1cbe1620ea8afe2e279523df3006eefd0b0ed24addca33de10cfc8109e5aaec66beccbd5f30e032bb9f2bd9b81ac798cb
EBUILD foot-1.11.0-r1.ebuild 1147 BLAKE2B 2a8281e9583ba5e94bce33f931646d7f204c6dba3bbe4718a2054e6b082dd8c30fda09702d1edb97eb7248a7e68b43aae496e307fa557bd2b735a48a0c6f1a1e SHA512 f532c40b846ab77f0ba09cacd670f661252321c214b44a335e068babc5fd57984975c8274d9aa792cf0fa5442a15a3de2595cceb48203c28e41949e976507b31
+EBUILD foot-1.12.1.ebuild 1609 BLAKE2B 95c0f9c99faff7dd2829b3d35b50798da82481f7708df2b28c8bc8d936ac1199a830caf12e0e5855f0aa11d07af251af0b4b4ab73986f670dfe322eacb12ea37 SHA512 f6a4f80c2fcb63526a6d0946b3f0abb61da55e92ae0ccfe0a20da2a227573170be00ad9c7bfe47eb419d8e6886cfa1a19056ed12af2085525ee91aef5052c377
MISC metadata.xml 487 BLAKE2B c9585e04b395d413dc3d087f7e5043a39c8c422299e5aadb560a50a3f600913d2e27f0ac7a3eb8ec5816f167b4c5637063a71cdd4c84a15885200d6417154764 SHA512 78b22205ff6d7f6f75a8d01df4ac4ba497bc31783f2c626d0b9cc3b8347a72e6bc4bd598fc3a1c0da3bd84af2df9391f39bdf00ddc33830ad41aa94b67d57304
diff --git a/gui-apps/foot/foot-1.12.1.ebuild b/gui-apps/foot/foot-1.12.1.ebuild
new file mode 100644
index 000000000000..7960c0ac2e55
--- /dev/null
+++ b/gui-apps/foot/foot-1.12.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg systemd
+
+DESCRIPTION="Fast, lightweight and minimalistic Wayland terminal emulator"
+HOMEPAGE="https://codeberg.org/dnkl/foot"
+SRC_URI="https://codeberg.org/dnkl/foot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="+grapheme-clustering"
+
+COMMON_DEPEND="
+ dev-libs/wayland
+ media-libs/fcft
+ media-libs/fontconfig
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ grapheme-clustering? (
+ dev-libs/libutf8proc:=
+ media-libs/fcft[harfbuzz]
+ )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-libs/tllist
+ dev-libs/wayland-protocols
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ || (
+ >=sys-libs/ncurses-6.3[-minimal]
+ ~gui-apps/foot-terminfo-${PV}
+ )
+"
+BDEPEND="
+ app-text/scdoc
+ dev-util/wayland-scanner
+"
+
+src_prepare() {
+ default
+ # disable the systemd dep, we install the unit file manually
+ sed -i "s/systemd', required: false)$/', required: false)/" "${S}"/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature grapheme-clustering)
+ -Dthemes=true
+ -Dime=true
+ -Dterminfo=disabled
+ -Dwerror=false
+ )
+ meson_src_configure
+
+ sed 's|@bindir@|/usr/bin|g' "${S}/"/foot-server@.service.in > foot-server@.service
+}
+
+src_install() {
+ local DOCS=( CHANGELOG.md README.md LICENSE )
+ meson_src_install
+
+ # foot unconditionally installs CHANGELOG.md, README.md and LICENSE.
+ # we handle this via DOCS and dodoc instead.
+ rm -r "${ED}/usr/share/doc/${PN}" || die
+ systemd_douserunit foot-server@.service "${S}"/foot-server@.socket
+}