summaryrefslogtreecommitdiff
path: root/gnustep-libs/sqlclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnustep-libs/sqlclient
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnustep-libs/sqlclient')
-rw-r--r--gnustep-libs/sqlclient/Manifest3
-rw-r--r--gnustep-libs/sqlclient/metadata.xml11
-rw-r--r--gnustep-libs/sqlclient/sqlclient-1.8.1.ebuild47
3 files changed, 61 insertions, 0 deletions
diff --git a/gnustep-libs/sqlclient/Manifest b/gnustep-libs/sqlclient/Manifest
new file mode 100644
index 000000000000..d2664f93a6be
--- /dev/null
+++ b/gnustep-libs/sqlclient/Manifest
@@ -0,0 +1,3 @@
+DIST SQLClient-1.8.1.tar.gz 148622 BLAKE2B 824d7510dacaa813b9b696530cbc4c3ab49c6de3303a6c4c8694226907c84b780f0eb5ec1298214247a41191a393931c89aba7d08c6e3cc5ef953fa6e1553ce1 SHA512 f0339063bf1f0a9050826440f9d4c116fddf61e62f4a8fd4c694afd079d82b54b306dcdadcd29951bbb3502129de211d166e2958de4d31cd6e78563498f2b50f
+EBUILD sqlclient-1.8.1.ebuild 1124 BLAKE2B 8e4fcdf6eef24215e962770b1ce54ba94c5af3182efc44e5e0b3c11ee94dee38eb5151382ac2340414679d9609e8365d5ead3146709e4a7d3f0bfb6a572b3f50 SHA512 83855211fe2bececedcec1bfc3ed309583b44001932b446d0cd0bbf6d14334b46a74c0c65402f02bd69b7e0bb3814cea09279eefc0a953bca79ef1c5c70bd020
+MISC metadata.xml 796 BLAKE2B 1695ffe2d2b9fe6ff8038689854907b7ec6290c027f3f7a5ab03098db92b79862ccfc67f6f5f8c3233aea0f06df37fce63f5f5361e43ea98186bb3a8a7a5bbc2 SHA512 a395bcea0e303cfd0a2a37fb51c13ea1828aad9e9dea0cc8d271e9f94d1073f1b99bf3162eaa2094e8e0e251e476505a1f94c1e4b00816e6cce4599e2cc02b4b
diff --git a/gnustep-libs/sqlclient/metadata.xml b/gnustep-libs/sqlclient/metadata.xml
new file mode 100644
index 000000000000..d044d0bd0362
--- /dev/null
+++ b/gnustep-libs/sqlclient/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnustep@gentoo.org</email>
+ <name>Gentoo GNUstep Project</name>
+ </maintainer>
+ <longdescription>The SQLClient library is designed to provide a simple interface to SQL databases for GNUstep applications. It does not attempt the sort of abstraction provided by the much more sophisticated GDL2 library but rather allows applications to directly execute SQL queries and statements.
+
+SQLClient provides for the Objective-C programmer much the same thing that JDBC provides for the Java programmer (though SQLClient is a bit faster, easier to use, and easier to add new database backends for than JDBC).</longdescription>
+</pkgmetadata>
diff --git a/gnustep-libs/sqlclient/sqlclient-1.8.1.ebuild b/gnustep-libs/sqlclient/sqlclient-1.8.1.ebuild
new file mode 100644
index 000000000000..6861f637d3cb
--- /dev/null
+++ b/gnustep-libs/sqlclient/sqlclient-1.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit java-pkg-opt-2 gnustep-2
+
+MY_P=${P/sqlc/SQLC}
+DESCRIPTION="GNUstep lightweight database abstraction layer"
+HOMEPAGE="http://wiki.gnustep.org/index.php/SQLClient"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="LGPL-3"
+SLOT="0"
+
+IUSE="java mysql postgres +sqlite"
+
+RDEPEND=">=gnustep-libs/performance-0.3.2
+ mysql? ( virtual/mysql:= )
+ postgres? ( dev-db/postgresql:= )
+ sqlite? ( >=dev-db/sqlite-3 )"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="|| ( java mysql postgres sqlite )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if ! use doc; then
+ # Remove doc target
+ sed -i -e '/documentation\.make/d' GNUmakefile \
+ || die "doc sed failed"
+ fi
+
+ default
+}
+
+src_configure() {
+ local myconf=""
+ use java || myconf="${myconf} --disable-jdbc-bundle"
+ use mysql || myconf="${myconf} --disable-mysql-bundle"
+ use postgres || myconf="${myconf} --disable-postgres-bundle"
+ use sqlite || myconf="${myconf} --disable-sqllite-bundle"
+
+ egnustep_env
+ econf ${myconf}
+}