summaryrefslogtreecommitdiff
path: root/gnustep-libs/performance
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnustep-libs/performance
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnustep-libs/performance')
-rw-r--r--gnustep-libs/performance/Manifest3
-rw-r--r--gnustep-libs/performance/metadata.xml9
-rw-r--r--gnustep-libs/performance/performance-0.5.0.ebuild26
3 files changed, 38 insertions, 0 deletions
diff --git a/gnustep-libs/performance/Manifest b/gnustep-libs/performance/Manifest
new file mode 100644
index 000000000000..a84e965ab476
--- /dev/null
+++ b/gnustep-libs/performance/Manifest
@@ -0,0 +1,3 @@
+DIST Performance-0.5.0.tar.gz 50569 BLAKE2B b79f27fc0974c6005725b916cfb528c15d380b62dea2b846c129fda04e4b56ad33d00c4432d19f0ee9bfa3593cd9fa8781d0dbd168c26cceb9e007054252d7b2 SHA512 ac83d046c801e1c2b69c708fa806cccf40fca4d5dabe5d461524c3c3eea989c939a11e58d8bff177f45e55a3e1be73bd03b0bb80b611c8390560740cd5cf9fd5
+EBUILD performance-0.5.0.ebuild 566 BLAKE2B 96076852e3b834a65b3d917196e4d8a9da4f71c91565e5a5acb692ce24438a391a168f8f2863eea74d7ac1b9f367720d0e6cc0ecc80b134fdeb159e1f7ad0b3e SHA512 a17efa9f4f9150868de791f64e981d0e42524c4d2a2a20ff619e86c20694a273a2f4951c2d3dc78957a531fd28815f528dbcdc2a2e8d571294aac88ef52e4e52
+MISC metadata.xml 368 BLAKE2B 653d9f2799b5cf5be3a6a8214fd71db599e2603f64bbf0d49320ad9b3b970c0aeb4977d736cd89b812afeffa1c3d3c107a780a9832e12cf50b4e1268b518fb32 SHA512 bbed0181555aa329b43ef8839daff91b7dc447a25992687b0009ab63327fb3568b5753bf3406febabc7c75f90f5786b70fdc7708f6bf99c3caaf7c39d750a40e
diff --git a/gnustep-libs/performance/metadata.xml b/gnustep-libs/performance/metadata.xml
new file mode 100644
index 000000000000..3f6082034133
--- /dev/null
+++ b/gnustep-libs/performance/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnustep@gentoo.org</email>
+ <name>Gentoo GNUstep Project</name>
+ </maintainer>
+ <longdescription>A collection of classes to help improve/tune performance of your software </longdescription>
+</pkgmetadata>
diff --git a/gnustep-libs/performance/performance-0.5.0.ebuild b/gnustep-libs/performance/performance-0.5.0.ebuild
new file mode 100644
index 000000000000..5f6bcc8b2665
--- /dev/null
+++ b/gnustep-libs/performance/performance-0.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnustep-2
+
+MY_P=${P/p/P}
+DESCRIPTION="Help improve the performance of GNUstep applications"
+HOMEPAGE="http://wiki.gnustep.org/index.php/Performance"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="LGPL-3"
+SLOT="0"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if ! use doc; then
+ # Remove doc target
+ sed -i -e '/documentation\.make/d' GNUmakefile \
+ || die "doc sed failed"
+ fi
+
+ default
+}