summaryrefslogtreecommitdiff
path: root/gnustep-libs/pantomime/pantomime-1.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /gnustep-libs/pantomime/pantomime-1.2.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'gnustep-libs/pantomime/pantomime-1.2.2.ebuild')
-rw-r--r--gnustep-libs/pantomime/pantomime-1.2.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnustep-libs/pantomime/pantomime-1.2.2.ebuild b/gnustep-libs/pantomime/pantomime-1.2.2.ebuild
new file mode 100644
index 000000000000..6a0806e6054e
--- /dev/null
+++ b/gnustep-libs/pantomime/pantomime-1.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils gnustep-2
+
+MY_P=${P/p/P}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A set of Objective-C classes that model a mail system"
+HOMEPAGE="http://www.collaboration-world.com/pantomime/"
+SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 Elm"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/openssl:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s|ADDITIONAL_LDFLAGS|LIBRARIES_DEPEND_UPON|" \
+ Framework/Pantomime/GNUmakefile || die "as-needed sed failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ cd "${S}"/Documentation
+ dodoc AUTHORS README TODO
+ docinto rfc
+ dodoc RFC/*
+}