summaryrefslogtreecommitdiff
path: root/gnustep-base/libobjc2/libobjc2-2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-13 00:46:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-13 00:46:32 +0000
commit360468f13add58583c7780bcacafb5452a07851d (patch)
treeb9894c277f3edb6e7270436ca2a7000e3575b0a0 /gnustep-base/libobjc2/libobjc2-2.2.ebuild
parentd71aca7673826d5f5fa93b43c7c8af3c1e023dc6 (diff)
gentoo auto-resync : 13:03:2024 - 00:46:32
Diffstat (limited to 'gnustep-base/libobjc2/libobjc2-2.2.ebuild')
-rw-r--r--gnustep-base/libobjc2/libobjc2-2.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnustep-base/libobjc2/libobjc2-2.2.ebuild b/gnustep-base/libobjc2/libobjc2-2.2.ebuild
new file mode 100644
index 000000000000..6e91f4972f94
--- /dev/null
+++ b/gnustep-base/libobjc2/libobjc2-2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="GNUstep Objective-C runtime"
+HOMEPAGE="https://gnustep.github.io"
+SRC_URI="https://github.com/gnustep/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-cpp/robin-map"
+BDEPEND="${RDEPEND}
+ sys-devel/clang"
+
+src_configure() {
+ export CC="clang"
+ export CXX="clang++"
+ local mycmakeargs=(
+ -DGNUSTEP_CONFIG=GNUSTEP_CONFIG-NOTFOUND
+ -DTESTS="$(usex test)"
+ )
+ cmake_src_configure
+}