summaryrefslogtreecommitdiff
path: root/gnustep-apps/textedit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnustep-apps/textedit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnustep-apps/textedit')
-rw-r--r--gnustep-apps/textedit/Manifest5
-rw-r--r--gnustep-apps/textedit/files/textedit-0.95_pre20100427-gcc47.patch20
-rw-r--r--gnustep-apps/textedit/files/textedit-0.95_pre20100427-nsinvalidargument.patch26
-rw-r--r--gnustep-apps/textedit/metadata.xml13
-rw-r--r--gnustep-apps/textedit/textedit-0.95_pre20100427-r1.ebuild21
5 files changed, 85 insertions, 0 deletions
diff --git a/gnustep-apps/textedit/Manifest b/gnustep-apps/textedit/Manifest
new file mode 100644
index 000000000000..cfc85c585580
--- /dev/null
+++ b/gnustep-apps/textedit/Manifest
@@ -0,0 +1,5 @@
+AUX textedit-0.95_pre20100427-gcc47.patch 1138 BLAKE2B c1d070e651a162a95f538bcd5ce67068d0c95e12f984c33f7e18dd2c1bda3eb514748930cf88fa20214680eecbdccce5261b0a3451433ef76771fe22241c73bc SHA512 d270ae159399c6a3c3bf8dc815aaf0cbc294151944ff08fe8691093fc8fa26332ec75a86afece97c3b73abb68660cc0e5fbe7ef1145b0a155aeda347c6c3c13e
+AUX textedit-0.95_pre20100427-nsinvalidargument.patch 706 BLAKE2B 3946e4e16f6de2312e779a9f0e16502d5a98d4581cf82e929212af171932ca1280311d837bda2cb5ae97e979211f66a9199f5aa063ad1078ab6f62bfeba2be2b SHA512 251418c683a8b29f47ddd8c67d59573673931576de6455b1365003f51f9c7a3ff53b4e3041e78fe0ed8eeaec62dd730a3c4da13cf30de9b0fea64423fc943f18
+DIST textedit-0.95_pre20100427.tar.gz 131332 BLAKE2B 443c54e243ca23bc1805778e912847f02bd118a9859a61f0c959a4cdeeba91f77daeb53f45f2de4d83defa421d11f3f5ae0c15585ee6ffbbe8dbb108f9a1b6e1 SHA512 df46ce1d0eb61ee776a0c4318f743f365d4d632ec0bbf9d04d1e6afbd35456f4a396fcafcac70e924475ccb2bb8dbbbf7dea18a68014f9634212c2803db59596
+EBUILD textedit-0.95_pre20100427-r1.ebuild 495 BLAKE2B 6bd0e12deaba0fcb5619ea00bd3600ff4a6ed5d0461c246188fbf6bffe11cc5dd16fd94690af10d00f6342fe6aae9dee163fdb6ee291414347f79495b09914c2 SHA512 b8ba3064d37b692d45ec276de39de9252359df9a3d9a6ca006e5afb33aaa0d94a554f270bbb0fd6ae4eba5eb57c18eb02f71c4ffc80a7db9c1094f3516b31fef
+MISC metadata.xml 394 BLAKE2B b7f81fb353d28af53c512d9382e041958efbfcd5f14d68b091f5b5a2f0cb7d36d26c4080dbeff5ef5138061143f06df62b016c97fccad12332ad1b4bb78f2240 SHA512 3ec6a6a517708d591b37510f55b26e22d42e31b42b24b8221a6834158dfa59ec42916c93ccf72a2043454bcb23235b322fc5419213f7122d6a2a7a96665e063e
diff --git a/gnustep-apps/textedit/files/textedit-0.95_pre20100427-gcc47.patch b/gnustep-apps/textedit/files/textedit-0.95_pre20100427-gcc47.patch
new file mode 100644
index 000000000000..b2a0bfedcd3c
--- /dev/null
+++ b/gnustep-apps/textedit/files/textedit-0.95_pre20100427-gcc47.patch
@@ -0,0 +1,20 @@
+--- textedit.app-4.0+20061029.orig/Document.m
++++ textedit.app-4.0+20061029/Document.m
+@@ -1361,13 +1361,13 @@ validateToggleItem (NSMenuItem *aCell, B
+ {
+ SEL action = [aCell action];
+ #ifdef GNUSTEP
+- const char *sel_name = sel_get_name (action);
++ const char *sel_name = sel_getName (action);
+
+- if (!strcmp (sel_name, sel_get_name (@selector (toggleRich:)))) {
++ if (!strcmp (sel_name, sel_getName (@selector (toggleRich:)))) {
+ validateToggleItem (aCell, [self isRichText], _(@"&Make Plain Text"), _(@"&Make Rich Text"));
+- } else if (!strcmp (sel_name, sel_get_name (@selector (togglePageBreaks:)))) {
++ } else if (!strcmp (sel_name, sel_getName (@selector (togglePageBreaks:)))) {
+ validateToggleItem (aCell, [self hasMultiplePages], _(@"&Wrap to Window"), _(@"&Wrap to Page"));
+- } else if (!strcmp (sel_name, sel_get_name (@selector (toggleHyphenation:)))) {
++ } else if (!strcmp (sel_name, sel_getName (@selector (toggleHyphenation:)))) {
+ if (!hyphenationSupported()) // Disable it
+ return NO;
+ validateToggleItem (aCell, ([self hyphenationFactor] > 0.0), _(@"Disallow &Hyphenation"), _(@"Allow &Hyphenation"));
diff --git a/gnustep-apps/textedit/files/textedit-0.95_pre20100427-nsinvalidargument.patch b/gnustep-apps/textedit/files/textedit-0.95_pre20100427-nsinvalidargument.patch
new file mode 100644
index 000000000000..345a0641fcbc
--- /dev/null
+++ b/gnustep-apps/textedit/files/textedit-0.95_pre20100427-nsinvalidargument.patch
@@ -0,0 +1,26 @@
+--- textedit.app-4.0+20061029.orig/Document.m
++++ textedit.app-4.0+20061029/Document.m
+@@ -124,12 +124,6 @@
+ [self setViewSize: size];
+ }
+
+- [[NSNotificationCenter defaultCenter]
+- addObserver: self
+- selector: @selector (fixUpScrollViewBackgroundColor:)
+- name: NSSystemColorsDidChangeNotification
+- object: nil];
+-
+ potentialSaveDirectory = nil;
+ return self;
+ }
+@@ -195,10 +189,6 @@
+ NSNotificationCenter *center = [NSNotificationCenter defaultCenter];
+
+ [center removeObserver: self
+- name: NSSystemColorsDidChangeNotification
+- object: nil];
+-
+- [center removeObserver: self
+ name: NSTextStorageDidProcessEditingNotification
+ object: [self textStorage]];
+
diff --git a/gnustep-apps/textedit/metadata.xml b/gnustep-apps/textedit/metadata.xml
new file mode 100644
index 000000000000..0c76e2ff1bd4
--- /dev/null
+++ b/gnustep-apps/textedit/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnustep@gentoo.org</email>
+ <name>Gentoo GNUstep Project</name>
+</maintainer>
+<longdescription>
+TextEdit
+
+This directory contains the source code for the TextEdit demo, which is a simple text editor.
+</longdescription>
+</pkgmetadata>
diff --git a/gnustep-apps/textedit/textedit-0.95_pre20100427-r1.ebuild b/gnustep-apps/textedit/textedit-0.95_pre20100427-r1.ebuild
new file mode 100644
index 000000000000..c1ded6382b92
--- /dev/null
+++ b/gnustep-apps/textedit/textedit-0.95_pre20100427-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils gnustep-2
+
+S=${WORKDIR}/TextEdit
+
+DESCRIPTION="A text editor with font, color, and style capabilities for GNUstep"
+HOMEPAGE="http://www.nongnu.org/backbone/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+KEYWORDS="amd64 ~ppc x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+ epatch "${FILESDIR}"/${P}-nsinvalidargument.patch
+}