summaryrefslogtreecommitdiff
path: root/gnustep-apps/gworkspace
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnustep-apps/gworkspace
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnustep-apps/gworkspace')
-rw-r--r--gnustep-apps/gworkspace/Manifest3
-rw-r--r--gnustep-apps/gworkspace/gworkspace-0.9.4.ebuild42
-rw-r--r--gnustep-apps/gworkspace/metadata.xml14
3 files changed, 59 insertions, 0 deletions
diff --git a/gnustep-apps/gworkspace/Manifest b/gnustep-apps/gworkspace/Manifest
new file mode 100644
index 000000000000..dbf2103c7384
--- /dev/null
+++ b/gnustep-apps/gworkspace/Manifest
@@ -0,0 +1,3 @@
+DIST gworkspace-0.9.4.tar.gz 3855909 BLAKE2B 5a636ccfb4fa79acd91bce34d3b5fe8a6d7bccc3f2f1f5a3d9f19c8a91743ec19c2eae0930e81807c6a5f098761b65f17e86a3edc44da155c50c903284ea2b20 SHA512 d2246b87be7d1659ecec3657c314ca333dc983509394c3e383b650056affd108b76241fa0fa59443b183a2e20906d9a7a9d1f2ad601cb569990b5490a6c5d2a7
+EBUILD gworkspace-0.9.4.ebuild 877 BLAKE2B c7d08f264f2984e9a439332ae869d2d3a712d206139cd609f45d72c28d51ffad872746a1d82dba9aeb581b9f19d6b8268e79e6f2ab22a740465534dd63341a7d SHA512 b1b2fa6096b78e3dc1713da29966e720a37927d45766130a90be609112b973a1a57b74b9bb4089f7df9f56279be7a5a7de906fac5139efb38e95783251a8319e
+MISC metadata.xml 579 BLAKE2B 1cee2bbb6f86ab94b59b6e3169c7ffbdb927b9f84c1c62e5c7935fb9ba158768f4a6911d3c357c5a30741843069f69986ad89d3139c614e7fc87572c096ad58c SHA512 d369179dfa43f986b92e64b7d458a00925b0700de1fd8ae910e37312529519694293734464e993ca071cdc995832c2125837c2e28497b10a9a885a4ebff94b12
diff --git a/gnustep-apps/gworkspace/gworkspace-0.9.4.ebuild b/gnustep-apps/gworkspace/gworkspace-0.9.4.ebuild
new file mode 100644
index 000000000000..72574db0a946
--- /dev/null
+++ b/gnustep-apps/gworkspace/gworkspace-0.9.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnustep-2
+
+DESCRIPTION="A workspace manager for GNUstep"
+HOMEPAGE="http://www.gnustep.org/experience/GWorkspace.html"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/usr-apps/${P}.tar.gz"
+
+KEYWORDS="amd64 ppc x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="+gwmetadata"
+
+DEPEND=">=gnustep-base/gnustep-gui-0.25.0
+ gwmetadata? (
+ >=gnustep-apps/systempreferences-1.0.1_p24791
+ >=dev-db/sqlite-3.2.8
+ )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myconf=""
+ use kernel_linux && myconf="${myconf} --with-inotify"
+ use gwmetadata && myconf="${myconf} --enable-gwmetadata"
+
+ egnustep_env
+ econf ${myconf}
+}
+
+src_install() {
+ egnustep_env
+ egnustep_install
+
+ if use doc;
+ then
+ dodir /usr/share/doc/${PF}
+ cp "${S}"/Documentation/*.pdf "${D}"/usr/share/doc/${PF}
+ fi
+}
diff --git a/gnustep-apps/gworkspace/metadata.xml b/gnustep-apps/gworkspace/metadata.xml
new file mode 100644
index 000000000000..be6503de9155
--- /dev/null
+++ b/gnustep-apps/gworkspace/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnustep@gentoo.org</email>
+ <name>Gentoo GNUstep Project</name>
+</maintainer>
+<longdescription>
+GWorkspace is the official GNUstep workspace manager. It is a clone of the NeXT workspace manager. GWorkspace is becoming more and more stable every day and it is already ready for daily usage.
+</longdescription>
+<use>
+ <flag name="gwmetadata">Enable the metadata indexing and searching system</flag>
+</use>
+</pkgmetadata>