summaryrefslogtreecommitdiff
path: root/gnustep-apps/gnumail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnustep-apps/gnumail
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnustep-apps/gnumail')
-rw-r--r--gnustep-apps/gnumail/Manifest5
-rw-r--r--gnustep-apps/gnumail/gnumail-1.2.2.ebuild34
-rw-r--r--gnustep-apps/gnumail/gnumail-1.2.3.ebuild33
-rw-r--r--gnustep-apps/gnumail/metadata.xml13
4 files changed, 85 insertions, 0 deletions
diff --git a/gnustep-apps/gnumail/Manifest b/gnustep-apps/gnumail/Manifest
new file mode 100644
index 000000000000..586b22ea7d4c
--- /dev/null
+++ b/gnustep-apps/gnumail/Manifest
@@ -0,0 +1,5 @@
+DIST GNUMail-1.2.2.tar.gz 1397764 BLAKE2B 8b913d31d93d8bdbd186ecb50530926ccfec4917b3f4bd1ed9c70b86a97110cb1bae620cb24d9f8e1dbcebb652dbf1d30847cf8fdbc68a5ed0b1ede214440c57 SHA512 3243c51eb177c1fabeeb894e6231e5ace09fb08fd0eb9d6311726bdebddc743e3b3958b4c00597e7eb97de7c2a25f1ca7e8f4111e7d543ecd65ee5f35bea89cc
+DIST GNUMail-1.2.3.tar.gz 1411658 BLAKE2B 25feddbe4cb18305421488d3452093b5ef9dd04d4742b06c9260cd5428befa2643af8c34d402ecbcbeed20866adaf3a11c927b7d4aaa141869259799f5b39633 SHA512 5ee9b134b16c9aa8a7a0d4aff1e9d12a8c8d4f1f68c54d58cc354c3444a57a4c0bb31393886589ef83ae588789f00fd6e1313d01eb1f950af6623cc9ee42e598
+EBUILD gnumail-1.2.2.ebuild 871 BLAKE2B 008b8b151e29b919429ba412804c2b2992daecdb83248d6b78390831d7ac446e6e4ae9c13d9f1a90d8663f022ec3f29028769a0fa2d290ad3cad4f590b1ef496 SHA512 5916e7e39f0600389dba2bf50510481ad1b9918a0925889cc3b552c7ea4853a97d4a0110516b71754cea6a5d4c6f0462b3e8722315b90fb57488035d2da6d491
+EBUILD gnumail-1.2.3.ebuild 736 BLAKE2B bde78c8b048ee40c66dd9d01e67895c99974ee4a53c7feeca36e4742a09223606eeaf1338ccc5e08ea6eb1e7608ee4518cddcd3b860be6b00d687718aa3dcbe9 SHA512 afe73dc6225e3b370dc5f7543bd8a942d2cf69de795113cdc3d63e817a6e8934e5b4d94a7b996a322bec622f8c71f43f0a0790fceaee84bf9ac675c693d273e4
+MISC metadata.xml 713 BLAKE2B b7dcad7f57d6ee2d2c8fd3d1fd581d8bf33f11efcebc41514c528f1694d3ead9f086e2ece07fe660696055a41f6c22cf6c06271cdedd7b16802dd6d737784243 SHA512 3abb024b255072dc2ec848d6d356d41ad131be58fbcf68a7cfd2cbd5c21842c2c0c237b84c69519720faf0ff9ac300e8753abfcfe983122a6c617c74e41f24e2
diff --git a/gnustep-apps/gnumail/gnumail-1.2.2.ebuild b/gnustep-apps/gnumail/gnumail-1.2.2.ebuild
new file mode 100644
index 000000000000..66e106bd9472
--- /dev/null
+++ b/gnustep-apps/gnumail/gnumail-1.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit gnustep-2
+
+MY_P=${P/gnum/GNUM}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A fully featured mail application for GNUstep"
+HOMEPAGE="http://www.collaboration-world.com/gnumail/"
+SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="crypt"
+DEPEND=">=gnustep-base/gnustep-gui-0.11.0
+ =gnustep-libs/pantomime-1.2*
+ gnustep-apps/addresses"
+RDEPEND="crypt? ( app-crypt/gnupg )"
+
+src_prepare() {
+ sed -i -e 's|GNUMail_GUI_LIBS =|LIBRARIES_DEPEND_UPON +=|' \
+ Framework/GNUMail/GNUmakefile || die "as-needed sed failed"
+ use crypt || sed -i -e 's|Bundles/PGP||' \
+ GNUmakefile || die "PGP bundle sed failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+ dodoc "${S}"/Documentation/*
+}
diff --git a/gnustep-apps/gnumail/gnumail-1.2.3.ebuild b/gnustep-apps/gnumail/gnumail-1.2.3.ebuild
new file mode 100644
index 000000000000..5cfe2b71f6c0
--- /dev/null
+++ b/gnustep-apps/gnumail/gnumail-1.2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnustep-2
+
+MY_P=${P/gnum/GNUM}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A fully featured mail application for GNUstep"
+HOMEPAGE="http://www.nongnu.org/gnustep-nonfsf/gnumail/index.html"
+SRC_URI="mirror://nongnu/gnustep-nonfsf/${MY_P}.tar.gz"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="crypt"
+DEPEND=">=gnustep-base/gnustep-gui-0.11.0
+ =gnustep-libs/pantomime-1.2*
+ gnustep-apps/addresses"
+RDEPEND="crypt? ( app-crypt/gnupg )"
+
+src_prepare() {
+ use crypt || sed -i -e 's|Bundles/PGP||' GNUmakefile || die
+
+ default
+}
+
+src_install() {
+ gnustep-base_src_install
+ dodoc "${S}"/Documentation/*
+}
diff --git a/gnustep-apps/gnumail/metadata.xml b/gnustep-apps/gnumail/metadata.xml
new file mode 100644
index 000000000000..f9a3efbf8402
--- /dev/null
+++ b/gnustep-apps/gnumail/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnustep@gentoo.org</email>
+ <name>Gentoo GNUstep Project</name>
+</maintainer>
+<longdescription>
+GNUMail.app is a fully featured mail application running on Linux (or FreeBSD, OpenBSD, etc) and Apple Mac OS X. It uses the GNUstep development framework or Apple Cocoa, which is based on the OpenStep specification provided by NeXT, Inc.. GNUMail.app is licensed under the GPL, and the full sources of the application are available.
+
+GNUMail.app was written from scratch. It uses Pantomime as its mail handling framework.
+</longdescription>
+</pkgmetadata>