summaryrefslogtreecommitdiff
path: root/gnustep-apps/gemas
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnustep-apps/gemas
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnustep-apps/gemas')
-rw-r--r--gnustep-apps/gemas/Manifest4
-rw-r--r--gnustep-apps/gemas/files/gemas-0.4-bundle_makefile.patch24
-rw-r--r--gnustep-apps/gemas/gemas-0.4.ebuild44
-rw-r--r--gnustep-apps/gemas/metadata.xml12
4 files changed, 84 insertions, 0 deletions
diff --git a/gnustep-apps/gemas/Manifest b/gnustep-apps/gemas/Manifest
new file mode 100644
index 000000000000..ba5dc8194497
--- /dev/null
+++ b/gnustep-apps/gemas/Manifest
@@ -0,0 +1,4 @@
+AUX gemas-0.4-bundle_makefile.patch 1171 BLAKE2B b6a4e93248b4891a7940f03e36ba6bf88bc47c57b42f7428dcc90d35b3c2ce8b17ecf74f2a58b85b22c43e4677bff010216bb6d7d689215cad2652e174fdb96a SHA512 0d53cf299be329b227152326c3e7e61dbbddfcbe3635a42a5e925a963aa3270d33fc42d9f8758824405bb3520128d4d521bbd4ed50f72d5f5945c565bce42638
+DIST Gemas-0.4.tar.gz 552558 BLAKE2B 0bc3c2ca5a54fd1af5e85816174473910743d0fd045934ccee170f6c13933cd9059fbe9d25040c3dbeeb91325a7c2573663929d7bb984735c2d68f059c665681 SHA512 6ae1acadd1be71362d93ac44498b789d160146f02c995280a003ac748c4d5dde615854014351c560e4e49576c20094dce0c4e2bef0c8096368c0c25679670e58
+EBUILD gemas-0.4.ebuild 911 BLAKE2B 85fa5a0737321e8cc4e4f2ca8d2e97c0fdbea27f2e3bd246eb84be0c7b0e211762799d8736a21e3ef82a52d42fc28e4bbd8d706242b6ee30e1a451a3efdf8f86 SHA512 5cceb8ba7319311bd3b42a6b7acb92f13fccee476898ae67dd886f73153df4bed3dc45213d4c1ceac0110be26fcc162cb01e3c8a97201a3e862fc03dade4083c
+MISC metadata.xml 650 BLAKE2B 2db84c12e3501cbb95af1f6d968aac83337414888094d4989b717eeaf39feddc9de9591c42a340fab70aa733ee60bc6c08e5dc5eaab07c249f3413e94d32f3c8 SHA512 a947ebcee4024d140b0aeb972cbd69b9fc13bb842fdf9866a660240b0914cbe7049c778929749735eabba0cc4a03fdf69aa65a9f324d4ec0386d33c73a1b4e9a
diff --git a/gnustep-apps/gemas/files/gemas-0.4-bundle_makefile.patch b/gnustep-apps/gemas/files/gemas-0.4-bundle_makefile.patch
new file mode 100644
index 000000000000..73595f256b56
--- /dev/null
+++ b/gnustep-apps/gemas/files/gemas-0.4-bundle_makefile.patch
@@ -0,0 +1,24 @@
+diff -Naur Gemas-0.4.orig/Bundle/Gemas/GNUmakefile Gemas-0.4/Bundle/Gemas/GNUmakefile
+--- Gemas-0.4.orig/Bundle/Gemas/GNUmakefile 2013-12-24 18:51:16.000000000 +0100
++++ Gemas-0.4/Bundle/Gemas/GNUmakefile 2014-02-10 10:50:45.331011111 +0100
+@@ -10,7 +10,7 @@
+ BUNDLE_NAME = Gemas
+ BUNDLE_EXTENSION = .editor
+ Gemas_PRINCIPAL_CLASS = GemasEditor
+-Gemas_INSTALL_DIR=$(GNUSTEP_LOCAL_APPS)/ProjectCenter.app/Resources
++Gemas_INSTALL_DIR=${DESTDIR}/$(GNUSTEP_SYSTEM_APPS)/ProjectCenter.app/Resources
+
+ #
+ # Additional libraries
+diff -Naur Gemas-0.4.orig/Bundle/Gemas/GNUmakefile.preamble Gemas-0.4/Bundle/Gemas/GNUmakefile.preamble
+--- Gemas-0.4.orig/Bundle/Gemas/GNUmakefile.preamble 2013-12-24 18:51:16.000000000 +0100
++++ Gemas-0.4/Bundle/Gemas/GNUmakefile.preamble 2014-02-10 10:50:50.622016109 +0100
+@@ -15,7 +15,7 @@
+ ADDITIONAL_LDFLAGS +=
+
+ # Additional include directories the compiler should search
+-ADDITIONAL_INCLUDE_DIRS +=-I$(GNUSTEP_LOCAL_HEADERS)/ProjectCenter
++ADDITIONAL_INCLUDE_DIRS +=-I$(GNUSTEP_SYSTEM_HEADERS)/ProjectCenter
+
+ # Additional library directories the linker should search
+ ADDITIONAL_LIB_DIRS += -L./HighlighterKit/HighlighterKit.framework
diff --git a/gnustep-apps/gemas/gemas-0.4.ebuild b/gnustep-apps/gemas/gemas-0.4.ebuild
new file mode 100644
index 000000000000..2fdf624eafe8
--- /dev/null
+++ b/gnustep-apps/gemas/gemas-0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils gnustep-2
+
+MY_P=${P/g/G}
+DESCRIPTION="a simple code editor for GNUstep"
+HOMEPAGE="http://wiki.gnustep.org/index.php/Gemas.app"
+SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="projectcenter"
+
+DEPEND=">=gnustep-libs/highlighterkit-0.1.2
+ >=virtual/gnustep-back-0.22.0
+ projectcenter? ( gnustep-apps/projectcenter )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-bundle_makefile.patch
+}
+
+src_compile() {
+ gnustep-base_src_compile
+ if use projectcenter;
+ then
+ cd Bundle/Gemas || die "compile cd failed"
+ egnustep_make
+ fi
+}
+
+src_install() {
+ gnustep-base_src_install
+ if use projectcenter;
+ then
+ cd Bundle/Gemas || die "install cd failed"
+ egnustep_install
+ fi
+}
diff --git a/gnustep-apps/gemas/metadata.xml b/gnustep-apps/gemas/metadata.xml
new file mode 100644
index 000000000000..3567c784835a
--- /dev/null
+++ b/gnustep-apps/gemas/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnustep@gentoo.org</email>
+ <name>Gentoo GNUstep Project</name>
+ </maintainer>
+ <longdescription>Gemas is a simple code editor for GNUstep. It have autoindentation and highlight syntax for C, C++, Objective-C, Objective-C++, GSmarkup. And to edit Strings, Plist, GNUmakefile, ChangeLog files and plain text files (INSTALL, README, ...)</longdescription>
+ <use>
+ <flag name="projectcenter">Build and install plugin for <pkg>gnustep-apps/projectcenter</pkg></flag>
+ </use>
+</pkgmetadata>