summaryrefslogtreecommitdiff
path: root/gnustep-apps/ftp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /gnustep-apps/ftp
reinit the tree, so we can have metadata
Diffstat (limited to 'gnustep-apps/ftp')
-rw-r--r--gnustep-apps/ftp/Manifest5
-rw-r--r--gnustep-apps/ftp/ftp-0.5.ebuild21
-rw-r--r--gnustep-apps/ftp/ftp-0.6.ebuild21
-rw-r--r--gnustep-apps/ftp/metadata.xml12
4 files changed, 59 insertions, 0 deletions
diff --git a/gnustep-apps/ftp/Manifest b/gnustep-apps/ftp/Manifest
new file mode 100644
index 000000000000..891017077c5d
--- /dev/null
+++ b/gnustep-apps/ftp/Manifest
@@ -0,0 +1,5 @@
+DIST FTP-0.5.tar.gz 132587 SHA256 159b297df1d797f6a4af2aa353380eeecc99078db27ecc5172e90c5bc3f06073 SHA512 186ea229d15d06f43410bfb7eaa5d50548f908f1675a0beae54dcbc9f7adeb62384ab68fee8980df582d0c257721fb3a56ea4968ecdc91c3301172d82d61bee7 WHIRLPOOL eded4bed4af37a14971527de67a3697ed7e19da387b5399f04184ef476bd365a7a690df58eb90f802c25eb0b253c4da0d2591b19ee54f0bf7427f19515253cce
+DIST FTP-0.6.tar.gz 161962 SHA256 f9884c1d0a3f37fea183ed1f80905d0f9ed3c99f776dc6a876434c7512c4d610 SHA512 c717a7163b98b00c20aa06ab9acc5f3abca0e2b035a3ad801d5339bc80ad54cd86f1e52c1a28f0d7fb931bf70f0565073c20f9ba5e129cb7514cf0a153ec16a4 WHIRLPOOL 041dc4d52d40565153434be5e27b8587a360ed0e2edaef30dddc578bafff947f91a5c6735c45b19edbf1a01baf87a150b84627a09b386f48e6195c3461ead61f
+EBUILD ftp-0.5.ebuild 403 SHA256 b1e96309850becae9d654bc67948f38aed69c5ea74df1d6306bdc159f2959694 SHA512 f1c7285ba5ed3da2c52516a815ac9a13701472b40a28296c3aacd51707528f24a9c7dbfaac868d6634743f43ea53860e756678ad88cc7ba2299e6c70b202fe97 WHIRLPOOL 402fbc9fc1c32fa4306b362ed427d147e0d39d38ce9c172609d8315bcbac82e1b7a6c4d7f03f0e1be9eb914cd3e81c61f96bb654f8bcfee3d967968eab033b69
+EBUILD ftp-0.6.ebuild 403 SHA256 b1e96309850becae9d654bc67948f38aed69c5ea74df1d6306bdc159f2959694 SHA512 f1c7285ba5ed3da2c52516a815ac9a13701472b40a28296c3aacd51707528f24a9c7dbfaac868d6634743f43ea53860e756678ad88cc7ba2299e6c70b202fe97 WHIRLPOOL 402fbc9fc1c32fa4306b362ed427d147e0d39d38ce9c172609d8315bcbac82e1b7a6c4d7f03f0e1be9eb914cd3e81c61f96bb654f8bcfee3d967968eab033b69
+MISC metadata.xml 758 SHA256 9d98f6c5742344562a26b40460f1f3e4667ea7f1c7fab5b2225ef3d4ad011953 SHA512 b002ee5e922f16c67876213e29a5009d67db75f5af1ed5cd847a4db1bf9b288768ec1d2ea786d941d8b4528d4faa2d256767666f4d857a1a3910b8bdf01da951 WHIRLPOOL 7e872dd304058df3dd29e45daa4db429ef181120d77fcba732c3a49a266e7bde7e95b862c8594bbaaf3522f64d79a91d76f6af006629db0cca35ad36296e1611
diff --git a/gnustep-apps/ftp/ftp-0.5.ebuild b/gnustep-apps/ftp/ftp-0.5.ebuild
new file mode 100644
index 000000000000..df4e52448d48
--- /dev/null
+++ b/gnustep-apps/ftp/ftp-0.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnustep-2
+
+MY_P="FTP-${PV}"
+
+DESCRIPTION="FTP client for GNUstep"
+HOMEPAGE="http://gap.nongnu.org/ftp/"
+SRC_URI="https://savannah.nongnu.org/download/gap/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
diff --git a/gnustep-apps/ftp/ftp-0.6.ebuild b/gnustep-apps/ftp/ftp-0.6.ebuild
new file mode 100644
index 000000000000..df4e52448d48
--- /dev/null
+++ b/gnustep-apps/ftp/ftp-0.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnustep-2
+
+MY_P="FTP-${PV}"
+
+DESCRIPTION="FTP client for GNUstep"
+HOMEPAGE="http://gap.nongnu.org/ftp/"
+SRC_URI="https://savannah.nongnu.org/download/gap/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
diff --git a/gnustep-apps/ftp/metadata.xml b/gnustep-apps/ftp/metadata.xml
new file mode 100644
index 000000000000..8c1fd1a8d59e
--- /dev/null
+++ b/gnustep-apps/ftp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnustep@gentoo.org</email>
+ <name>Gentoo GNUstep Project</name>
+</maintainer>
+<longdescription>FTP is a file transfer application (RFC 765) featuring a compact and easy interface. As most applications in GAP it tries to work on both GNUstep and MacOS X and retain the utmost possible simlilarity among the two version to ease working in both environments.
+
+Two panes manage local (left) and remote (right) resources.
+Transfer of single files as well as multiple selection is possible, recursive upload (directories and sub-directories) is performed transparently.</longdescription>
+</pkgmetadata>