summaryrefslogtreecommitdiff
path: root/gnustep-apps/cynthiune
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnustep-apps/cynthiune
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnustep-apps/cynthiune')
-rw-r--r--gnustep-apps/cynthiune/Manifest3
-rw-r--r--gnustep-apps/cynthiune/cynthiune-1.0.0.ebuild59
-rw-r--r--gnustep-apps/cynthiune/metadata.xml45
3 files changed, 107 insertions, 0 deletions
diff --git a/gnustep-apps/cynthiune/Manifest b/gnustep-apps/cynthiune/Manifest
new file mode 100644
index 000000000000..b203832d13a6
--- /dev/null
+++ b/gnustep-apps/cynthiune/Manifest
@@ -0,0 +1,3 @@
+DIST Cynthiune-1.0.0.tar.gz 570554 BLAKE2B 84cf68622c75b3e2b978aef2d8e3ab1de582d58a3d0c9cd7fac47c30cde69e61a16016abcfe0290339648cda58e0600fc21dae3ce97d3d0ec07013af9cb1c366 SHA512 ae56a77a138b2f661ecedbbad89935c3e8ec44447b000b73985577ea28304d11bb957fe118ba844168e9c7a06a229e8b024a6bc6eb4199080d6e69b77a31b4b7
+EBUILD cynthiune-1.0.0.ebuild 1702 BLAKE2B ad1e73150726a8867f12ac347ba455a0f83ea0181856f10bd8954658b77edf577218ea54efa31c1f071c227ee64792dccadb940f5734960b0b5edf07e201dfad SHA512 b991e8e64fa3a2c5906c47a6e50e9f49d1e13d002eb4cf7f4eeb77e7e379b93052f269f03b5d403a9e34e9e1e9743b1791857903fafbd06e84451c27bd25648d
+MISC metadata.xml 2309 BLAKE2B 2e481586c05f827797dbf4e4994dd6f4d17024ec9326090208fe8332efa0722ae6d6cde1e12658091ea8af1e032af7b15afd5d1c36a82336ffe4824dee510674 SHA512 ba9ac73bb2da9a4bb0935c3bad93a7ed9b78ef2ef1e43264e6c09558954c8a725ba3c1df88fec14fc0d7a2cb6a953d1aeb612b16edfdd4b1a7f14e42eb58c0a8
diff --git a/gnustep-apps/cynthiune/cynthiune-1.0.0.ebuild b/gnustep-apps/cynthiune/cynthiune-1.0.0.ebuild
new file mode 100644
index 000000000000..f6c3a25f513b
--- /dev/null
+++ b/gnustep-apps/cynthiune/cynthiune-1.0.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit gnustep-2
+
+MY_P=${P/c/C}
+DESCRIPTION="Free software and romantic music player for GNUstep"
+HOMEPAGE="http://gap.nongnu.org/cynthiune/"
+SRC_URI="https://savannah.nongnu.org/download/gap/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="alsa ao flac mad modplug musepack oss timidity vorbis"
+
+# musicbrainz disabled upstream for now
+RDEPEND="media-libs/audiofile
+ media-libs/taglib
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ flac? ( media-libs/flac )
+ mad? ( media-libs/libid3tag
+ media-libs/libmad )
+ musepack? ( >=media-sound/musepack-tools-444 )
+ modplug? ( media-libs/libmodplug )
+ timidity? ( media-sound/timidity++ )
+ vorbis? ( >=media-libs/libogg-1.1.2
+ >=media-libs/libvorbis-1.0.1-r2 )"
+DEPEND="${RDEPEND}
+ mad? ( virtual/pkgconfig )"
+
+S=${WORKDIR}/${MY_P}
+
+cynthiune_get_config() {
+ local myconf="disable-windowsmedia=yes disable-esound=yes"
+ use alsa || myconf="${myconf} disable-alsa=yes"
+ use ao || myconf="${myconf} disable-ao=yes"
+ use flac || myconf="${myconf} disable-flac=yes disable-flactags=yes"
+ use mad || myconf="${myconf} disable-mp3=yes disable-id3tag=yes"
+ use modplug || myconf="${myconf} disable-mod=yes"
+ use musepack || myconf="${myconf} disable-musepack=yes"
+ use oss || myconf="${myconf} disable-oss=yes"
+ use timidity || myconf="${myconf} disable-timidity=yes"
+ use vorbis || myconf="${myconf} disable-ogg=yes disable-vorbistags=yes"
+
+ echo ${myconf}
+}
+
+src_compile() {
+ egnustep_env
+ egnustep_make "$(cynthiune_get_config)"
+}
+
+src_install() {
+ egnustep_env
+ egnustep_install "$(cynthiune_get_config)"
+}
diff --git a/gnustep-apps/cynthiune/metadata.xml b/gnustep-apps/cynthiune/metadata.xml
new file mode 100644
index 000000000000..69269796fe98
--- /dev/null
+++ b/gnustep-apps/cynthiune/metadata.xml
@@ -0,0 +1,45 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnustep@gentoo.org</email>
+ <name>Gentoo GNUstep Project</name>
+</maintainer>
+<longdescription>
+Cynthiune (january 2004)
+=========
+
+What is Cynthiune?
+------------------
+Cynthiune is a free software and romantic music player for GNUstep and MacOSX.
+I wrote it originally as a christmas gift to a girl that I liked because she
+could not listen to music on her Mac with a free program. Since then, I decided
+to make it public and add even more features to make it a complete and useable
+media player.
+
+For the moment, it looks pretty much like XMMS, Winamp and similar software.
+Even though it has far less features than those, the essential components of a
+usable and user-friendly program are there in my opinion.
+
+From a programmatic point-of-view, I have decided to write a program that is
+released only when considered bug-free. The free software community lacks,
+IMnsHO, a sense of quality that makes its programs nearly useless to
+lambda users. Not only is it useless, but I think it also gives free software
+a bad reputation. The principle of freedom in "free software" is fundamental
+to me, but it has to be reachable not only by some sort of geeky elite. There
+is no point in telling users that since they have the freedom to enhance those
+programs, they must fix them if they want to use them. Releasing a program
+with too many bugs is of no use and is likely not to interest other fellow
+programmers in the community either.
+
+On the other hand, Apple has published an interesting program called "iTunes".
+Of course, it is not free software but it does implement interesting ideas
+that I would like to include in Cynthiune. For example: CD burning, complete
+playlist management, etc... Personally I find its user interface to be not as
+user-friendly as it could be. My plan is thus to take advantage of my own
+programming skills and sense of aesthetics (and ergonomy) to try to write
+something a little bit different, inspired both by XMMS/Winamp and iTunes.
+Cynthiune is thus currently very basic but its core design is starting to be
+extensible enough that it will not be too much trouble to enhance it.
+</longdescription>
+</pkgmetadata>