summaryrefslogtreecommitdiff
path: root/gnustep-apps/cenon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnustep-apps/cenon
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnustep-apps/cenon')
-rw-r--r--gnustep-apps/cenon/Manifest6
-rw-r--r--gnustep-apps/cenon/cenon-4.0.2-r1.ebuild26
-rw-r--r--gnustep-apps/cenon/files/cenon-4.0.2-check-return-value.patch40
-rw-r--r--gnustep-apps/cenon/files/cenon-4.0.2-gnustep-gui-0.24-support.patch231
-rw-r--r--gnustep-apps/cenon/files/cenon-4.0.2-install.patch19
-rw-r--r--gnustep-apps/cenon/metadata.xml13
6 files changed, 335 insertions, 0 deletions
diff --git a/gnustep-apps/cenon/Manifest b/gnustep-apps/cenon/Manifest
new file mode 100644
index 000000000000..6c359a4dacb7
--- /dev/null
+++ b/gnustep-apps/cenon/Manifest
@@ -0,0 +1,6 @@
+AUX cenon-4.0.2-check-return-value.patch 1416 BLAKE2B fa71100d4dc75119f3b853ad246ce81a9703d26fd1a90ed8a40cf34d1c472f15a94c5328e333b616d820aef9bbf7d6426b612ef1b92c118eeda90595bedbf372 SHA512 07cd48ed24fc791a5b3921cae99b4bcd9a36167b1d4c376881b82f420c7870ea2ae02aaf1cade56bc88b3f306154e60d3e64a9c2b6fe880ead317250e0ada921
+AUX cenon-4.0.2-gnustep-gui-0.24-support.patch 7456 BLAKE2B 87be676970631e905cef75c1d4f7fa4b49449c24987d561851a888e0e510d18ed645047baf8b50db42ef045fc49f2de34a7c6878b2598eca5b5ad67a14b38439 SHA512 a740fda5548284d4d6ad46d972c19b23382b6d0e4b92573c9edebe1eb362f13863bc9e8b50fcfd0c9f450fea979ba781ce3723fe692f862ed23fc0e7f02b23b7
+AUX cenon-4.0.2-install.patch 690 BLAKE2B 64eff078e98b8d4052af2801517c0712384222007eb3af343f92793a42d4f4b5fdcc347b70b8832062471b73a13eb32d811de7a26b18e0b70005d4cc57b3de1c SHA512 fece9ed365b6fa5ca2b897b64c073eb780c6270f6e7f8c7e92748c54626cda3a47872245869f4e3ba8b8fbd9ee8bf8665b0feb1574daca006f828d363e95ad21
+DIST Cenon-4.0.2.tar.bz2 4150615 BLAKE2B 75252c6495c0cdba32f18e31674ff1c4f8e3d6c7f94b56ac763bcd7d8bcb401fe6817e0a06642dc927ff87c32956e9277a777a7744a8a33135a4e3a76aa511cc SHA512 94bf95dbdb8fbe9c21fbe80cbc33fbe376c598cf79be295cb1045a0ac888da5363f388f3f051d593ca47f6c1fcbade2825389aec5da328c59158a1e5da89db75
+EBUILD cenon-4.0.2-r1.ebuild 677 BLAKE2B 6ceb3cd274d1c4f3f24713fbf6fc26a7527bd89cf905eacd3ae8b215cc6aeb040b804386ef5a11b5801007f1c3a39b717e4a2c53ddd04d2bd28a222052c82716 SHA512 f52dfb053603ecfee1a702e9e6ed28d3247401ebcc68aae84af489c9d3878bb8040a7113bbc50fe90fa8ffc1e9de190e5b9e7819aac56fe8fee434e500b36ee9
+MISC metadata.xml 447 BLAKE2B cb51c659c741f694f0e13e16113d92e3211b52105bdaa29754c0f3ed040dd6d37bb1873b438d779a6f26080a23a25659a349405c28e4a05f0949c8472ed8d300 SHA512 8b1bf24888d06c487d4601bd31d5184070554ecd59923a3de482b4fcce6f5130c706f68d4b35d1545be4a1fbbd76ac36f3072df1c6f5e92c03d8ee3d566b72a3
diff --git a/gnustep-apps/cenon/cenon-4.0.2-r1.ebuild b/gnustep-apps/cenon/cenon-4.0.2-r1.ebuild
new file mode 100644
index 000000000000..209586efc0a7
--- /dev/null
+++ b/gnustep-apps/cenon/cenon-4.0.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit gnustep-2
+
+S=${WORKDIR}/${PN/c/C}
+
+DESCRIPTION="Cenon is a vector graphics tool for GNUstep, OpenStep and MacOSX"
+HOMEPAGE="http://www.cenon.info/"
+SRC_URI="http://www.cenon.zone/download/source/${P/c/C}.tar.bz2"
+KEYWORDS="amd64 ppc x86"
+SLOT="0"
+LICENSE="Cenon"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=gnustep-libs/cenonlibrary-4.0.0"
+
+src_prepare() {
+ # Do not install files already provided by cenonlibrary
+ epatch "${FILESDIR}"/${P}-install.patch
+
+ epatch "${FILESDIR}"/${P}-check-return-value.patch
+ epatch "${FILESDIR}"/${P}-gnustep-gui-0.24-support.patch
+}
diff --git a/gnustep-apps/cenon/files/cenon-4.0.2-check-return-value.patch b/gnustep-apps/cenon/files/cenon-4.0.2-check-return-value.patch
new file mode 100644
index 000000000000..a23135b3230d
--- /dev/null
+++ b/gnustep-apps/cenon/files/cenon-4.0.2-check-return-value.patch
@@ -0,0 +1,40 @@
+Description: Check the return value of `system'.
+Author: Yavor Doganov <yavor@gnu.org>
+Forwarded: yes
+Last-Update: 2014-06-25
+---
+
+--- cenon.app.orig/VHFImport/PSImport.m
++++ cenon.app/VHFImport/PSImport.m
+@@ -143,7 +143,14 @@
+
+ /* convert pdf to eps */
+ commandLine = [NSString stringWithFormat:@"%@ -q -dNOPAUSE -dBATCH -dSAFER -sDEVICE=epswrite -sOutputFile=%@ -c save pop -f '%@'", [self gsPath], psFile, pdfFile];
+- system([commandLine UTF8String]);
++ if (system([commandLine UTF8String]) != 0)
++ {
++ NSRunAlertPanel(@"Unable to import file",
++ @"An error occured while importing the file.\n"
++ @"Make sure you have ghostscript installed in PATH.",
++ @"OK", nil, nil);
++ return nil;
++ }
+
+ /* import ps */
+ psData = [NSData dataWithContentsOfFile:psFile];
+@@ -330,7 +337,14 @@
+ //[data writeToFile:inFile atomically:NO]; // <= 10.4
+
+ commandLine = [NSString stringWithFormat:@"%@ -dNODISPLAY -dBATCH -dNOSAFER -g1000x1000 '%@'", [self gsPath], inFile];
+- system([commandLine UTF8String]);
++ if (system([commandLine UTF8String]) != 0)
++ {
++ NSRunAlertPanel(@"Unable to import file",
++ @"An error occured while importing the file.\n"
++ @"Make sure you have ghostscript installed in PATH.",
++ @"OK", nil, nil);
++ return nil;
++ }
+
+ /* load generated file */
+ //data = [[[NSString alloc] initWithContentsOfFile:outFile] autorelease];
diff --git a/gnustep-apps/cenon/files/cenon-4.0.2-gnustep-gui-0.24-support.patch b/gnustep-apps/cenon/files/cenon-4.0.2-gnustep-gui-0.24-support.patch
new file mode 100644
index 000000000000..b0799d835175
--- /dev/null
+++ b/gnustep-apps/cenon/files/cenon-4.0.2-gnustep-gui-0.24-support.patch
@@ -0,0 +1,231 @@
+Description: Various fixes for gnustep-base/1.24 and gnustep-gui/0.24.
+ - Proper intialization.
+ - Use correct return types for methods and compare functions.
+ - Likewise for method arguments.
+ - Avoid conflicting methods by declaring the ivars of a specific type.
+ - Add mising argument to private method declaration.
+Author: Yavor Doganov <yavor@gnu.org>
+Bug-Debian: http://bugs.debian.org/749553
+Forwarded: yes
+Last-Update: 2014-06-25
+---
+
+--- cenon.app.orig/GraphicObjects.subproj/VCurveFit.m
++++ cenon.app/GraphicObjects.subproj/VCurveFit.m
+@@ -87,7 +87,7 @@
+ /* turn lines into optimized curves
+ */
+ - (VPath*)fitGraphic:(VGraphic*)g maxError:(double)maxError
+-{ Point2 *pts = nil;
++{ Point2 *pts = NULL;
+ int i, nPts = 0;
+ VPath *path = nil;
+
+--- cenon.app.orig/GraphicObjects.subproj/VGroup.h
++++ cenon.app/GraphicObjects.subproj/VGroup.h
+@@ -67,7 +67,7 @@
+ - (float)stepWidth;
+ - (void)setRadialCenter:(NSPoint)rc;
+ - (NSPoint)radialCenter;
+-- (void)setList:(NSArray*)aList;
++- (void)setList:(NSMutableArray*)aList;
+ - (void)addObject:(VGraphic*)g;
+ - (void)add:(NSArray*)addList;
+ - (NSMutableArray*)list;
+--- cenon.app.orig/InspectorPanel.subproj/IPAllAcc.h
++++ cenon.app/InspectorPanel.subproj/IPAllAcc.h
+@@ -40,7 +40,7 @@
+
+ @interface IPAllAcc:IPBasicLevel
+ {
+- id accPopup; // the popup to allow the user to select the different accessories
++ NSPopUpButton *accPopup; // the popup to allow the user to select the different accessories
+ id accView; // the view containing the accessory view
+
+ int levelCnt; // number of accessories
+--- cenon.app.orig/InspectorPanel.subproj/IPAllFilling.h
++++ cenon.app/InspectorPanel.subproj/IPAllFilling.h
+@@ -39,7 +39,7 @@
+ id stepForm;
+ id colorWell;
+ id colorWellGraduated;
+- id fillPopup;
++ NSPopUpButton *fillPopup;
+ id sliderBox;
+ id radialCenterText;
+ id angleButtonLeft;
+--- cenon.app.orig/InspectorPanel.subproj/IPAllStrokeWidth.h
++++ cenon.app/InspectorPanel.subproj/IPAllStrokeWidth.h
+@@ -35,7 +35,7 @@
+ @interface IPAllStrokeWidth:IPBasicLevel
+ {
+ int stroked;
+- id strokePopup;
++ NSPopUpButton *strokePopup;
+ id colorWell;
+ id widthField;
+ id widthSlider;
+--- cenon.app.orig/LayerObject.h
++++ cenon.app/LayerObject.h
+@@ -144,8 +144,8 @@
+ - (void)setString:(NSString *)aString;
+ - (NSString*)string;
+
+-- (void)setTag:(int)newTag;
+-- (int)tag;
++- (void)setTag:(NSInteger)newTag;
++- (NSInteger)tag;
+
+ - (void)setColor:(NSColor *)aColor;
+ - (NSColor *)color;
+--- cenon.app.orig/LayerObject.m
++++ cenon.app/LayerObject.m
+@@ -227,8 +227,8 @@
+ - (void)setString:(NSString *)aString { [string release]; string = [aString retain]; }
+ - (NSString *)string { return string; }
+
+-- (void)setTag:(int)newTag { tag = newTag; }
+-- (int)tag { return tag; }
++- (void)setTag:(NSInteger)newTag { tag = newTag; }
++- (NSInteger)tag { return tag; }
+
+ - (void)setColor:(NSColor *)aColor { color=aColor; }
+ - (NSColor *)color { return color; }
+--- cenon.app.orig/GraphicObjects.subproj/VPath.h
++++ cenon.app/GraphicObjects.subproj/VPath.h
+@@ -58,7 +58,7 @@
+ - (NSMutableArray*)list;
+ - (void)setList:aList;
+ - (void)setList:aList optimize:(BOOL)optimize;
+-- (unsigned)count;
++- (NSUInteger)count;
+ - (unsigned)countRecursive;
+ - (void)getEndPoints:(NSPoint*)p1 :(NSPoint*)p2;
+ - (int)selectedKnobIndex;
+--- cenon.app.orig/GraphicObjects.subproj/VPath.m
++++ cenon.app/GraphicObjects.subproj/VPath.m
+@@ -399,7 +399,7 @@
+ *p2 = [[list objectAtIndex:[list count]-1] pointWithNum:MAXINT];
+ }
+
+-- (unsigned)count
++- (NSUInteger)count
+ {
+ return [list count];
+ }
+--- cenon.app.orig/InspectorPanel.subproj/IPImage.h
++++ cenon.app/InspectorPanel.subproj/IPImage.h
+@@ -43,7 +43,7 @@
+ id thumbSwitch;
+ id nameField;
+ id factorField;
+- id compPopUp;
++ NSPopUpButton *compPopUp;
+
+ VGraphic *graphic; // the loaded graphic or the first of them if multiple
+ }
+--- cenon.app.orig/DINImportSub.m
++++ cenon.app/DINImportSub.m
+@@ -46,7 +46,7 @@
+ /* created: 2001-06-06
+ * performcance map is not used, because we set this later when the layers are added to the view!
+ */
+-static NSInteger sortLayer(id l1, id l2, void *context)
++static NSComparisonResult sortLayer(id l1, id l2, void *context)
+ { float d1 = 0.0, d2 = 0.0;
+ VGraphic *g0 = [[l1 list] objectAtIndex:0], *g1 = [[l2 list] objectAtIndex:0];
+
+--- cenon.app.orig/DocView.m
++++ cenon.app/DocView.m
+@@ -994,7 +994,7 @@
+ #define SORT_COL_LRUL 5
+ #define SORT_ROW_URLL 6
+ #define SORT_ROW_LRUL 7
+-NSInteger sortPosition(id g1, id g2, void *context)
++NSComparisonResult sortPosition(id g1, id g2, void *context)
+ { NSPoint p1 = [g1 bounds].origin, p2 = [g2 bounds].origin;
+ int sort = *(int*)context;
+
+--- cenon.app.orig/SVGImportSub.m
++++ cenon.app/SVGImportSub.m
+@@ -112,7 +112,7 @@
+ /* allocate a group object
+ * copy the objects in aList to the group, add the group to bList
+ */
+-- (void)addGroupList:(NSArray*)aList toList:bList
++- (void)addGroupList:(NSMutableArray*)aList toList:bList
+ { VGroup *g = [VGroup group];
+ int i;
+ NSMutableArray *mutArray = [NSMutableArray array];
+@@ -136,7 +136,7 @@
+ [bList addObject:g];
+ }
+
+-- (void)addGroupList:(NSArray*)aList toList:bList withTransform:(NSAffineTransform*)matrix
++- (void)addGroupList:(NSMutableArray*)aList toList:bList withTransform:(NSAffineTransform*)matrix
+ { VGroup *g = [VGroup group];
+ int i;
+ NSMutableArray *mutArray = [NSMutableArray array];
+--- cenon.app.orig/MoveCell.h
++++ cenon.app/MoveCell.h
+@@ -32,7 +32,7 @@
+
+ @interface MoveCell:NSCell
+ {
+- int tag;
++ NSInteger tag;
+ MoveMatrix *moveMatrix;
+
+ float ascender, descender, lineHeight;
+@@ -41,8 +41,8 @@
+ - (void)setMatrix:(MoveMatrix *)anMatrix;
+ - (void)setFont:(NSFont *)fontObj;
+
+-- (void)setTag:(int)anInt;
+-- (int)tag;
++- (void)setTag:(NSInteger)anInt;
++- (NSInteger)tag;
+
+ - (BOOL)dependant;
+
+--- cenon.app.orig/MoveCell.m
++++ cenon.app/MoveCell.m
+@@ -39,14 +39,14 @@
+
+ /* modified: 13.01.93
+ */
+-- (void)setTag:(int)anInt
++- (void)setTag:(NSInteger)anInt
+ {
+ tag=anInt;
+ }
+
+ /* modified: 13.01.93
+ */
+-- (int)tag
++- (NSInteger)tag
+ {
+ return tag;
+ }
+--- cenon.app.orig/VHFImport/DXFImport.m
++++ cenon.app/VHFImport/DXFImport.m
+@@ -86,7 +86,7 @@
+ - (BOOL)getSolid:(NSScanner*)scanner :(NSPoint*)ps :(int*)pCnt;
+ - (BOOL)getCircle:(NSScanner*)scanner :(NSPoint*)ctr :(NSPoint*)start :(float*)angle;
+ - (BOOL)getArc:(NSScanner*)scanner :(NSPoint*)ctr :(NSPoint*)start :(float*)angle;
+-- (BOOL)getText :(NSScanner*)scanner mtext:(BOOL)mext :(NSString**)string :(float*)angle :(NSPoint*)origin :(float*)size :(float*)ar :(int*)alignment;
++- (BOOL)getText :(NSScanner*)scanner mtext:(BOOL)mext :(NSString**)string :(float*)angle :(NSPoint*)origin :(float*)size :(float*)ar :(int*)alignment :(NSString**)fontName;
+ - (BOOL)get3DFace:(NSScanner*)scanner points:(V3Point*)pts color:(NSColor**)color;
+ - (BOOL)getInsert:(NSScanner*)scanner :cList;
+ - (void)updateBounds:(NSPoint)p;
+--- cenon.app.orig/TileScrollView.h
++++ cenon.app/TileScrollView.h
+@@ -36,7 +36,7 @@
+ @interface TileScrollView:NSScrollView
+ {
+ id box;
+- id resPopupListButton;
++ NSPopUpButton *resPopupListButton;
+ id document;
+ VFloat oldScaleFactor;
+ }
diff --git a/gnustep-apps/cenon/files/cenon-4.0.2-install.patch b/gnustep-apps/cenon/files/cenon-4.0.2-install.patch
new file mode 100644
index 000000000000..8a75db6ee13a
--- /dev/null
+++ b/gnustep-apps/cenon/files/cenon-4.0.2-install.patch
@@ -0,0 +1,19 @@
+diff -Naur Cenon.orig/GNUmakefile.postamble Cenon/GNUmakefile.postamble
+--- Cenon.orig/GNUmakefile.postamble 2013-04-23 18:18:19.231871028 +0200
++++ Cenon/GNUmakefile.postamble 2013-04-23 18:19:31.482864370 +0200
+@@ -18,12 +18,12 @@
+ # before-install::
+
+ # Things to do after installing
+-after-install::
++#after-install::
+ # copy library
+ #rm -R $(GNUSTEP_LIBRARY)/$(APP_NAME)
+- cp -R Library/$(APP_NAME)/ $(GNUSTEP_LIBRARY)/
++ #cp -R Library/$(APP_NAME)/ $(GNUSTEP_LIBRARY)/
+ # set permissions (rrr)
+- chmod -R ugo+rX $(GNUSTEP_APPS)/$(APP_NAME).*
++ #chmod -R ugo+rX $(GNUSTEP_APPS)/$(APP_NAME).*
+ #chmod -R ugo+rX $(GNUSTEP_LIBRARY)/$(APP_NAME)
+
+ # Things to do before uninstalling
diff --git a/gnustep-apps/cenon/metadata.xml b/gnustep-apps/cenon/metadata.xml
new file mode 100644
index 000000000000..82760064a1ed
--- /dev/null
+++ b/gnustep-apps/cenon/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnustep@gentoo.org</email>
+ <name>Gentoo GNUstep Project</name>
+ </maintainer>
+ <longdescription>
+ Cenon is a graphical tool of a special kind. Build upon a
+ modular graphical core, Cenon offers a wide variety of
+ possibilities and applications.
+ </longdescription>
+</pkgmetadata>