summaryrefslogtreecommitdiff
path: root/gnome-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
commitf625b9919a60a30f1bd860f7d1b2eac183ced593 (patch)
tree7543f00925ff7277e31881de0a87801681f6f92f /gnome-extra
parente3872864be25f7421015bef2732fa57c0c9fb726 (diff)
gentoo resync : 08.08.2018
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/Manifest.gzbin10688 -> 10858 bytes
-rw-r--r--gnome-extra/authenticator/Manifest5
-rw-r--r--gnome-extra/authenticator/authenticator-0.2.1.ebuild55
-rw-r--r--gnome-extra/authenticator/authenticator-9999.ebuild55
-rw-r--r--gnome-extra/authenticator/files/disable-failing-tests.patch24
-rw-r--r--gnome-extra/authenticator/metadata.xml19
6 files changed, 158 insertions, 0 deletions
diff --git a/gnome-extra/Manifest.gz b/gnome-extra/Manifest.gz
index 47142fe3179f..be5917694e35 100644
--- a/gnome-extra/Manifest.gz
+++ b/gnome-extra/Manifest.gz
Binary files differ
diff --git a/gnome-extra/authenticator/Manifest b/gnome-extra/authenticator/Manifest
new file mode 100644
index 000000000000..3b5a8c7e2b53
--- /dev/null
+++ b/gnome-extra/authenticator/Manifest
@@ -0,0 +1,5 @@
+AUX disable-failing-tests.patch 784 BLAKE2B 67367ef35234046a2fdedd8d82c0c2037ecbe8005e9972d05c9654645225f42d23a4fbe0b819daa6fdf219d4852284fc068d24227a89bd4afc4c15e4792c2d8d SHA512 226bce7609fedf6cf9a3459d5945f0ca31004df595fd6717781dce142bd53f5c552821031b3de516964a97abc91efaadf902b943aa0a149ed3603ae26aa0355e
+DIST authenticator-0.2.1.tar.gz 147693 BLAKE2B b9f3a7fd5b3b7867120b9ed17b90cea4c07a271dc4d75a845ad539e15453a606d48e8637d44d12cecf9b91e5fb351d081c1add48c1a4a955444f39addd51b075 SHA512 aebf3ce147d5ccd404de6af52e130e9a85a3d5d86140d73026dac00219853652e7aa1e67db5838f9ac4d147021cd07b3ebfb86a1ab4b413ec3b98360097d1d6e
+EBUILD authenticator-0.2.1.ebuild 1135 BLAKE2B 2a6d45a38a6d6cfa038e43d55608435a4a42305ded96868a87c9e48afa22a60ced6dc8befc5af05e2bae7ecca4194f97400c46494c942c0c9abf271473cfc584 SHA512 b0c5aa1d701e714e754d396474d25b0bd98b4169020368ffc2aceb97abe208cebb169c0d431e843663ff77ee8964e3997846a35a926556fb120d6311cc8b6e58
+EBUILD authenticator-9999.ebuild 1135 BLAKE2B 2a6d45a38a6d6cfa038e43d55608435a4a42305ded96868a87c9e48afa22a60ced6dc8befc5af05e2bae7ecca4194f97400c46494c942c0c9abf271473cfc584 SHA512 b0c5aa1d701e714e754d396474d25b0bd98b4169020368ffc2aceb97abe208cebb169c0d431e843663ff77ee8964e3997846a35a926556fb120d6311cc8b6e58
+MISC metadata.xml 615 BLAKE2B 6e7f20b374a19cf14cfaa2df3ffcc4f98df79bcdb2c2bd128482dbb9a44d118295b8ac76dd668c4675aa900ac24fc0d38115967ff73cbaa4b4771e62ca0434ac SHA512 9e6e905369b669cf8e2d337db0ea84f600bd874ca24d3624fd3a37a08ac5d132ca0f9b12bb1c80105fdc46a8a15bc85d4af2bd0681b128109de92536d83bd2e7
diff --git a/gnome-extra/authenticator/authenticator-0.2.1.ebuild b/gnome-extra/authenticator/authenticator-0.2.1.ebuild
new file mode 100644
index 000000000000..880d0174f52e
--- /dev/null
+++ b/gnome-extra/authenticator/authenticator-0.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit gnome2-utils meson python-r1 virtualx xdg-utils
+
+DESCRIPTION="Two-factor authentication code generator for GNOME"
+HOMEPAGE="https://github.com/bilelmoussaoui/Authenticator"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="${HOMEPAGE}"
+else
+ SRC_URI="https://github.com/bilelmoussaoui/Authenticator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Authenticator-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND="
+ app-crypt/libsecret
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pyotp[${PYTHON_USEDEP}]
+ dev-python/pyzbar[${PYTHON_USEDEP}]
+ media-gfx/gnome-screenshot
+ x11-libs/gtk+:3
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/disable-failing-tests.patch" )
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+src_test() {
+ xdg_environment_reset
+ virtx meson_src_test
+}
diff --git a/gnome-extra/authenticator/authenticator-9999.ebuild b/gnome-extra/authenticator/authenticator-9999.ebuild
new file mode 100644
index 000000000000..880d0174f52e
--- /dev/null
+++ b/gnome-extra/authenticator/authenticator-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit gnome2-utils meson python-r1 virtualx xdg-utils
+
+DESCRIPTION="Two-factor authentication code generator for GNOME"
+HOMEPAGE="https://github.com/bilelmoussaoui/Authenticator"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="${HOMEPAGE}"
+else
+ SRC_URI="https://github.com/bilelmoussaoui/Authenticator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Authenticator-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND="
+ app-crypt/libsecret
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pyotp[${PYTHON_USEDEP}]
+ dev-python/pyzbar[${PYTHON_USEDEP}]
+ media-gfx/gnome-screenshot
+ x11-libs/gtk+:3
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/disable-failing-tests.patch" )
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+src_test() {
+ xdg_environment_reset
+ virtx meson_src_test
+}
diff --git a/gnome-extra/authenticator/files/disable-failing-tests.patch b/gnome-extra/authenticator/files/disable-failing-tests.patch
new file mode 100644
index 000000000000..0c17070d9106
--- /dev/null
+++ b/gnome-extra/authenticator/files/disable-failing-tests.patch
@@ -0,0 +1,24 @@
+diff --git a/data/meson.build b/data/meson.build
+index d21a6d1..b2a849b 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -50,10 +50,12 @@ endif
+
+ appstreamcli = find_program(['appstreamcli', 'appstream-util'], required:false)
+
+-if appstreamcli.found()
+- test (
+- 'Validate appdata file',
+- appstreamcli,
+- args: ['validate', join_paths(meson.current_build_dir (), meson.project_name() + '.appdata.xml')]
+- )
+-endif
++# This test fails because screenshot images do not comply with restrictions.
++# See https://github.com/bilelmoussaoui/Authenticator/issues/67
++#if appstreamcli.found()
++# test (
++# 'Validate appdata file',
++# appstreamcli,
++# args: ['validate', join_paths(meson.current_build_dir (), meson.project_name() + '.appdata.xml')]
++# )
++#endif
diff --git a/gnome-extra/authenticator/metadata.xml b/gnome-extra/authenticator/metadata.xml
new file mode 100644
index 000000000000..3950af1a3351
--- /dev/null
+++ b/gnome-extra/authenticator/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>oleksandr.trotsenko@gmail.com</email>
+ <name>Oleksandr Trotsenko</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bilelmoussaoui/Authenticator</remote-id>
+ <maintainer>
+ <name>Bilal Elmoussaoui</name>
+ </maintainer>
+ <bugs-to>https://github.com/bilelmoussaoui/Authenticator/issues</bugs-to>
+ </upstream>
+</pkgmetadata>