summaryrefslogtreecommitdiff
path: root/gnome-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-28 01:37:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-28 01:37:43 +0000
commite67d5b4ba05349b3bf4229d0cf7d069809c4420e (patch)
tree0fe2174d8edf159924d772ad279f37faba8d5b6a /gnome-extra
parent249ae8c1a241b514fc83737660927ee175091346 (diff)
gentoo auto-resync : 28:12:2023 - 01:37:43
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/Manifest.gzbin11259 -> 11258 bytes
-rw-r--r--gnome-extra/cjs/Manifest1
-rw-r--r--gnome-extra/cjs/files/cjs-5.6.1-clang15.patch50
3 files changed, 0 insertions, 51 deletions
diff --git a/gnome-extra/Manifest.gz b/gnome-extra/Manifest.gz
index d79713b12cd8..7261fadfe98b 100644
--- a/gnome-extra/Manifest.gz
+++ b/gnome-extra/Manifest.gz
Binary files differ
diff --git a/gnome-extra/cjs/Manifest b/gnome-extra/cjs/Manifest
index 6ec67306f4b6..419d50f8f60b 100644
--- a/gnome-extra/cjs/Manifest
+++ b/gnome-extra/cjs/Manifest
@@ -1,4 +1,3 @@
-AUX cjs-5.6.1-clang15.patch 1712 BLAKE2B b3e78b3e13f34011e45b13f537860cb18329b5e5249d83f987b0803e8429bd4ebf7434d0788d7cdd458bd44e83538eacbd7c491cdbc10e663b07c17eb90f6612 SHA512 b731d86a8f76afe66dae5b49747374947e63437b40e0bccc5654bc28f00b1ea52cb14db734803c1f172bc91cc85fe0683260793407b8e0e6f482d6edd8ee0280
AUX cjs-5.8.0-move_have_gtk4_to_the_appropriate_place.patch 1417 BLAKE2B 203701b5535b338283b99aad63e3577d3abb295c005d2e2ac908e2f8abdb24e8f7b9ef311bcf35889a93804583f13ac65f1d9453111b5195320aab9442237b2e SHA512 e2f7ed4c5f15cec6a6a7d3303779a217716ca3d8fa5d3128f4e7e685c47284fd95b9e416d50b28ca34bd06a9c469ebb3f317db88526cdc2ba1088381871da9a4
DIST cjs-5.8.0.tar.gz 877668 BLAKE2B e4c031631030c2a4221937d5ca04034163f70f21e6e5ff2d0ca15f31a7455e83ecb1f977c4c4fb9a57e58d266856f817446e53b86ee87460bedf5339e33461b6 SHA512 f43bda5810b90ceab24d096d884c65503b2d9b94f5c0a9e6082215a427df97fbec4a21ee3f2d4f22d98ac24a04af1dcd9064600ec191ccec96ae0869cc803a02
EBUILD cjs-5.8.0.ebuild 2393 BLAKE2B ef37c491778c8821a03ffc88dd82914ca9721f12fb9ade0641eeaf8793a9d848e83011ce02e40e7c100f96bd919dfbd4b44a8ed1d058881e9a35d07c3aadd6b8 SHA512 760f674ec14ec6eab030ee38db457386af61e3dc23a9b1aa04c799170d4f786038c0ce2cfcfdebb3b392cd67ec187bbe164bca418014b378b2d1df47c7126c2c
diff --git a/gnome-extra/cjs/files/cjs-5.6.1-clang15.patch b/gnome-extra/cjs/files/cjs-5.6.1-clang15.patch
deleted file mode 100644
index 43439e6f2c2a..000000000000
--- a/gnome-extra/cjs/files/cjs-5.6.1-clang15.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-https://bugs.gentoo.org/905430
-https://github.com/linuxmint/cjs/issues/115
-https://gitlab.gnome.org/GNOME/gjs/-/issues/514
-https://gitlab.gnome.org/GNOME/gjs/-/commit/9b11ed0ba70718a8b1983126563cea58658a808f
-
-From f93880c356108cfdbc8f9ebe318d18f256d7128d Mon Sep 17 00:00:00 2001
-From: Philip Chimento <philip.chimento@gmail.com>
-Date: Sat, 5 Nov 2022 18:01:36 -0700
-Subject: [PATCH] tests: Avoid using char type in uniform_int_distribution<T>
- template
-
-This is undefined behaviour. GCC and pre-15.x Clang accept it, so we
-didn't notice it before.
-
-Closes: #514
---- a/test/gjs-tests.cpp
-+++ b/test/gjs-tests.cpp
-@@ -55,12 +55,30 @@ static unsigned cpp_random_seed = 0;
-
- using Gjs::Test::assert_equal;
-
-+template <typename T>
-+struct is_char_helper : public std::false_type {};
-+template <>
-+struct is_char_helper<char> : public std::true_type {};
-+template <>
-+struct is_char_helper<wchar_t> : public std::true_type {};
-+template <>
-+struct is_char_helper<char16_t> : public std::true_type {};
-+template <>
-+struct is_char_helper<char32_t> : public std::true_type {};
-+template <typename T>
-+struct is_char : public is_char_helper<std::remove_cv_t<T>>::type {};
-+template <typename T>
-+inline constexpr bool is_char_v = is_char<T>::value;
-+
- template <typename T>
- T get_random_number() {
- std::mt19937_64 gen(cpp_random_seed);
-
- if constexpr (std::is_same_v<T, bool>) {
- return g_random_boolean();
-+ } else if constexpr (is_char_v<T>) {
-+ return std::char_traits<T>::to_char_type(
-+ get_random_number<typename std::char_traits<T>::int_type>());
- } else if constexpr (std::is_integral_v<T>) {
- T lowest_value = std::numeric_limits<T>::lowest();
-
---
-GitLab