summaryrefslogtreecommitdiff
path: root/gnome-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-17 12:28:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-17 12:28:32 +0100
commit16857b69f990738d17bc5842e3e49a6e82d1428d (patch)
tree09af7d330926974197aa59536133e026de791874 /gnome-extra
parentb6fa31c964a602f8461a77d5b83355e8750c12eb (diff)
gentoo auto-resync : 17:07:2024 - 12:28:31
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/Manifest.gzbin11244 -> 11243 bytes
-rw-r--r--gnome-extra/gnome-boxes/Manifest2
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-46.1.ebuild121
3 files changed, 123 insertions, 0 deletions
diff --git a/gnome-extra/Manifest.gz b/gnome-extra/Manifest.gz
index 1e83f03cf0e8..83b9c5a37fc4 100644
--- a/gnome-extra/Manifest.gz
+++ b/gnome-extra/Manifest.gz
Binary files differ
diff --git a/gnome-extra/gnome-boxes/Manifest b/gnome-extra/gnome-boxes/Manifest
index b82c80bdaa16..8937f2aa4e1d 100644
--- a/gnome-extra/gnome-boxes/Manifest
+++ b/gnome-extra/gnome-boxes/Manifest
@@ -1,3 +1,5 @@
DIST gnome-boxes-45.0.tar.xz 1239116 BLAKE2B 15f52a78cf3a3b010a7ad662d4a7f537e43e7793baf85918abc64d65e260e3e9c7a84dfa0c8b2a37e911363a04b26ae3cb285baa065a9620e145e01478640d5d SHA512 f8e1f5562ef65b05f8f2bb156646ee8bc8c951268386ede175567e8ec6104e1c1ee427d3cef3e6a2be7234bc2a3cfc44c80f55144be2ffbb96778142279ba334
+DIST gnome-boxes-46.1.tar.xz 1249848 BLAKE2B 56776a2bd66923caa777ec0d3f397f5f70352fd1b2108e22223c652ff46c0e579d6adda2ab56968336b9b833bd0846bdbd19404eed89731e986e73b45e5eb728 SHA512 db2ffb3d69c4689d3a318b5ae0fbbb61485b89c093a448715e4536aa5b68d306946b86a08bf75f7bd2eda5aee54df9ca3bd763ae35d446e530ab5326b8cacaf0
EBUILD gnome-boxes-45.0.ebuild 3455 BLAKE2B ae947d9c8fa6305f634adbf924cb656e866eb2697620cf03a5d28f098cddaa0c16d6210ba6bc2e78f2cbf8b769ec3183a66cd3bd758879148a72cf8b417f15bd SHA512 b3fdd921d9ecda1c14ab0bec2e8887a2165ffeba0ccaf91383118e63eac64998bb1ad96b18f979319142b3263a40e116402b2221baaeb5e15a5c2fb10aa13b3b
+EBUILD gnome-boxes-46.1.ebuild 3494 BLAKE2B 9d52b9f310d974d028bef8667c1b3be612e08d7b4c98e739b9945bef2472ace5779586091e8949f8f82d23c20072ea25837c2405125da683a7175848c2b6aee5 SHA512 960bb7f5139216ad7066c521171a2e2908f55ee32021a9c8e6838cfae59fb0d19d144be20a8b7ea2ba0d48429f82a672093985d0500995f6b2497637c23878bb
MISC metadata.xml 352 BLAKE2B 285b6e588965df3d070f92552b36941c6346a9fde3dce831baa82d42c8ca23f62cc027e5984a27fc87bffca8181c2d13a52b064729349daef0aa815a566a885e SHA512 09baca6576a90ca57b6e0935879f1630550efc9d591b425d6944b28b1184612b34fcdbae6d835d98812c89ec7a47415af9a01678be16f35a52933bb7c374131f
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-46.1.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-46.1.ebuild
new file mode 100644
index 000000000000..568ae54a4ce0
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-46.1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils linux-info meson readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Simple GNOME application to access remote or virtual systems"
+HOMEPAGE="https://apps.gnome.org/Boxes/"
+
+LICENSE="LGPL-2+ CC-BY-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# FIXME: qemu probably needs to depend on spice[smartcard] directly with USE=spice
+# FIXME: Check over libvirt USE=libvirtd,qemu and the smartcard/usbredir requirements
+# Technically vala itself still ships a libsoup vapi, but that may change, and
+# it should be better to use the .vapi from the same libsoup version
+DEPEND="
+ >=app-arch/libarchive-3.0.0:=
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.24.1:3
+ >=dev-libs/libportal-0.7[gtk]
+ >=gui-libs/libhandy-1.5.0:1
+ >=sys-libs/libosinfo-1.10.0-r1
+ net-libs/libsoup:3.0
+ virtual/libusb:1
+ >=app-emulation/libvirt-glib-5.0.0
+ >=dev-libs/libxml2-2.7.8:2
+ >=net-misc/spice-gtk-0.32[gtk3(+),smartcard,usbredir]
+ >=net-libs/webkit-gtk-2.38.0:4.1
+
+ >=dev-libs/gobject-introspection-1.56:=
+ >=dev-libs/libgudev-165:=
+" # gobject-introspection needed for libovf subproject
+# These are called via exec():
+# - sys-fs/mtools mcopy for unattended file copying for files that libarchive doesn't support
+# - app-cdr/cdrtools mkisofs is needed for unattended installer secondary disk image creation
+# - app-emulation/libguestfs virt-sysprep is used for VM cloing, if not there, it logs debug and doesn't function
+# - sys-apps/policycoreutils restorecon is used for checking selinux context
+# - app-emulation/libvirt virsh used for various checks (and we need the library anyways)
+# - sys-auth/polkit used for making all libvirt system disks readable via "pkexec
+# chmod a+r" that aren't already readable to the user (libvirt system importer)
+# - app-emulation/qemu qemu-img used to convert image to QCOW2 format during copy
+RDEPEND="${DEPEND}
+ app-cdr/cdrtools
+ app-misc/tracker-miners:3[iso]
+ app-emulation/spice[smartcard]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/qemu-1.3.1[spice,smartcard,usbredir]
+ sys-fs/mtools
+ sys-auth/polkit
+"
+# This is only needed for creating the .vapi file, but gnome-boxes needs it
+BDEPEND="
+ $(vala_depend)
+ sys-libs/libosinfo[vala]
+ app-crypt/libsecret[vala]
+ net-libs/libsoup:3.0[vala]
+ app-emulation/libvirt-glib[vala]
+ net-misc/spice-gtk[vala]
+ x11-libs/vte:2.91[vala]
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Before running gnome-boxes for local VMs, you will need to load the KVM modules.
+If you have an Intel Processor, run:
+# modprobe kvm-intel
+
+If you have an AMD Processor, run:
+# modprobe kvm-amd"
+
+pkg_pretend() {
+ linux-info_get_any_version
+
+ if linux_config_exists; then
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes local VM support!"
+ fi
+ fi
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddistributor_name=Gentoo
+ -Ddistributor_version=${PVR}
+ -Dinstalled_tests=false
+ -Dflatpak=false
+ -Dprofile=default
+ -Duefi=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}