summaryrefslogtreecommitdiff
path: root/gnome-extra/zenity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /gnome-extra/zenity
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'gnome-extra/zenity')
-rw-r--r--gnome-extra/zenity/Manifest2
-rw-r--r--gnome-extra/zenity/zenity-3.28.1.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/gnome-extra/zenity/Manifest b/gnome-extra/zenity/Manifest
index 1fabd78322e8..356d0b2f70a4 100644
--- a/gnome-extra/zenity/Manifest
+++ b/gnome-extra/zenity/Manifest
@@ -1,3 +1,5 @@
DIST zenity-3.24.0.tar.xz 1085124 BLAKE2B 2be50461c8575b5322319e3b35a9c833ae87f2e35abfdb27bed61dbead1b31dc31d551c8973634a7a0f0abc178ee6c7a4bb24377632df7d7fcaf77780f7fd4d6 SHA512 b24291166221cc2dabeabfeab7ca00ca63ff21c12a4eb327cd35ac43f485b8d4a858dd717df1b35b8bd3fd89d0bb235609855c6d349b76879b0f77b4fedd4dd9
+DIST zenity-3.28.1.tar.xz 4458404 BLAKE2B e2ae199ab51dffffbe4bf01b21bbff588a4f71328b385bdd92f3228c6971b248d50c8f890c818ae2496f595cd1609dcb9f372bff13f3dfb653d179108074bdd2 SHA512 07cfef3dc17b3d321e6abfb15c7d035caad7c2cba938263920c503e67d35e9a1dc86b48255334e50b58f6998eb4c064cc24ebd71d02f278b21b568500daae0c0
EBUILD zenity-3.24.0.ebuild 1108 BLAKE2B 32be4a94db30a9b9f4ed49607c096b9375041b360a10972a23b8441b4685082326375b3835cb8321367ddfde751fd2cc6fcebf8e6649618793da946603f35f3b SHA512 dafbd0107b9135b22a575d235dd6921928d2bdbde5dacd500798151255500343892978226b14a4c05359c52a55ed2b2ad67b3d8b948debfa49a06bebeaa3c47c
+EBUILD zenity-3.28.1.ebuild 1110 BLAKE2B 1905762638335c0cf2fc5b9032cc086491d62bac3bc01df803c63bd0f608467de1ecafc1fe4159d42349306ace338052533c7368337b1c086b273a473aeddff4 SHA512 17b9de028333cf7d86e52e892877aeb7c2fd356be73ccd349211bd56f9c0a55cf81b28eb8e7437a4fcb0f53c3adc38e761026c6022ac4abaf030ff087e9293eb
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/gnome-extra/zenity/zenity-3.28.1.ebuild b/gnome-extra/zenity/zenity-3.28.1.ebuild
new file mode 100644
index 000000000000..b22c4741cf16
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.28.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug libnotify webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=dev-libs/glib-2.8:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3:3[X]
+ x11-libs/libX11
+ x11-libs/pango
+ libnotify? ( >=x11-libs/libnotify-0.6.1:= )
+ webkit? ( >=net-libs/webkit-gtk-2.8.1:4 )
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ gnome-base/gnome-common
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable libnotify) \
+ $(use_enable webkit webkitgtk) \
+ PERL=$(type -P false)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Not really needed and prevent us from needing perl
+ rm "${ED}/usr/bin/gdialog" || die "rm gdialog failed!"
+}