summaryrefslogtreecommitdiff
path: root/gnome-extra/sushi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /gnome-extra/sushi
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'gnome-extra/sushi')
-rw-r--r--gnome-extra/sushi/Manifest4
-rw-r--r--gnome-extra/sushi/sushi-41.1.ebuild52
-rw-r--r--gnome-extra/sushi/sushi-41.2.ebuild52
3 files changed, 108 insertions, 0 deletions
diff --git a/gnome-extra/sushi/Manifest b/gnome-extra/sushi/Manifest
index c26d1b4d142c..177fe1d0d79d 100644
--- a/gnome-extra/sushi/Manifest
+++ b/gnome-extra/sushi/Manifest
@@ -1,3 +1,7 @@
DIST sushi-41.0.tar.xz 80940 BLAKE2B 211fb0c96ac0a911809007ed2e79659cc90a32be23d61137d85cc4502beb995d2131f62bbbb9a66f8da9328a4bf7d83b0c05f93e8913c8390be5cf22baaaeb00 SHA512 690018b846b23b3b21db244ae6e1f373870cc8cdb374dee2f4ba7eebf65af5d33a3366d37476b5f4556daf196c3f9cf8bf44903193831340f23ad33eef3ed484
+DIST sushi-41.1.tar.xz 81228 BLAKE2B 8bff3ed2b70be8335139499fb982efc89163ab1ec95ff9053a117a72945d8733f0125ec4c64b7d175212a9d74f36212319e75f46e84b1eda90896a0ea4b26be7 SHA512 55fca36e73842943bb54a2e1ae005ffe0818763e787e1f987479b71527ce36970aa502c22053195fc3711b8cfcbb6892d3f1add674e425b9358d3682972026d5
+DIST sushi-41.2.tar.xz 81252 BLAKE2B 811b02e0738aa3aba22d71545e888ec0334779591a56d6a28f3942d5d79fb9fece2fdffe0203757ba0806352584a50228b669fc0969f7ad75265fc40a3a1cd67 SHA512 c47b22a013fe31de6943d8af0f333b8050a8f0ecb0e827ea71666cd0175d5cc99336eb7ad96b21ba7aaf87f23d01b4f37a1ca8c0fc644fa89aa8960699b61f43
EBUILD sushi-41.0.ebuild 1303 BLAKE2B b3266138ec01f3ce8af3acdfedddcaa603e497e26c5d8a5e68b6113c588e5ba51eae51a4edccd925ae82caf2837f0d6eec00219e85a55634a0072ed6b7f1fc77 SHA512 e0472db272aef64e1434ec7897a26222e10cd2aa1f7d82d89600c11028452eca374bc934925f0e9c460823422389b9e9d8ff8221aed59539048f2000df977400
+EBUILD sushi-41.1.ebuild 1354 BLAKE2B fbf5e36f0fa4298a965d6d6458ab6753efa25a6b08d6efd5bff4932e6dfb3e9237723c9166c299855680b933b090fea281604a6e2873d01e9eba60dfa1566167 SHA512 cea5a9f2f8c79da7975e56570201b3ab302d1cc13852a71a5ca4461bd76389514dff977c609cf4270aea74e58d5dde4def857313990b3f72454412b329f5a3f9
+EBUILD sushi-41.2.ebuild 1354 BLAKE2B 3ddf0774aebbb1d71354b5c1e49a1d6dc88393715c0aa6f021e63e1e2095741aeb473e5da8dda744cdde3419bc78bb238106ae72c8560e2da157e7e4abeb9aaa SHA512 c5715e84990188dea90ee0df90a076c7431c0f46d2d6add4c87b6fcc56f5cf6d0b37ec245fb5b8d97eb7d05bab6a8913756db44d000e9c97196ac005d0d2689d
MISC metadata.xml 385 BLAKE2B 8b38e81530f0280af7c0d773ae60a0cf4144d3a7d876b30574da186bafb023da5da9abd75471543d528f0e6aa9664ba787aeb45bc46dab64077f3a1a0c8bc932 SHA512 d5d35182551e497f3ac5a89734387a1a6e03848ce02f017c6982d5261edbdc72ee342ec7ccc9304f08918f3bc81548bbc26039d7c88a397a627c4a37215808e0
diff --git a/gnome-extra/sushi/sushi-41.1.ebuild b/gnome-extra/sushi/sushi-41.1.ebuild
new file mode 100644
index 000000000000..fbf71c2e59eb
--- /dev/null
+++ b/gnome-extra/sushi/sushi-41.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson xdg
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+IUSE="office wayland +X"
+REQUIRED_USE="|| ( wayland X )"
+
+# Optional app-office/libreoffice support (OOo to pdf and then preview)
+DEPEND="
+ media-libs/libepoxy
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ >=x11-libs/gdk-pixbuf-2.23.0[introspection]
+ >=dev-libs/glib-2.29.14:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[introspection,wayland?,X?]
+ >=x11-libs/gtksourceview-4.0.3:4[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ >=dev-libs/gobject-introspection-1.54:=
+ >=net-libs/webkit-gtk-2.34:4[introspection]
+ >=dev-libs/gjs-1.40
+"
+RDEPEND="${DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ media-plugins/gst-plugins-gtk:1.0[wayland?,X?]
+ office? ( app-office/libreoffice )
+"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ meson_src_configure \
+ $(meson_feature wayland) \
+ $(meson_feature X X11)
+}
+
+src_compile() {
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+ meson_src_compile
+}
diff --git a/gnome-extra/sushi/sushi-41.2.ebuild b/gnome-extra/sushi/sushi-41.2.ebuild
new file mode 100644
index 000000000000..a9e7cb992539
--- /dev/null
+++ b/gnome-extra/sushi/sushi-41.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org meson xdg
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+IUSE="office wayland +X"
+REQUIRED_USE="|| ( wayland X )"
+
+# Optional app-office/libreoffice support (OOo to pdf and then preview)
+DEPEND="
+ media-libs/libepoxy
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ >=x11-libs/gdk-pixbuf-2.23.0[introspection]
+ >=dev-libs/glib-2.29.14:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[introspection,wayland?,X?]
+ >=x11-libs/gtksourceview-4.0.3:4[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ >=dev-libs/gobject-introspection-1.54:=
+ >=net-libs/webkit-gtk-2.34:4[introspection]
+ >=dev-libs/gjs-1.40
+"
+RDEPEND="${DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ media-plugins/gst-plugins-gtk:1.0[wayland?,X?]
+ office? ( app-office/libreoffice )
+"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ meson_src_configure \
+ $(meson_feature wayland) \
+ $(meson_feature X X11)
+}
+
+src_compile() {
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+ meson_src_compile
+}