summaryrefslogtreecommitdiff
path: root/gnome-extra/sushi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /gnome-extra/sushi
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'gnome-extra/sushi')
-rw-r--r--gnome-extra/sushi/Manifest2
-rw-r--r--gnome-extra/sushi/sushi-3.30.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/gnome-extra/sushi/Manifest b/gnome-extra/sushi/Manifest
index b29000c674b6..57aecbd7d366 100644
--- a/gnome-extra/sushi/Manifest
+++ b/gnome-extra/sushi/Manifest
@@ -1,3 +1,5 @@
DIST sushi-3.24.0.tar.xz 297332 BLAKE2B a01947627e9ca711f9f1d634f2791ee79e414bab38058ca4a8bfd822a2d277522fe99d66b3364f46662ee0fc1fa8a148f48ce8c434fd0d7bbb7ef1c159f2ea12 SHA512 b49e9c1ef1dc4c74ae06f6da9a2f428ed4ee3ec1ca3ba04c483ddb1bd976e6981466456d27a641048756a1ea0bf2fe033883059895e889950d0d0f340535b29b
+DIST sushi-3.30.0.tar.xz 296940 BLAKE2B ff8617aabab16d41c9b072f8cf9774e4f5ce59e0dada05dcad23ba6929005c963d86a1beb5c2a3adc5e8cbaf8a6ce769b48ff53f4979db9f1853bbed0f80fb2d SHA512 48d2b960c2ebe86cdfbd0043968acdd6864162368941b921f25e137e6aeb2a2513738ad4d8c6ef5d5c6d2863e6ace5d2819e0a5dfc487efd20a1914a7cbcc40e
EBUILD sushi-3.24.0.ebuild 1397 BLAKE2B e70854e83c0ad23bc2c289eeef570624ad279636a05c2e19d62b0c0f103a439d7a183f8dd2148c78bd13d2631ddd25e804bf8aa8d782440d0528f8ae4c726bd7 SHA512 0dc8e816b550fc5ab58beeec4f379442adb23e9fbdb164551a4ab5551e604e3171abb4c0c5ee49f54ebf4ac3d7397d085fbc12006aa4693fe620e196351be130
+EBUILD sushi-3.30.0.ebuild 1417 BLAKE2B a001540a7312d17495835b3e2fcb294f589a1c8fd6bfafdc64f90b7576fc3c794e12ab5726426aed458eeee0c1455d26cf5f5ea8d799f4fdad6791fd460c8634 SHA512 c1cfbf96bc0fd85e763096a68ec64b33043b1c4845e4dde07ea6856eeae44785063afacf36de1e5467b94517ab6d7a29b6261b180cdde7d949d6dc01acbfb0d0
MISC metadata.xml 384 BLAKE2B 9d8094a09a87c46785605cae4b610f59fb6e8bdfef8e58c19dbd0725c8a11ba03cf3c25eeb77d553281934deeb64e91af780a44b43a630b5293f112f678115b4 SHA512 c6d8a451147839eb220b0e7b6759efdb59f1929da7f1d66d7c7a956a2626f04035f1b007da0e06fcf6d958bb8102df9c8c3dbc0634d89ad3937d40e21fe24651
diff --git a/gnome-extra/sushi/sushi-3.30.0.ebuild b/gnome-extra/sushi/sushi-3.30.0.ebuild
new file mode 100644
index 000000000000..de2d87e343dc
--- /dev/null
+++ b/gnome-extra/sushi/sushi-3.30.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://git.gnome.org/browse/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="office"
+
+# Optional app-office/unoconv support (OOo to pdf)
+# freetype needed for font loader
+# gtk+[X] optionally needed for sushi_create_foreign_window(); when wayland is more widespread, might want to not force it
+COMMON_DEPEND="
+ >=x11-libs/gdk-pixbuf-2.23[introspection]
+ >=dev-libs/gjs-1.40
+ >=dev-libs/glib-2.29.14:2
+ >=dev-libs/gobject-introspection-0.9.6:=
+ >=media-libs/clutter-1.11.4:1.0[introspection]
+ >=media-libs/clutter-gtk-1.0.1:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[X,introspection]
+
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ media-libs/clutter-gst:3.0[introspection]
+ media-libs/musicbrainz:5=
+ net-libs/webkit-gtk:4[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+
+ office? ( app-office/unoconv )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/nautilus-3.1.90
+"
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}