summaryrefslogtreecommitdiff
path: root/gnome-extra/sushi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /gnome-extra/sushi
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'gnome-extra/sushi')
-rw-r--r--gnome-extra/sushi/Manifest2
-rw-r--r--gnome-extra/sushi/sushi-41.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/gnome-extra/sushi/Manifest b/gnome-extra/sushi/Manifest
index 75dfa2e8fcf1..cd51b5d271b7 100644
--- a/gnome-extra/sushi/Manifest
+++ b/gnome-extra/sushi/Manifest
@@ -1,3 +1,5 @@
DIST sushi-3.38.1.tar.xz 79384 BLAKE2B 7306d375f85cc491fa8819e6857b1d61d158149045069002ed7a9c0f08c021ce0e9ed5ee751404a507dfdffdfa99895288f9c9601001818b4d1bc987f94bd823 SHA512 b999e6892314875725bd4029163ae58813b46f0e5c59e58b62fc4491d611b48fc39459f6c5b5e1a7d75d792cfeb66681f4d3a7057e8cde8f5c3364a2312e0be7
+DIST sushi-41.0.tar.xz 80940 BLAKE2B 211fb0c96ac0a911809007ed2e79659cc90a32be23d61137d85cc4502beb995d2131f62bbbb9a66f8da9328a4bf7d83b0c05f93e8913c8390be5cf22baaaeb00 SHA512 690018b846b23b3b21db244ae6e1f373870cc8cdb374dee2f4ba7eebf65af5d33a3366d37476b5f4556daf196c3f9cf8bf44903193831340f23ad33eef3ed484
EBUILD sushi-3.38.1.ebuild 1324 BLAKE2B 82f4e9004950823abed357e188a4f90e51af15f560e46fe370333d4dd4d78d7d74523894bd7b71101cb0ef0ceb9c82e91ebcc842d8fbd57f32af6530735c708b SHA512 d3d46b3141563662982104e08a651a156d9a9bfda449a90854e77f929c19161d672b87c3f63efbf8fc651fd32e3963d84dd5842f632fe0506beef1a04e329b11
+EBUILD sushi-41.0.ebuild 1306 BLAKE2B 0bb737a6bf6a09419fa1d1cfe4ea79c6be06fbbbc8f371fd89459cb1204c5d6f5b696a96aa2a132632379ba390b4377554dd05cca7734a810f148cac36b5ab6b SHA512 96682a1475b696510c35e922c9a6cc73be19ce793c49c85fce2839eefdd3a9245286f796d886b25a1a195f5b1d92a878903708d4dd76e13e0bf1308f86b816e8
MISC metadata.xml 385 BLAKE2B 8b38e81530f0280af7c0d773ae60a0cf4144d3a7d876b30574da186bafb023da5da9abd75471543d528f0e6aa9664ba787aeb45bc46dab64077f3a1a0c8bc932 SHA512 d5d35182551e497f3ac5a89734387a1a6e03848ce02f017c6982d5261edbdc72ee342ec7ccc9304f08918f3bc81548bbc26039d7c88a397a627c4a37215808e0
diff --git a/gnome-extra/sushi/sushi-41.0.ebuild b/gnome-extra/sushi/sushi-41.0.ebuild
new file mode 100644
index 000000000000..0ce63af012ee
--- /dev/null
+++ b/gnome-extra/sushi/sushi-41.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson xdg
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+IUSE="office wayland +X"
+REQUIRED_USE="|| ( wayland X )"
+
+# Optional app-office/libreoffice support (OOo to pdf and then preview)
+DEPEND="
+ media-libs/libepoxy
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ >=x11-libs/gdk-pixbuf-2.23.0[introspection]
+ >=dev-libs/glib-2.29.14:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[introspection,wayland?,X?]
+ >=x11-libs/gtksourceview-4.0.3:4[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ >=dev-libs/gobject-introspection-1.54:=
+ >=net-libs/webkit-gtk-2.34:4[introspection]
+ >=dev-libs/gjs-1.40
+"
+RDEPEND="${DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ office? ( app-office/libreoffice )
+"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ meson_src_configure \
+ $(meson_feature wayland) \
+ $(meson_feature X X11)
+}
+
+src_compile() {
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+ meson_src_compile
+}