summaryrefslogtreecommitdiff
path: root/gnome-extra/sushi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnome-extra/sushi
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnome-extra/sushi')
-rw-r--r--gnome-extra/sushi/Manifest3
-rw-r--r--gnome-extra/sushi/metadata.xml12
-rw-r--r--gnome-extra/sushi/sushi-3.24.0.ebuild49
3 files changed, 64 insertions, 0 deletions
diff --git a/gnome-extra/sushi/Manifest b/gnome-extra/sushi/Manifest
new file mode 100644
index 000000000000..b29000c674b6
--- /dev/null
+++ b/gnome-extra/sushi/Manifest
@@ -0,0 +1,3 @@
+DIST sushi-3.24.0.tar.xz 297332 BLAKE2B a01947627e9ca711f9f1d634f2791ee79e414bab38058ca4a8bfd822a2d277522fe99d66b3364f46662ee0fc1fa8a148f48ce8c434fd0d7bbb7ef1c159f2ea12 SHA512 b49e9c1ef1dc4c74ae06f6da9a2f428ed4ee3ec1ca3ba04c483ddb1bd976e6981466456d27a641048756a1ea0bf2fe033883059895e889950d0d0f340535b29b
+EBUILD sushi-3.24.0.ebuild 1397 BLAKE2B e70854e83c0ad23bc2c289eeef570624ad279636a05c2e19d62b0c0f103a439d7a183f8dd2148c78bd13d2631ddd25e804bf8aa8d782440d0528f8ae4c726bd7 SHA512 0dc8e816b550fc5ab58beeec4f379442adb23e9fbdb164551a4ab5551e604e3171abb4c0c5ee49f54ebf4ac3d7397d085fbc12006aa4693fe620e196351be130
+MISC metadata.xml 384 BLAKE2B 9d8094a09a87c46785605cae4b610f59fb6e8bdfef8e58c19dbd0725c8a11ba03cf3c25eeb77d553281934deeb64e91af780a44b43a630b5293f112f678115b4 SHA512 c6d8a451147839eb220b0e7b6759efdb59f1929da7f1d66d7c7a956a2626f04035f1b007da0e06fcf6d958bb8102df9c8c3dbc0634d89ad3937d40e21fe24651
diff --git a/gnome-extra/sushi/metadata.xml b/gnome-extra/sushi/metadata.xml
new file mode 100644
index 000000000000..367fae8e3eae
--- /dev/null
+++ b/gnome-extra/sushi/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <use>
+ <flag name="office">Support viewing file formats such as generated by
+ <pkg>app-office/libreoffice</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/gnome-extra/sushi/sushi-3.24.0.ebuild b/gnome-extra/sushi/sushi-3.24.0.ebuild
new file mode 100644
index 000000000000..3a0f5d975093
--- /dev/null
+++ b/gnome-extra/sushi/sushi-3.24.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://git.gnome.org/browse/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="office"
+
+# Optional app-office/unoconv support (OOo to pdf)
+# freetype needed for font loader
+# gtk+[X] optionally needed for sushi_create_foreign_window(); when wayland is more widespread, might want to not force it
+COMMON_DEPEND="
+ >=x11-libs/gdk-pixbuf-2.23[introspection]
+ >=dev-libs/gjs-1.40
+ >=dev-libs/glib-2.29.14:2
+ >=dev-libs/gobject-introspection-0.9.6:=
+ >=media-libs/clutter-1.11.4:1.0[introspection]
+ >=media-libs/clutter-gtk-1.0.1:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[X,introspection]
+
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ media-libs/clutter-gst:3.0[introspection]
+ media-libs/musicbrainz:5=
+ net-libs/webkit-gtk:4[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+
+ office? ( app-office/unoconv )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/nautilus-3.1.90
+"
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}