summaryrefslogtreecommitdiff
path: root/gnome-extra/sushi/sushi-3.24.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /gnome-extra/sushi/sushi-3.24.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'gnome-extra/sushi/sushi-3.24.0.ebuild')
-rw-r--r--gnome-extra/sushi/sushi-3.24.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnome-extra/sushi/sushi-3.24.0.ebuild b/gnome-extra/sushi/sushi-3.24.0.ebuild
new file mode 100644
index 000000000000..3a0f5d975093
--- /dev/null
+++ b/gnome-extra/sushi/sushi-3.24.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://git.gnome.org/browse/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="office"
+
+# Optional app-office/unoconv support (OOo to pdf)
+# freetype needed for font loader
+# gtk+[X] optionally needed for sushi_create_foreign_window(); when wayland is more widespread, might want to not force it
+COMMON_DEPEND="
+ >=x11-libs/gdk-pixbuf-2.23[introspection]
+ >=dev-libs/gjs-1.40
+ >=dev-libs/glib-2.29.14:2
+ >=dev-libs/gobject-introspection-0.9.6:=
+ >=media-libs/clutter-1.11.4:1.0[introspection]
+ >=media-libs/clutter-gtk-1.0.1:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[X,introspection]
+
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ media-libs/clutter-gst:3.0[introspection]
+ media-libs/musicbrainz:5=
+ net-libs/webkit-gtk:4[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+
+ office? ( app-office/unoconv )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/nautilus-3.1.90
+"
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}