summaryrefslogtreecommitdiff
path: root/gnome-extra/pch-session/pch-session-3.30.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /gnome-extra/pch-session/pch-session-3.30.0.1.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'gnome-extra/pch-session/pch-session-3.30.0.1.ebuild')
-rw-r--r--gnome-extra/pch-session/pch-session-3.30.0.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnome-extra/pch-session/pch-session-3.30.0.1.ebuild b/gnome-extra/pch-session/pch-session-3.30.0.1.ebuild
new file mode 100644
index 000000000000..ca53eeb88fa6
--- /dev/null
+++ b/gnome-extra/pch-session/pch-session-3.30.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils
+
+DESCRIPTION="Unofficial gnome based session with different default settings and extensions"
+HOMEPAGE="https://gitlab.com/pachoramos/pch-session"
+SRC_URI="https://gitlab.com/pachoramos/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=gnome-base/gnome-shell-3.30
+ gnome-extra/gnome-shell-extensions
+ gnome-extra/gnome-shell-extension-dash-to-panel
+ gnome-extra/gnome-shell-extension-desktop-icons
+ gnome-extra/gnome-shell-extension-gsconnect
+ gnome-extra/gnome-shell-extensions-topicons-plus
+"
+BDEPEND=""
+DEPEND=""
+
+src_install() {
+ insinto /usr
+ doins -r usr/.
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}