summaryrefslogtreecommitdiff
path: root/gnome-extra/office-runner
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnome-extra/office-runner
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnome-extra/office-runner')
-rw-r--r--gnome-extra/office-runner/Manifest3
-rw-r--r--gnome-extra/office-runner/metadata.xml14
-rw-r--r--gnome-extra/office-runner/office-runner-1.0.2.ebuild42
3 files changed, 59 insertions, 0 deletions
diff --git a/gnome-extra/office-runner/Manifest b/gnome-extra/office-runner/Manifest
new file mode 100644
index 000000000000..ba300ee69756
--- /dev/null
+++ b/gnome-extra/office-runner/Manifest
@@ -0,0 +1,3 @@
+DIST office-runner-1.0.2.tar.xz 562660 BLAKE2B ad69a4340025b58d45f954524c9807831c98a4d81901276bfa3e8f76adb3a5bd1fcf0b50908e00c19888d82b6c48602228a42b84b008f2b7b95210868c8a90ed SHA512 a840af75f014147d30e950a4bc8628c97a79c8161eab3d0f658f5e4f5200df5baaa761d4ea27dc1bc70c6a467fc2536ac0aa473c338ffcbfc48689ba1ec13177
+EBUILD office-runner-1.0.2.ebuild 878 BLAKE2B dd7e6c8471381566e6cb3edbc3b4457e8e79dd8a1b78ecc008d567f2b0e94b79de164f537469a2f9f6279e0b20b8582535c7b15c6e6142a3648d77b36933a849 SHA512 920d5eae8032228f0cb2c8661d2f2f14e9e5b087272a4e3508f714062a183eb7a2157f0110c07597ef04253ddb1c4e24ef3d40946a5da7195cf7b2e9a7a27572
+MISC metadata.xml 520 BLAKE2B 7a1706f5380983f935e4feb3f00224194024beeea99aed500f2550780049354bab448ce6b507e9cfad63b0d16d08d1d5bc7880aff36be791a5888a8c813a2181 SHA512 54abe575b83b5b14c227e8e4b87f7bb00503afd69cce7d5a05124b4d67a0385ff21fcf4618f41668c3fedbd27c918753b4bdc0dcef296a63fcd774c608fbcc80
diff --git a/gnome-extra/office-runner/metadata.xml b/gnome-extra/office-runner/metadata.xml
new file mode 100644
index 000000000000..77410621ce8c
--- /dev/null
+++ b/gnome-extra/office-runner/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <longdescription lang="en">
+ A tool in the form of a lighthearted game that
+ temporarily inhibits GNOME's default suspend on lid close behavior,
+ allowing the user to move his laptop with the lid closed without dropping
+ network connections.
+ </longdescription>
+</pkgmetadata>
diff --git a/gnome-extra/office-runner/office-runner-1.0.2.ebuild b/gnome-extra/office-runner/office-runner-1.0.2.ebuild
new file mode 100644
index 000000000000..d9bcef381725
--- /dev/null
+++ b/gnome-extra/office-runner/office-runner-1.0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 readme.gentoo
+
+DESCRIPTION="Lighthearted tool to temporarily inhibit GNOME's suspend on lid close behavior"
+HOMEPAGE="http://www.hadess.net/search/label/office-runner"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ >=gnome-base/gnome-settings-daemon-3.0
+ >=x11-libs/gtk+-3.8:3
+"
+# requires systemd's org.freedesktop.login1 dbus service
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/systemd-190
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+DOC_CONTENTS="${PN} inhibits suspend on lid close only for 10 minutes"
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}