summaryrefslogtreecommitdiff
path: root/gnome-extra/nm-applet/nm-applet-1.22.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /gnome-extra/nm-applet/nm-applet-1.22.0.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'gnome-extra/nm-applet/nm-applet-1.22.0.ebuild')
-rw-r--r--gnome-extra/nm-applet/nm-applet-1.22.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnome-extra/nm-applet/nm-applet-1.22.0.ebuild b/gnome-extra/nm-applet/nm-applet-1.22.0.ebuild
new file mode 100644
index 000000000000..9a0c4cf3048d
--- /dev/null
+++ b/gnome-extra/nm-applet/nm-applet-1.22.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="network-manager-applet"
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="NetworkManager connection editor and applet"
+HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="appindicator modemmanager selinux teamd"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=app-crypt/libsecret-0.18
+ >=net-libs/libnma-1.8.27
+ >=x11-libs/gtk+-3.10:3
+ >=dev-libs/libgudev-147:=
+ >=x11-libs/libnotify-0.7.0
+ >=net-misc/networkmanager-1.16:=[modemmanager?,teamd?]
+ appindicator? (
+ dev-libs/libappindicator:3
+ >=dev-libs/libdbusmenu-16.04.0
+ )
+ modemmanager? ( net-misc/modemmanager )
+ selinux? ( sys-libs/libselinux )
+ teamd? ( >=dev-libs/jansson-2.7 )
+
+ virtual/freedesktop-icon-theme
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dappindicator=$(usex appindicator ubuntu no)
+ $(meson_use modemmanager wwan)
+ $(meson_use selinux)
+ $(meson_use teamd team)
+ -Dmore_asserts=0
+ -Dld_gc=false
+ )
+ meson_src_configure
+}