summaryrefslogtreecommitdiff
path: root/gnome-extra/libgsf/libgsf-1.14.50.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 02:30:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 02:30:06 +0100
commita6266c63b23ed0ee16865627ca53e4f5353f0a5c (patch)
tree6ed71ecc485e9c4903818db305f6ebee454a38db /gnome-extra/libgsf/libgsf-1.14.50.ebuild
parent1fd4e372381e1318aae1b7d3338c04156e5da974 (diff)
gentoo auto-resync : 17:07:2022 - 02:30:06
Diffstat (limited to 'gnome-extra/libgsf/libgsf-1.14.50.ebuild')
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.50.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/libgsf-1.14.50.ebuild b/gnome-extra/libgsf/libgsf-1.14.50.ebuild
new file mode 100644
index 000000000000..09c1888c5419
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.50.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libgsf"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ virtual/imagemagick-tools
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ dev-libs/gobject-introspection-common
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+ test? ( dev-perl/XML-Parser )
+"
+
+PATCHES=(
+ "${FILESDIR}"/1.14.49-skip-valgrind-tests.patch
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}