summaryrefslogtreecommitdiff
path: root/gnome-extra/krb5-auth-dialog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-07 18:14:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-07 18:14:11 +0000
commit7a027cd18c60d9abad83a60c98ccf27db26be067 (patch)
tree905c5e3c3ec66d8d756a71db384bdd7abf7a50f9 /gnome-extra/krb5-auth-dialog
parentd4d70691ab58dfcbd58e0863f3e64d59765533e3 (diff)
gentoo auto-resync : 07:01:2023 - 18:14:11
Diffstat (limited to 'gnome-extra/krb5-auth-dialog')
-rw-r--r--gnome-extra/krb5-auth-dialog/Manifest4
-rw-r--r--gnome-extra/krb5-auth-dialog/files/krb5-auth-dialog-43.0-remove-postinstall-script.patch21
-rw-r--r--gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0.ebuild29
-rw-r--r--gnome-extra/krb5-auth-dialog/metadata.xml19
4 files changed, 73 insertions, 0 deletions
diff --git a/gnome-extra/krb5-auth-dialog/Manifest b/gnome-extra/krb5-auth-dialog/Manifest
new file mode 100644
index 000000000000..44f8374c5785
--- /dev/null
+++ b/gnome-extra/krb5-auth-dialog/Manifest
@@ -0,0 +1,4 @@
+AUX krb5-auth-dialog-43.0-remove-postinstall-script.patch 506 BLAKE2B 602b6e6e54a14aece7ec0e9767b5627988d5c6fddbc5704222a97a33e2cf0f21b1d49a3162e596b62a1fbeda616dffd08b33795e4bb6e47755c011099b8035cd SHA512 6db9ae0b2e4eb4dce1652913b992c74b41a3e33516e29953125ac3b101c5d7f57ffbab5f457976a2a9c31768b6fe5c93476d462f8067134acb248a5ec733dc21
+DIST krb5-auth-dialog-43.0.tar.xz 316172 BLAKE2B d06dd2ec695520412b4d04b0db9f7b01cf41531f17f8cb753238a350327f58e12825a9447a669ed54a7c2cf42da217ce49fb6d91ade08463a378f714762db33d SHA512 576c98751429454b7293f7bb814662dc9f44d4205930a35a117095b1b1c06b840b23cc328379ccd9aa130c98ae5cf8b2f890459c30bb63f392e353f9ac9faa88
+EBUILD krb5-auth-dialog-43.0.ebuild 626 BLAKE2B b73b06133a62e42ed8eb0e2d28606b6c99e283aac2b4a266ec8a5d270b56724e770e798f591cb45fd212488a82f689b4a8e3156a95b86e980bce13e410d703ef SHA512 0e96e9fb4b543079974c3ddd6da2d311481fb122375524f428993332402b53f252d6ed02f82d5ba6a871c0ff28f455e416e9052cea488ef402ed92a7cd3725f2
+MISC metadata.xml 620 BLAKE2B 3db2484f4f2184f8a37fc560fed60bfaff69ac49761412ea4253035647c4eacdaff90e18f019805e81efb80578c8d075c8198ec746fbde5375233e0c8575b2bb SHA512 53f624a9eda270c9c6d28428b94d4bfe7961f7c17c0855f23b17637e0bdf6b777716ba32d5745c3a541bab7ca2021cbee6ba87fbc301077eeb564632088ee29f
diff --git a/gnome-extra/krb5-auth-dialog/files/krb5-auth-dialog-43.0-remove-postinstall-script.patch b/gnome-extra/krb5-auth-dialog/files/krb5-auth-dialog-43.0-remove-postinstall-script.patch
new file mode 100644
index 000000000000..8ce3273da8c3
--- /dev/null
+++ b/gnome-extra/krb5-auth-dialog/files/krb5-auth-dialog-43.0-remove-postinstall-script.patch
@@ -0,0 +1,21 @@
+glib-compile-schemas and gtk-update-icon-cache should not be run in src_
+phases, they are run in pkg_post functions
+
+So patch them out from meson.build
+
+Bug: https://bugs.gentoo.org/890062
+
+--- a/meson.build
++++ b/meson.build
+@@ -89,11 +89,6 @@
+ gmodule_dep = dependency('gmodule-2.0')
+ gcr_dep = dependency('gcr-3', version: '>= 3.5.5')
+
+-meson.add_install_script(
+- join_paths('build-aux', 'post_install.py'),
+- datadir
+-)
+-
+ # Both heimdal and mit ship a krb5.pc:
+ krb5_dep = dependency('krb5')
+
diff --git a/gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0.ebuild b/gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0.ebuild
new file mode 100644
index 000000000000..1fff5268fc34
--- /dev/null
+++ b/gnome-extra/krb5-auth-dialog/krb5-auth-dialog-43.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson
+
+DESCRIPTION="An application to acquire and list Kerberos tickets."
+HOMEPAGE="https://gitlab.gnome.org/GNOME/krb5-auth-dialog/"
+SRC_URI="https://download.gnome.org/sources/${PN}/$(ver_cut 1)/${P}.tar.xz"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-crypt/gcr:=
+ dev-libs/glib:2
+ sys-libs/pam
+ x11-libs/gtk+:3
+ || (
+ app-crypt/heimdal
+ app-crypt/mit-krb5
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/itstool"
+
+PATCHES=( "${FILESDIR}"/${P}-remove-postinstall-script.patch )
diff --git a/gnome-extra/krb5-auth-dialog/metadata.xml b/gnome-extra/krb5-auth-dialog/metadata.xml
new file mode 100644
index 000000000000..a83541627025
--- /dev/null
+++ b/gnome-extra/krb5-auth-dialog/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>henning@hennsch.de</email>
+ <name>Henning Schild</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>ceamac@gentoo.org</email>
+ <name>Viorel Munteanu</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gnome-gitlab">GNOME/krb5-auth-dialog</remote-id>
+ </upstream>
+</pkgmetadata>