summaryrefslogtreecommitdiff
path: root/gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild')
-rw-r--r--gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild b/gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild
new file mode 100644
index 000000000000..14bb204f238c
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit gnome2
+
+DESCRIPTION="Unicode character map viewer library"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
+IUSE="cjk debug doc +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.16.3:2
+ >=x11-libs/pango-1.2.1[introspection?]
+ >=x11-libs/gtk+-2.14.0:2[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # .desktop and schema files are only needed for the gucharmap program
+ sed -e 's:desktop_DATA\s*=.*:desktop_DATA = :' \
+ -e 's:schema_DATA\s*=.*:schema_DATA = :' \
+ -i Makefile.* || die "sed Makefile.* failed"
+
+ eapply "${FILESDIR}/${PN}-3.4.1.1-fix-doc.patch" # bug 436710, fixed in 3.6
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-gtk=2.0 \
+ --disable-charmap \
+ --disable-gconf \
+ $(use_enable cjk unihan) \
+ $(use_enable debug) \
+ $(use_enable introspection)
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! has_version "gnome-extra/gucharmap:2.90" ; then
+ ewarn "Note: ${PF} includes only the gucharmap-2 library."
+ ewarn "If you need the gucharmap program, emerge gucharmap:2.90"
+ fi
+}