summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-weather
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-16 12:27:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-16 12:27:58 +0100
commitb6fa31c964a602f8461a77d5b83355e8750c12eb (patch)
tree323fa7af31640b3ea8bb57fa7a927713f3d64769 /gnome-extra/gnome-weather
parent868fd5dc8aab84930cfaa5252b8be06b35552765 (diff)
gentoo auto-resync : 16:07:2024 - 12:27:58
Diffstat (limited to 'gnome-extra/gnome-weather')
-rw-r--r--gnome-extra/gnome-weather/Manifest2
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-46.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/gnome-extra/gnome-weather/Manifest b/gnome-extra/gnome-weather/Manifest
index 7e73dcc62b85..7c7eea6a2de2 100644
--- a/gnome-extra/gnome-weather/Manifest
+++ b/gnome-extra/gnome-weather/Manifest
@@ -1,3 +1,5 @@
DIST gnome-weather-45.0.tar.xz 238520 BLAKE2B c1d11e63a01f59f07dab3b59e7b885970fdfefc74179c21afcce097ab7454e07754726f4676b1c9a49415d6a2312a73c4dbf4c0b378aaab741ccaa4146ab59b9 SHA512 decc1d917a9b0dcd4b9feb49c9dce0096f0f22b8da193bb3e913a92687b06f2cee9f7e029653b1af101d6ab682b49f89be37b864804e0f42ea0e249fc77a027c
+DIST gnome-weather-46.0.tar.xz 239644 BLAKE2B 4acf901dbb7ee0240aa371797823c5d2eadfbc869b273e9bf0da45b311b71ea4977c6d0809f7067d79d80326d75c3c0184a463201c6f319573764277480ee23d SHA512 b180b231359e7b1cfa593b9a536d77520d6183aa752a8900bb27a290bc5f6f9676da132897e51e2810baca57196c9328a8cbbbb172068f52409076e39ba87a8b
EBUILD gnome-weather-45.0.ebuild 1393 BLAKE2B 5a59fce1d2e8b8d4335bfe2a3dab74f56cbf03eb4ba2c9808700bae80f579beb17d00ba49663ee7a0a5a8639aae6e8f303f7e89ec9a489e4ec3c5a3dc149b8a8 SHA512 c51e3203a748171e0e4e7ba14e554871560643dde9e0175345a461f1f071577a50f9d56a9973921b14e6696c57de962fe0170da58bb3057df7f7aa03c1d955d0
+EBUILD gnome-weather-46.0.ebuild 1385 BLAKE2B 847d6118636b7e00eeb688c343ca9436105d3fb00ee33f6efeed3161c86ecfca101bd10a4f9e049866de1bf4ab5825e15aecd14220f07f976427ffef2743f6df SHA512 9f3bf26dfabf9ef3b68f961eeaa57df3dc4d00616d50929a1ee0aa86748d2225562c6ec16e22fd8a8900621d5faa3f4211578ede6a18940a8fea254e28181db3
MISC metadata.xml 354 BLAKE2B dcbc0869b8b8ca66a0363e8a1bc751252e37e9938aaa787a63cdf2d02c425c1fa62038d7140f8f1eaef708b9ddcb8bd47dfd6046c0f7261c4d8a53b56cd2d56b SHA512 b9bf0473c6f2085f429ad2dfe8b265bbf07d393c47bc0764d8205e5adf7bd6f4f349c148438126b7fe3c0d60521d28f05ccb82e1f0ec89e93f0a0cd25ea62d40
diff --git a/gnome-extra/gnome-weather/gnome-weather-46.0.ebuild b/gnome-extra/gnome-weather/gnome-weather-46.0.ebuild
new file mode 100644
index 000000000000..12fa82314e23
--- /dev/null
+++ b/gnome-extra/gnome-weather/gnome-weather-46.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A weather application for GNOME"
+HOMEPAGE="https://apps.gnome.org/Weather/"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.56:=
+ >=gui-libs/gtk-4.5:4
+ >=dev-libs/gjs-1.71.0
+ >=app-misc/geoclue-2.3.1:2.0
+ >=gui-libs/libadwaita-1.4_alpha:1=
+ >=dev-libs/libgweather-3.90.0:4=
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+# Tests have a lot of issues, starting with reliance on a system installation,
+# accessing the network and other intermittent failures with network-sandbox disabled
+# https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
+# test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
+# With 3.34, this is now behind a dogtail option we can pass (and have data validation)
+
+src_configure() {
+ meson_src_configure -Dprofile=default -Ddogtail=false
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}