summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-weather
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /gnome-extra/gnome-weather
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'gnome-extra/gnome-weather')
-rw-r--r--gnome-extra/gnome-weather/Manifest2
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-3.32.2.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/gnome-extra/gnome-weather/Manifest b/gnome-extra/gnome-weather/Manifest
index eb28f9cb0d0e..bfbec8ae2ff3 100644
--- a/gnome-extra/gnome-weather/Manifest
+++ b/gnome-extra/gnome-weather/Manifest
@@ -1,3 +1,5 @@
DIST gnome-weather-3.26.0.tar.xz 5362056 BLAKE2B 0a427f8be6f8b79346d106430f6673961d03ca6770940f92eb866859907c7dc2e11805091bd9715e922176acad5c971114c9df33e6551c8992051e6ef873a298 SHA512 adb5400ca2674142132e499880793f9c4fafaa9a4459b2718eb24180480f8e4e1edb81aad947283208c3fe32f1c662d380421efa1b6b57968268ca64318a33ff
+DIST gnome-weather-3.32.2.tar.xz 5952300 BLAKE2B 536cac87066eb714bba15db0e662d9e9a0260caf67f3b9d7f2c8677deb3dc514d50768754bab46db1df9dc11367d1cf07690888b93031804d7a37a3898a1a689 SHA512 22f2de0f6d4355a44fef332d47a49b995d647d3d8d10c06a77c182d0efd6ea33f62e055f047a665710024ba02c90912ffefe67c8b299da6bb47d899d1d7a3825
EBUILD gnome-weather-3.26.0.ebuild 1150 BLAKE2B 7b1cb3709a379e1131e23f577667ca0c0910dd74a44b150ffd1f0deb96171069ab039b1a1edc7e383d3db245e9934416f51e01c8db4c54bcb84fcd51bce26f66 SHA512 20a17b0ef63fa3e2060f93823548f8e0a05210b38fb3548cbedeb4f8c80a689f03d7b81dec03dbc3ac8b6ccc0b0920814513470dbb61adc6d441533c26652609
+EBUILD gnome-weather-3.32.2.ebuild 1247 BLAKE2B 2ed1000388eb101cb69a518335ecb7a30c3eabc9dd524c33571c7234372f317d800bc2192af42dbb78b9d9dd878a676b4f7adb150465e051a84c21a1826a18a6 SHA512 93a9e0e8580c7a943353e574bba53eee233f1658b237dfd452beecd99448a5839ceae70d752c9b1e4ad006ca6caee0e3e671ae64071f2cbd0cbef72fd3905e68
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/gnome-extra/gnome-weather/gnome-weather-3.32.2.ebuild b/gnome-extra/gnome-weather/gnome-weather-3.32.2.ebuild
new file mode 100644
index 000000000000..df53c28f533c
--- /dev/null
+++ b/gnome-extra/gnome-weather/gnome-weather-3.32.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A weather application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.56:=
+ >=x11-libs/gtk+-3.20:3
+ >=dev-libs/gjs-1.50
+ >=app-misc/geoclue-2.3.1:2.0
+ >=dev-libs/libgweather-3.28:=
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# Tests have a lot of issues, starting with reliance on a system installation,
+# accessing the network and other intermittent failures with network-sandbox disabled
+# https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
+# test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
+RESTRICT="test"
+
+src_configure() {
+ meson_src_configure -Dprofile=default
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}