summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-weather
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /gnome-extra/gnome-weather
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'gnome-extra/gnome-weather')
-rw-r--r--gnome-extra/gnome-weather/Manifest2
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-42.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/gnome-extra/gnome-weather/Manifest b/gnome-extra/gnome-weather/Manifest
index 0edf6256ba7c..939fcaed8fdb 100644
--- a/gnome-extra/gnome-weather/Manifest
+++ b/gnome-extra/gnome-weather/Manifest
@@ -1,4 +1,6 @@
AUX gnome-weather-41.0-fix-meson-0.61-build.patch 706 BLAKE2B 9023904ae76060fe81992bcf2c5185241335c9eb79941f92e27c5b645fe467e7b69774fddcfcb9698ed4388c65816927d377786b331bd94672f730ecf8ca5823 SHA512 365e7119ccc3d7bf50675f9870558c835da1d893f4d366f54beb73aa64d6f3cb3a7165a0b0e33bdd5f39b6eb33a98d7058487efd1f009cec30869bd65bdfeaea
DIST gnome-weather-41.0.tar.xz 943500 BLAKE2B a349360f001bc8a3246227fcdad51bdb115db382650ead36e9768c002f0d7892296610320bf90bb569915c72c48492002268f8aa049055ebc687dc08052d6170 SHA512 f625a83ecfffe1ad58aa268b6ab3009504f839f3d56e52c642bc23ee32c0b51638888de17a1b4bc0990b2fd6718a7266fe5cd79230594a06ae58a816308b2b99
+DIST gnome-weather-42.0.tar.xz 233552 BLAKE2B 64cdefbcdc93359518b4e08564eafc3235d7b2ab92d69d79b558c5d4f5ce03425d87fb8e7e351165d00983eab5807ebc05aa7c0eb604a618d135afb66170c8ff SHA512 10471a32adc148fad393e03098396a3cfccc75d1cd18985cdd2c287927213aeb493f2878ea986e1d3a3af4b1d3f439afcdb96833d849bbd5fbe7aebb1d1992e6
EBUILD gnome-weather-41.0.ebuild 1438 BLAKE2B 8d9d61fba786d3a290ab7f32ee524dc10f915fe052310600a59af893f231d5431f98f35b1816f8653ae5c7aaa16e66962116cbc0a6c0ad57abcc98385dc2ab89 SHA512 48488d4616a23d69ac6ea37c84c360509341183b65cbedf5471bc62c87b985af5569269c213f7368b71e90b3afa41977ff2a1db5d4a47368f5e8b13c948c060c
+EBUILD gnome-weather-42.0.ebuild 1385 BLAKE2B d356d9a73c0dabefd19231ca7c505678dfc1a5226a5322b1f8dce9c040b80e97f319629bf5ab6aebe3792e4ecf1e0d67c5d0dadb24426670a1540da0af6d25d4 SHA512 2bca241744fc08a0ae8c8236b1e5187a309c1b0b5dfdbd57213ea9c87ea776582fa5fe0465e7052e4f86f3aeaf8ad325469d416c39a5b4f0841aa03c2e922196
MISC metadata.xml 250 BLAKE2B 8f7f0fe023d43e380e7861e897e6afcb5de4baefb42ea9c65a57dfc0d204c6f787a99295141832e732ebb08be218da56ba77e2dd9639e4e3aabf718ce4db1d0c SHA512 2684e772dd6d83e4b49f08f2ba22d8a0a753e7b46863489eff1b5d1f2f147ad80ffd93245ca405ac4c747249bc1b754454ec9865fe16da70f9b257051e105fd8
diff --git a/gnome-extra/gnome-weather/gnome-weather-42.0.ebuild b/gnome-extra/gnome-weather/gnome-weather-42.0.ebuild
new file mode 100644
index 000000000000..82a788f80ae0
--- /dev/null
+++ b/gnome-extra/gnome-weather/gnome-weather-42.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A weather application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.56:=
+ >=gui-libs/gtk-4.5:4
+ >=dev-libs/gjs-1.71.0
+ >=app-misc/geoclue-2.3.1:2.0
+ >=gui-libs/libadwaita-1.0.0:1=
+ >=dev-libs/libgweather-3.90.0:4=
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+# Tests have a lot of issues, starting with reliance on a system installation,
+# accessing the network and other intermittent failures with network-sandbox disabled
+# https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
+# test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
+# With 3.34, this is now behind a dogtail option we can pass (and have data validation)
+
+src_configure() {
+ meson_src_configure -Dprofile=default -Ddogtail=false
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}