summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-weather
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /gnome-extra/gnome-weather
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'gnome-extra/gnome-weather')
-rw-r--r--gnome-extra/gnome-weather/Manifest2
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-3.36.1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/gnome-extra/gnome-weather/Manifest b/gnome-extra/gnome-weather/Manifest
index faeaa01f3b2a..bcdb9d2bfc3a 100644
--- a/gnome-extra/gnome-weather/Manifest
+++ b/gnome-extra/gnome-weather/Manifest
@@ -1,3 +1,5 @@
DIST gnome-weather-3.34.2.tar.xz 5957924 BLAKE2B d6257fb7654862f5fbd308bc202ce8b8f98a0b6baa5a150a1729962fa05812a93cd19f9462d83fec3d076b896be1d8166e360811c84bc3ab4f13b212b48884e5 SHA512 9e9ebbdf795b175f7640ad684da7642a3e6a07da4d95c520a8673f0001aac119c5ebe22737d254a75b878f503910265fa0fdf05b1c219063f6b4dfc6bc8d1633
+DIST gnome-weather-3.36.1.tar.xz 5959192 BLAKE2B f0745506ffd2b72a1a5fe0783fe04c563691840fdf2150e7850cd331ba2027b1d1fcbbb4565830d05c7e39e62a2c94e4c87443ce5786cc70f3ebabcc66e97eec SHA512 c3d4b0e7258c0bfbc1ab2b5695d601fe79326e1bed856734edc309c612f1cc0adc9cfd6b4afb4ad3069b864c807ca0b21a60f89feba68f1dacac58d0fd2221be
EBUILD gnome-weather-3.34.2.ebuild 1333 BLAKE2B 8a40937674d245eaff3481b2e76fe9e1d0d176b5b6c23067a8bad7bc90a4f6b3027862176649051e814b128986e7680d24ed48f417635728fc4359b35a715379 SHA512 4fdace50c44207d79068e06da79d7e88c436cf364eb044798e1872d58cd41748e6fc07b3687bece07b98a182bfa74e93c089deab0effa0015386d319325f23a7
+EBUILD gnome-weather-3.36.1.ebuild 1335 BLAKE2B f2213bda169d47563c1998d28c107229aaffdfedbe3126a34c181db83f40a06f0ecb30ad3184ce4df3dcf4f1326116ceefca14d0565138bcc81f180c02f6c788 SHA512 beb6cdc6253ce24bfe9a479cfd47ecc277ed011e8ce98ca0c0aedfa1f89db672eeb2167ac0ba114ea74bca5fc18654957fdb113ef4254f2ae3795dbfd107cd90
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/gnome-extra/gnome-weather/gnome-weather-3.36.1.ebuild b/gnome-extra/gnome-weather/gnome-weather-3.36.1.ebuild
new file mode 100644
index 000000000000..fa585992b10f
--- /dev/null
+++ b/gnome-extra/gnome-weather/gnome-weather-3.36.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A weather application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.56:=
+ >=x11-libs/gtk+-3.20:3
+ >=dev-libs/gjs-1.50
+ >=app-misc/geoclue-2.3.1:2.0
+ >=dev-libs/libgweather-3.28:=
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# Tests have a lot of issues, starting with reliance on a system installation,
+# accessing the network and other intermittent failures with network-sandbox disabled
+# https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
+# test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
+# With 3.34, this is now behind a dogtail option we can pass (and have data validation)
+
+src_configure() {
+ meson_src_configure -Dprofile=default -Ddogtail=false
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}